View Issue Details

IDProjectCategoryView StatusLast Update
0012327ScribusImport / Exportpublic2014-06-18 20:30
Reporterchristoph_s Assigned Tofschmid  
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Product Version1.5.0svn 
Target VersionFixed in Version1.5.0svn 
Summary0012327: Update the relevant plug-in interfaces and the plug-ins to use librevenge
Descriptionlibrevenge simplifies the adoption of import libraries provided by the Document Liberation Project, as well as building for those who regularly update trunk svn. Moreover, all of the latest versions of the libraries require librevenge, and the coming libpagemaker will do so as well.
TagsNo tags attached.
Patch

Activities

cbradney

2014-05-27 18:59

administrator   ~0031938

Dumb bug.. this is a "fix A" instead of about 10 bugs for fixing a,b,c,d.. etc. Dont submit stuff like this. librevenge is not tested and using it not required, although it might prove to be so.

christoph_s

2014-05-27 20:05

administrator   ~0031940

This isn't "dumb" at all. All current versions of libvisio, libmspub etc. require librevenge. librevenge replaces libwpd, libwpd and all the other dependencies that were required to even compile libvisio etc., which in return are required to build a fully functional 1.5svn.

jghali

2014-05-27 20:34

administrator   ~0031941

>> librevenge replaces libwpd, libwpd and all the other dependencies that were required to even compile libvisio

No, librevenge defines interfaces for importers, it does not replaces those libs. Libwpd and libwpg have had new releases at the same time as librevenge 0.0.0 and they now depend on librevenge.

Anyway even if we'd had to rewrite code, rewriting code because of a 0.0.0 release would be foolish and premature.

christoph_s

2014-05-28 11:36

administrator   ~0031943

I'm keeping this one closed, but please note that we likely won't be able to update to new versions of the import libraries without librevenge.

As to libwpd and libwpg, I remember Fridrich and Franz talking at LGM about how certain features that are necessary for all importers had been introduced in the most recent library, without any system or plan. Hence the reliance on libwpd and libwpg. This may have changed with librevenge.

Regarding the version number, Fridrich was pretty clear that Document Liberation is *extremely* conservative with version numbers, and that 0.0.0 is what other projects would use for a 1.0 release. Morevover, David Tardon has recently announced (including scribus-dev) that they intend to keep the 0.0.0 API stable for at least 2 years.

ale

2014-05-31 12:29

manager   ~0031963

that's why indesign is much better than scribus!
they're at version 6 and we at an embarassing 1.4... like the software we used to have in the eighties...

fschmid

2014-06-14 16:16

administrator   ~0032165

Started work on porting the relevant importers to use librevenge.

fschmid

2014-06-14 16:49

administrator   ~0032166

Importer for MS Publisher is ported

fschmid

2014-06-15 09:42

administrator   ~0032171

Importer for MS Visio is ported

fschmid

2014-06-18 08:45

administrator   ~0032227

All plugins are now ported to librevenge.

christoph_s

2014-06-18 20:30

administrator   ~0032232

Tested, fixed. Thanks!

Issue History

Date Modified Username Field Change
2014-05-27 06:19 christoph_s New Issue
2014-05-27 06:19 christoph_s Status new => assigned
2014-05-27 06:19 christoph_s Assigned To => fschmid
2014-05-27 18:59 cbradney Note Added: 0031938
2014-05-27 18:59 cbradney Status assigned => resolved
2014-05-27 18:59 cbradney Resolution open => won't fix
2014-05-27 18:59 cbradney Status resolved => closed
2014-05-27 20:05 christoph_s Note Added: 0031940
2014-05-27 20:05 christoph_s Status closed => assigned
2014-05-27 20:34 jghali Note Added: 0031941
2014-05-27 20:42 jghali Target Version 1.5.0 =>
2014-05-27 20:56 cbradney Status assigned => closed
2014-05-27 20:56 cbradney Assigned To fschmid =>
2014-05-28 11:36 christoph_s Note Added: 0031943
2014-05-31 12:29 ale Note Added: 0031963
2014-06-14 16:16 fschmid Assigned To => fschmid
2014-06-14 16:16 fschmid Status closed => new
2014-06-14 16:16 fschmid Note Added: 0032165
2014-06-14 16:17 fschmid Status new => assigned
2014-06-14 16:49 fschmid Note Added: 0032166
2014-06-15 09:42 fschmid Note Added: 0032171
2014-06-18 08:45 fschmid Note Added: 0032227
2014-06-18 08:45 fschmid Status assigned => resolved
2014-06-18 08:45 fschmid Fixed in Version => 1.5.0svn
2014-06-18 08:45 fschmid Resolution won't fix => fixed
2014-06-18 20:30 christoph_s Note Added: 0032232
2014-06-18 20:30 christoph_s Status resolved => closed