View Issue Details

IDProjectCategoryView StatusLast Update
0012392ScribusUndo/Redopublic2020-12-09 17:06
ReporterFirasH Assigned Tojghali  
PriorityhighSeveritycrashReproducibilityrandom
Status closedResolutionfixed 
Platformx86_64OSopenSUSEOS Version13.1
Product Version1.5.0svn 
Target Version1.5.5Fixed in Version1.5.7.svn 
Summary0012392: Undo/Redo crashes Scribus deleting a Group + Item
DescriptionUndo/Redo crashes Scribus deleting a Group + Item.

(second part of 0012358)
Steps To Reproduce0) Create a new document
1) Insert 2 items
2) Insert another item
3) Group the items added in Step 1
4) Move the Group
5) Select the Group and the item added in Step 2
6) Delete the selected items
7) Undo to Initial State
8) Redo

Scribus crashes due to Signal 11
Additional InformationScribus 1.5.0.svn (19220)

Screencast: https://www.dropbox.com/s/3x7jcwvb0nznpab/12358%282%29.mp4 [^]



Program received signal SIGSEGV, Segmentation fault.
0x00000000008c4bc9 in QString::isEmpty (this=0x2556258)
    at /home/.../Qt/5.3/gcc_64/include/QtCore/qstring.h:794
794 { return d->size == 0; }
(gdb) bt
#0 0x00000000008c4bc9 in QString::isEmpty (this=0x2556258)
    at /home/.../Qt/5.3/gcc_64/include/QtCore/qstring.h:794
0000001 0x0000000000cbd7df in ScPage::restorePageItemDeletion (this=0x2f70020, state=
    0x314b530, isUndo=false) at /home/.../Scribus/scribus/scpage.cpp:370
0000002 0x0000000000cbb705 in ScPage::restore (this=0x2f70020, state=0x314b530,
    isUndo=false) at /home/.../Scribus/scribus/scpage.cpp:214
0000003 0x0000000000e73aa8 in UndoState::redo (this=0x314b530)
    at /home/.../Scribus/scribus/undostate.cpp:79
0000004 0x0000000000e644ef in TransactionState::redo (this=0x2f5bb40)
    at /home/.../Scribus/scribus/undomanager.cpp:829
0000005 0x0000000000e72e01 in UndoStack::redo (this=0x315d590, steps=1, objectId=-1)
    at /home/.../Scribus/scribus/undostack.cpp:121
0000006 0x0000000000e62e6d in UndoManager::redo (this=0x1c5d420, steps=1)
    at /home/.../Scribus/scribus/undomanager.cpp:567
0000007 0x000000000081bbdf in UndoManager::qt_static_metacall (_o=0x1c5d420,
    _c=QMetaObject::InvokeMetaMethod, _id=13, _a=0x7fffffffc380)
    at /home/.../Scribus/build/scribus/moc_undomanager.cpp:144
0000008 0x00007ffff768a681 in QMetaObject::activate(QObject*, int, int, void**) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Core.so.5
0000009 0x000000000081b840 in UndoPalette::redo (this=0x295f9d0, _t1=1)
    at /home/.../Scribus/build/scribus/moc_undogui.cpp:528
0000010 0x0000000000e5e889 in UndoPalette::redoClicked (this=0x295f9d0)
    at /home/.../Scribus/scribus/undogui.cpp:432
0000011 0x000000000081b3d3 in UndoPalette::qt_static_metacall (_o=0x295f9d0,
    _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0x7fffffffc580)
    at /home/.../Scribus/build/scribus/moc_undogui.cpp:435
0000012 0x00007ffff768a681 in QMetaObject::activate(QObject*, int, int, void**) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Core.so.5
0000013 0x00007ffff701ee22 in QAbstractButton::clicked(bool) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Widgets.so.5
0000014 0x00007ffff6d8d053 in ?? ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Widgets.so.5
0000015 0x00007ffff6d8d96a in ?? ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Widgets.so.5
0000016 0x00007ffff6d8db74 in QAbstractButton::mouseReleaseEvent(QMouseEvent*) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Widgets.so.5
0000017 0x00007ffff6cc5a87 in QWidget::event(QEvent*) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Widgets.so.5
0000018 0x00007ffff6c8d764 in QApplicationPrivate::notify_helper(QObject*, QEvent*) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Widgets.so.5
0000019 0x00007ffff6c90bb6 in QApplication::notify(QObject*, QEvent*) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Widgets.so.5
0000020 0x00007ffff7658dd4 in QCoreApplication::notifyInternal(QObject*, QEvent*) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Core.so.5
0000021 0x00007ffff6c8fcca in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Widgets.so.5
0000022 0x00007ffff6ce5cb7 in ?? ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Widgets.so.5
0000023 0x00007ffff6ce8808 in ?? ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Widgets.so.5
0000024 0x00007ffff6c8d764 in QApplicationPrivate::notify_helper(QObject*, QEvent*) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Widgets.so.5
0000025 0x00007ffff6c90de6 in QApplication::notify(QObject*, QEvent*) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Widgets.so.5
0000026 0x00007ffff7658dd4 in QCoreApplication::notifyInternal(QObject*, QEvent*) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Core.so.5
0000027 0x00007ffff650d457 in QGuiApplicationPrivate::processMouseEvent(QWindowSystemInterfacePrivate::MouseEvent*) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Gui.so.5
0000028 0x00007ffff650de95 in QGuiApplicationPrivate::processWindowSystemEvent(QWindowSystemInterfacePrivate::WindowSystemEvent*) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Gui.so.5
0000029 0x00007ffff64f3148 in QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Gui.so.5
0000030 0x00007fffe3360630 in ?? ()
   from /home/.../Qt/5.3/gcc_64/plugins/platforms/libqxcb.so
0000031 0x00007fffeb7d8316 in g_main_context_dispatch ()
   from /usr/lib64/libglib-2.0.so.0
0000032 0x00007fffeb7d8668 in ?? ()
   from /usr/lib64/libglib-2.0.so.0
0000033 0x00007fffeb7d870c in g_main_context_iteration ()
   from /usr/lib64/libglib-2.0.so.0
0000034 0x00007ffff76b3444 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Core.so.5
0000035 0x00007ffff7656feb in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Core.so.5
0000036 0x00007ffff765beb5 in QCoreApplication::exec() ()
   from /home/.../Qt/5.3/gcc_64/lib/libQt5Core.so.5
0000037 0x00000000012d7f60 in mainApp (argc=1, argv=0x7fffffffdd38)
    at /home/.../Scribus/scribus/main_nix.cpp:86
0000038 0x00000000012d7ef0 in main (argc=1, argv=0x7fffffffdd38)
    at /home/.../Scribus/scribus/main_nix.cpp:54
TagsNo tags attached.
PatchNo

Relationships

related to 0016350 resolvedjghali Undo of ungrouped grouped object crashes Scribus 
related to 0011224 feedbackfschmid Undoing ungrouping leads to strange results 
child of 0012500 acknowledged Metabug: Undo/Redo (1.5.x.svn) 

Activities

jghali

2014-06-14 11:39

administrator   ~0032159

Cannot reproduce here.

FirasH

2014-06-14 11:44

developer   ~0032160

In the last step (8) I wrote only "Redo", but it is necessary to Redo 6 times.
The crash is randomly reproducible.

JLuc

2014-06-15 14:06

developer   ~0032179

What is it precisely what you call "initial state" in step 7) : is it step 0 or step 5) ??

FirasH

2014-06-15 14:23

developer   ~0032182

JLuc: http://imgur.com/YCVYefZ

Kunda

2014-07-03 15:08

updater   ~0032439

Reproduced on OSX 10.8.5 1.5svn r19309

jghali

2020-11-24 18:43

administrator   ~0048485

Fixed together with issue 0016350.

FirasH

2020-12-09 17:06

developer   ~0048540

Fix confirmed in 1.5.7.svn

Issue History

Date Modified Username Field Change
2014-06-14 09:43 FirasH New Issue
2014-06-14 11:39 jghali Note Added: 0032159
2014-06-14 11:44 FirasH Note Added: 0032160
2014-06-15 14:06 JLuc Note Added: 0032179
2014-06-15 14:23 FirasH Note Added: 0032182
2014-07-03 15:08 Kunda Note Added: 0032439
2014-07-03 15:08 Kunda Status new => confirmed
2014-07-03 15:08 Kunda Target Version => 1.5.0
2014-07-09 01:18 FirasH Relationship added child of 0012500
2014-09-11 02:47 Kunda Severity crash => block
2015-05-19 20:56 cbradney Target Version 1.5.0 => 1.5.1
2016-01-23 17:16 cbradney Target Version 1.5.1 => 1.5.3
2016-05-16 17:26 Kunda Relationship added related to 0011224
2016-05-16 17:33 Kunda Patch => No
2016-05-16 17:33 Kunda Priority normal => high
2016-05-16 17:33 Kunda Severity block => crash
2016-12-08 21:30 Kunda Target Version 1.5.3 => 1.5.5
2020-11-24 18:43 jghali Relationship added related to 0016350
2020-11-24 18:43 jghali Assigned To => jghali
2020-11-24 18:43 jghali Status confirmed => resolved
2020-11-24 18:43 jghali Resolution open => fixed
2020-11-24 18:43 jghali Fixed in Version => 1.5.7.svn
2020-11-24 18:43 jghali Note Added: 0048485
2020-12-09 17:06 FirasH Status resolved => closed
2020-12-09 17:06 FirasH Note Added: 0048540