View Issue Details

IDProjectCategoryView StatusLast Update
0001241ScribusStory Editor / Text Framespublic2005-04-26 07:55
Reporterlkaratzas Assigned To 
PrioritynormalSeveritytextReproducibilityalways
Status closedResolutionfixed 
Platformi686OSLinuxOS VersionSuSE 9.0
Product Version1.2.2cvs 
Target VersionFixed in Version1.2.2cvs 
Summary0001241: Pasting or adding text into the Story Editor
DescriptionWhen you paste something into the story editor, the program rehyphenates the whole text (which in my case is always big). It occured to me to check whether this happens when you simply add a word in the text. Well, it doesn't rehyphenate, but it does something even worse. It jumbles the letters of the added word transposing them with letters from the word that follow it. This happens no matter what you do. My text is Greek and I don't know if the same thing happens when you write something in English.
As a matter of fact, when you add a word directly into the text box, nothing funny happens.
TagsNo tags attached.
Patch

Relationships

related to 0001593 closedfschmid Paste in Story Editor leads to "reformating" in Storyeditor 
related to 0003828 acknowledged Metabug: Hyphenation 

Activities

plinnell

2005-04-17 14:52

viewer   ~0004279

Could you supply a sample doc to test this. I think it is fixed in current CVS.

lkaratzas

2005-04-22 12:25

reporter   ~0004362

I checked the issues against 1.3CVS with the following results:

1. Adding something no longer causes the following words to appear jumbled.
2. Pasting into the Story Editor works fast and has the intended results. However. as soon as you paste the text, there is some rolling up and down in the text window which is too fast for me to be able to tell what exactly happens.

Both issues I had reported should be considered resolved, I think. This rolling up and down is in fact a different issue which does not seriously affect the work at hand.

plinnell

2005-04-22 12:28

viewer   ~0004363

Can you test with 1.2.2cvs, as well. This is because we are trying to fix and remaining bugs in 1.2.2 before releasing. Thanks for the report on 1.3.0cvs.

lkaratzas

2005-04-23 14:43

reporter   ~0004382

The test with 1.2.2 gives identical results. No problem except for the speed. English texts perform much better than the Greek and Russian ones I tried both versions on. With an English text of approximately 150000 chars, pasting took an appreciable number of seconds, while the same operation with smaller Greek and Russian texts took minutes. The jerkiness however has disappeared completely in both versions.
One more remark: in 1.2.2 cut and paste shortcuts work in the text box but not in the story editor while in 1.3cvs they do not work at all in either. "Select all" does though!
Both versions were downloaded today.
I hope this helps.

plinnell

2005-04-23 15:14

viewer   ~0004384

Thanks for testing and the feedback. That is invaluable as I have no Greek texts to test with.

Issue History

Date Modified Username Field Change
2004-10-22 11:36 lkaratzas New Issue
2005-01-26 10:46 plinnell Relationship added related to 0001593
2005-04-17 14:52 plinnell Note Added: 0004279
2005-04-17 14:52 plinnell Status new => feedback
2005-04-17 14:52 plinnell Product Version 1.2.1cvs => 1.2.2cvs
2005-04-22 12:25 lkaratzas Note Added: 0004362
2005-04-22 12:28 plinnell Note Added: 0004363
2005-04-23 14:43 lkaratzas Note Added: 0004382
2005-04-23 15:14 plinnell Note Added: 0004384
2005-04-23 15:14 plinnell Status feedback => resolved
2005-04-23 15:14 plinnell Resolution open => fixed
2005-04-23 15:15 plinnell Fixed in Version => 1.2.2cvs
2005-04-26 07:55 plinnell Status resolved => closed
2006-05-16 22:14 christoph_s Relationship added related to 0003828
2015-09-17 20:08 Kunda Category Story Editor / Text Frames => Story Ed/Txt Frames
2015-09-17 20:12 Kunda Category Story Ed/Txt Frames => Story Editor / Text Frames