View Issue Details

IDProjectCategoryView StatusLast Update
0012471ScribusImport / Exportpublic2014-07-24 05:00
ReporterJLuc Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionduplicate 
Product Version1.5.0svn 
Target VersionFixed in Version 
Summary0012471: Scribus should warn when it cant import a SVG truthfully
DescriptionSince scribus doesnt understand filters in SVG, it should warn when a SVG is incorrectly imported.

Go on importing as is now is OK as long as the user is warned.

(It could also possibly explain which ar the not-understood filters or create a log file.)
TagsNo tags attached.
Patch

Relationships

duplicate of 0005941 acknowledged Add optional (geeky) extender for listing of unsupported SVG features that had been discarded on import 
related to 0010841 new importing an SVG with rasterized effects does not work 

Activities

JLuc

2014-07-03 20:29

developer   ~0032458

To avoid popups it could be a warning sign - somehow stored in the imported objects, i dont know how - as the one that appear for low resolution images

But (jghali) : amof there is such a warning but its hiden because in current state that warning would be displayed allmost all the time.

Kunda

2014-07-04 03:09

manager   ~0032460

Last edited: 2014-07-04 03:09

View 2 revisions

Perhaps there should be a note in the import dialog that explains or offers a place for people to link to learn more about the details?

EDIT: Lets create a wiki page with the details of the problem.

ale

2014-07-04 06:09

manager   ~0032469

since the previous approach (always warn when there could have been a difference) did not work (it was always shown), we could try do it the other way round: warning when specific unsupported features are found.

in this case a popup is fine to me.

Kunda

2014-07-04 12:47

manager   ~0032471

ale, agreed.
Should we also propose this to become an additional Preflight Verifier check ?

ale

2014-07-22 07:14

manager   ~0032911

no, the preflight verifier cannot see missing shapes from SVGs... since they have not been imported :-)

ale

2014-07-22 07:15

manager   ~0032912

ps.: but we could have a dialog similar to the preflight verifier that shows problems happing while you're working on the document...

Kunda

2014-07-22 11:36

manager   ~0032916

Valdimir brought this up in 0005941:0026807

JLuc

2014-07-22 17:06

updater   ~0032918

I dont know why this report has the "commentaire" status but it think it can be considered as a duplicate of 0005941

jghali

2014-07-22 21:05

administrator   ~0032923

It's indeed a duplicate.

Issue History

Date Modified Username Field Change
2014-07-03 20:00 JLuc New Issue
2014-07-03 20:29 JLuc Note Added: 0032458
2014-07-04 03:09 Kunda Note Added: 0032460
2014-07-04 03:09 Kunda Note Edited: 0032460 View Revisions
2014-07-04 06:09 ale Note Added: 0032469
2014-07-04 12:47 Kunda Note Added: 0032471
2014-07-04 12:47 Kunda Status new => feedback
2014-07-22 00:52 Kunda Relationship added related to 0005941
2014-07-22 07:14 ale Note Added: 0032911
2014-07-22 07:15 ale Note Added: 0032912
2014-07-22 11:36 Kunda Note Added: 0032916
2014-07-22 17:06 JLuc Note Added: 0032918
2014-07-22 17:06 JLuc Status feedback => new
2014-07-22 21:05 jghali Note Added: 0032923
2014-07-22 21:05 jghali Relationship replaced duplicate of 0005941
2014-07-22 21:05 jghali Status new => resolved
2014-07-22 21:05 jghali Resolution open => duplicate
2014-07-22 21:05 jghali Assigned To => jghali
2014-07-22 21:05 jghali Status resolved => closed
2014-07-24 05:00 Kunda Relationship added related to 0010841