View Issue Details

IDProjectCategoryView StatusLast Update
0012573ScribusUser Interfacepublic2016-11-01 21:24
ReporterFirasH Assigned ToFirasH  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.5.0svn 
Target Version1.5.3Fixed in Version1.5.3.svn 
Summary0012573: Double Sided corresponds to Double Page?
DescriptionDouble Sided corresponds to Double Page? See attached screenshot.
Steps To ReproduceA) Open the dialog to create a New Document
B) Open: File > Preferences > Document Setup > Layout
Additional Information1.5.0.svn (19381)
Tagsdiscussion
PatchYes

Relationships

child of 0013906 acknowledged Metabug: UI enhancement proposals (1.5.x.svn) 

Activities

FirasH

2014-07-29 19:53

developer  

12573.png (110,854 bytes)
12573.png (110,854 bytes)

Kunda

2014-07-30 20:47

updater   ~0033095

Thanks Firash.
Agree that there should be uniformity. I vote for 'Double Sided'.

Kunda

2014-08-01 20:37

updater   ~0033132

Last edited: 2014-08-01 20:42

View 2 revisions

Did a search through the code via github.
https://github.com/scribusproject/scribus/search?p=1&q=%22Double+Sided%22&type=Code
and
https://github.com/scribusproject/scribus/search?q=%22Double+Page%22&type=Code

Seems like if we were going to change something it would be "Double Sided" since "Double Page" is referenced way more times.

EDIT: I'll submit a patch if the Devs acknowledge and give a hat tip toward the solution they want.

owencook

2014-08-07 20:56

reporter   ~0033203

Double sided refers to printing
Double page refers to layout

Two different things, suggest you close this one

FirasH

2014-08-08 00:40

developer  

12573-2.png (64,991 bytes)
12573-2.png (64,991 bytes)

FirasH

2014-08-08 00:42

developer   ~0033204

In Windows > Arrange Pages it is listed as "Double Sided". The option has the same result of changing Layout in Document Setup.

Kunda

2014-08-25 16:23

updater   ~0033348

Discussion on ML: http://lists.scribus.net/pipermail/scribus-dev/2014-August/002336.html

FirasH

2014-12-14 00:29

developer  

12573-Patch.diff (547 bytes)
Index: scribus/ui/prefs_documentsetupbase.ui
===================================================================
--- scribus/ui/prefs_documentsetupbase.ui	(revisione 19663)
+++ scribus/ui/prefs_documentsetupbase.ui	(copia locale)
@@ -246,7 +246,7 @@
		  <item row="1" column="1">
		   <widget class="QRadioButton" name="doublePageRadioButton">
			<property name="text">
-            <string>Double Page</string>
+            <string>Double Sided</string>
			</property>
			<attribute name="buttonGroup">
			 <string>pageLayoutButtonGroup</string>
12573-Patch.diff (547 bytes)

JLuc

2015-04-02 22:16

developer   ~0034810

All pages have 2 sides, havent they ? avoid "double sided".

"Facing page" is more clear about the document and is used in various DTP softwares

Kunda

2016-05-12 13:48

updater   ~0040971

punting to christoph

christoph_s

2016-05-13 05:38

administrator   ~0040990

I agree with JLuc: it should be "Facing Pages". I'm transferring this to cbradney, because he's in charge of the Prefs/DocSetup dialogues.

FirasH

2016-10-31 21:44

developer   ~0042253

As there are no more 3 and 4 fold layout option "Facing Pages" sounds right to me.

FirasH

2016-10-31 22:53

developer   ~0042254

Here is a patch to replace "Double Pages" to "Facing Pages".

12573-PatchV2.diff (3,768 bytes)

diff --git a/scribus/commonstrings.cpp b/scribus/commonstrings.cpp
--- a/scribus/commonstrings.cpp
+++ b/scribus/commonstrings.cpp
@@ -331,11 +331,11 @@
 	CommonStrings::trCustomPageSize = tr( "Custom", "CommonStrings, custom page size" );
 
 	CommonStrings::pageSet1    = "Single Page";
-	CommonStrings::pageSet2    = "Double Sided";
+	CommonStrings::pageSet2    = "Facing Pages";
 	CommonStrings::pageSet3    = "3-Fold";
 	CommonStrings::pageSet4    = "4-Fold";
 	CommonStrings::trPageSet1  = tr( "Single Page" );
-	CommonStrings::trPageSet2  = tr( "Double Sided" );
+	CommonStrings::trPageSet2  = tr( "Facing Pages" );
 	CommonStrings::trPageSet3  = tr( "3-Fold" );
 	CommonStrings::trPageSet4  = tr( "4-Fold" );
 
diff --git a/scribus/pageitem.h b/scribus/pageitem.h
--- a/scribus/pageitem.h
+++ b/scribus/pageitem.h
@@ -1298,7 +1298,7 @@
 	int CompressionMethodIndex;
 	bool OverrideCompressionQuality;
 	int CompressionQualityIndex;
-	bool imageIsAvailable; ///< Flag to hiold image file availability
+	bool imageIsAvailable; ///< Flag to hold image file availability
 	int OrigW;
 	int OrigH;
 	double BBoxX; ///< Bounding Box-X
diff --git a/scribus/ui/prefs_documentsetupbase.ui b/scribus/ui/prefs_documentsetupbase.ui
--- a/scribus/ui/prefs_documentsetupbase.ui
+++ b/scribus/ui/prefs_documentsetupbase.ui
@@ -244,7 +244,7 @@
          <item row="1" column="1">
           <widget class="QRadioButton" name="doublePageRadioButton">
            <property name="text">
-            <string>Double Page</string>
+            <string>Facing Pages</string>
            </property>
            <attribute name="buttonGroup">
             <string notr="true">pageLayoutButtonGroup</string>
diff --git a/scribus/ui/prefs_pdfexportbase.ui b/scribus/ui/prefs_pdfexportbase.ui
--- a/scribus/ui/prefs_pdfexportbase.ui
+++ b/scribus/ui/prefs_pdfexportbase.ui
@@ -1601,7 +1601,7 @@
        <item>
         <widget class="QRadioButton" name="doublePageLeftRadioButton">
          <property name="text">
-          <string>Double Page Left</string>
+          <string>Facing Pages Left</string>
          </property>
         </widget>
        </item>
@@ -1608,7 +1608,7 @@
        <item>
         <widget class="QRadioButton" name="doublePageRightRadioButton">
          <property name="text">
-          <string>Double Page Right</string>
+          <string>Facing Pages Right</string>
          </property>
         </widget>
        </item>
diff --git a/scribus/ui/tabpdfoptions.ui b/scribus/ui/tabpdfoptions.ui
--- a/scribus/ui/tabpdfoptions.ui
+++ b/scribus/ui/tabpdfoptions.ui
@@ -988,7 +988,7 @@
             <item>
              <widget class="QRadioButton" name="doublePageLeft">
               <property name="text">
-               <string>Double Page Left</string>
+               <string>Facing Pages Left</string>
               </property>
              </widget>
             </item>
@@ -995,7 +995,7 @@
             <item>
              <widget class="QRadioButton" name="doublePageRight">
               <property name="text">
-               <string>Double Page Right</string>
+               <string>Facing Pages Right</string>
               </property>
              </widget>
             </item>
diff --git a/scribus/plugins/scriptplugin/cmddoc.h b/scribus/plugins/scriptplugin/cmddoc.h
--- a/scribus/plugins/scriptplugin/cmddoc.h
+++ b/scribus/plugins/scriptplugin/cmddoc.h
@@ -36,7 +36,7 @@
 UNIT_PICAS, UNIT_POINTS.\n\
 \n\
 pagesType = One of the predefined constants PAGE_n. PAGE_1 is single page,\n\
-PAGE_2 is for double sided documents, PAGE_3 is for 3 pages fold and\n\
+PAGE_2 is for facing pages documents, PAGE_3 is for 3 pages fold and\n\
 PAGE_4 is 4-fold.\n\
 \n\
 firstPageOrder = What is position of first page in the document.\n\
12573-PatchV2.diff (3,768 bytes)

FirasH

2016-11-01 21:24

developer   ~0042287

Thanks cbradney!
Fixed in 1.5.3.svn (21491).

Issue History

Date Modified Username Field Change
2014-07-29 19:49 FirasH New Issue
2014-07-29 19:53 FirasH File Added: 12573.png
2014-07-30 20:47 Kunda Note Added: 0033095
2014-07-30 20:47 Kunda Status new => feedback
2014-08-01 20:37 Kunda Note Added: 0033132
2014-08-01 20:42 Kunda Note Edited: 0033132 View Revisions
2014-08-07 20:56 owencook Note Added: 0033203
2014-08-08 00:40 FirasH File Added: 12573-2.png
2014-08-08 00:42 FirasH Note Added: 0033204
2014-08-08 00:42 FirasH Status feedback => new
2014-08-25 16:23 Kunda Note Added: 0033348
2014-12-14 00:29 FirasH File Added: 12573-Patch.diff
2014-12-14 00:29 FirasH Patch => Yes
2015-04-02 22:16 JLuc Note Added: 0034810
2016-04-03 10:47 FirasH Relationship added child of 0013906
2016-04-04 01:15 Kunda Tag Attached: discussion
2016-05-12 13:48 Kunda Assigned To => christoph_s
2016-05-12 13:48 Kunda Status new => assigned
2016-05-12 13:48 Kunda Note Added: 0040971
2016-05-13 05:38 christoph_s Note Added: 0040990
2016-05-13 05:38 christoph_s Assigned To christoph_s => cbradney
2016-05-13 13:23 Kunda Target Version => 1.6 milestone
2016-10-31 21:44 FirasH Note Added: 0042253
2016-10-31 21:46 FirasH Target Version 1.6 milestone => 1.5.3
2016-10-31 22:53 FirasH File Added: 12573-PatchV2.diff
2016-10-31 22:53 FirasH Note Added: 0042254
2016-11-01 21:00 cbradney Assigned To cbradney => FirasH
2016-11-01 21:00 cbradney Status assigned => resolved
2016-11-01 21:00 cbradney Resolution open => fixed
2016-11-01 21:00 cbradney Fixed in Version => 1.5.3.svn
2016-11-01 21:24 FirasH Status resolved => closed
2016-11-01 21:24 FirasH Note Added: 0042287