View Issue Details

IDProjectCategoryView StatusLast Update
0013154ScribusOS-Win32public2015-09-12 13:10
Reporterrmroppert Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformPCOSWin7OS VersionWin7 Pro SP1 de
Product Version1.4.5 
Target VersionFixed in Version1.4.6.svn 
Summary0013154: Error message during the startup of scribus
DescriptionAfter the installation of Scribus 1.4.5 (and also 1.5.0) i got the error message (german):
"Der Prozedureinsprungpunkt "_crtCreateSymbolicLinkW" wurde in der DLL "MSVCR110.dll" nicht gefunden"

or in english
"The procedure entry point __crtCreateSymbolicLinkW could not be located in the dynamic link library MSVCR110.dll"
Steps To ReproduceThis happens always during startup until you install the correct c++ library (see below).
Additional InformationSolution:
"Visual C++ Redistributable for Visual Studio 2012" have to be installed. Doing this, all works fine.

Link: Visual C++ version:
https://www.microsoft.com/en-us/download/details.aspx?id=30679

It must be this version of c++, a newer versions does not work.

TagsNo tags attached.
PatchNo

Activities

jghali

2015-06-19 22:27

administrator   ~0035453

This is weird as I have tested the x64 installers on clean Windows 7 systems and they work without problem. The provided link does not even correspond to the msvc runtime version I have installed on my machine which is v11.0.51106.1.

jghali

2015-06-20 13:22

administrator   ~0035463

I did an additional test of 1.4.5 and 1.5.0 installers in a clean virtual machine of a german Windows 7 SP1 system. Both version could execute without problem after installation.

jghali

2015-06-23 21:30

administrator   ~0035491

Next release will have updated Visual C++ runtimes. The root cause of the issue looks rather like a broken Visual C++ runtime setup however.

Kunda

2015-09-12 13:10

manager   ~0036198

Closing

Issue History

Date Modified Username Field Change
2015-06-19 18:40 rmroppert New Issue
2015-06-19 22:27 jghali Note Added: 0035453
2015-06-20 02:24 Kunda Category Releases => OS-Win32
2015-06-20 13:22 jghali Note Added: 0035463
2015-06-23 21:30 jghali Note Added: 0035491
2015-06-23 21:30 jghali Status new => resolved
2015-06-23 21:30 jghali Fixed in Version => 1.4.6.svn
2015-06-23 21:30 jghali Resolution open => fixed
2015-06-23 21:30 jghali Assigned To => jghali
2015-09-12 13:10 Kunda Note Added: 0036198
2015-09-12 13:10 Kunda Status resolved => closed