View Issue Details

IDProjectCategoryView StatusLast Update
0013208ScribusGeneralpublic2015-07-06 21:20
Reporterbughunter Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
PlatformLinuxOSUbuntuOS Version14.04 LTS
Product Version 
Target VersionFixed in Version 
Summary0013208: Import features only imports 1 page of .sla document properly on Scribus 1.4.2
DescriptionWhenever I use the feature Page --> Import in Scribus, only the first page of my target document gets imported. Pages 2 and up only have empty text frames imported. The document I am trying to import was saved using the same version of Scribus and has an extension of .sla.
Steps To Reproduce1. Have any Scribus non-blank .sla document with more than 1 page ready
2. Create a blank document of the same type (e.g. single page, double-sided, etc). Use the same dimensions. It does not matter if "automatic text frames" is checked; the import will still fail.
3. On the blank document, go to Pages --> Import. Choose the non-blank multipage .sla document. Under the "Pages" box, type a page range (e.g. 1-100). Click Import.
4. If Scribus prompts you, agree to let it create more pages.
5. Wait while Scribus imports
6. When Scribus is done, note that only page 1 has been imported properly. Pages 2 and upward will appear blank. Upon closer inspection, it will be clear that the text frames from the source document WERE imported, but their contents were not imported properly. Only page 1's text frame and contents will have been imported properly.
TagsNo tags attached.
PatchNo

Relationships

duplicate of 0008056 assignedale [WIP PATCH] Import pages with linked text frames breaks the links 

Activities

jghali

2015-07-06 21:20

administrator   ~0035672

This is a duplicate of issue 0008056. You currently have to recreate links between text frames.

Issue History

Date Modified Username Field Change
2015-07-06 21:05 bughunter New Issue
2015-07-06 21:20 jghali Note Added: 0035672
2015-07-06 21:20 jghali Relationship added duplicate of 0008056
2015-07-06 21:20 jghali Status new => resolved
2015-07-06 21:20 jghali Resolution open => duplicate
2015-07-06 21:20 jghali Assigned To => jghali
2015-07-06 21:20 jghali Status resolved => closed