View Issue Details

IDProjectCategoryView StatusLast Update
0013217ScribusPDFpublic2015-09-26 11:51
Reporterjhmtv Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityrandom
Status closedResolutionfixed 
PlatformMacOSMacOSXOS Version10.10.3
Product Version1.5.0 
Target Version1.5.1Fixed in Version1.5.1svn 
Summary0013217: large group incorrectly clipped on PDF output
DescriptionSometimes, in this case, a rectangle (may be happen with other objects too) is not exported with the correct width to the PDF. Image export works well. I had to add extra width to the rectangle to get a correctly exported PDF.

Steps To Reproducesee attached file, and export to PDF (I use 1.5 or x4).

It is a large layout (188 cm x 63 cm + 0,5 cm surrounding bleeds). If you export to PDF and open it in PDF Reader zoom in and you see some white space left at the right edge. Exporting it to an image is using the full design area.

Additional InformationIf you make the lines 20mm larger than required you can workaround the bug, but this makes a wrong WYSIWYG design view on screen is in this case.
TagsNo tags attached.
PatchNo

Relationships

related to 0012508 closedjghali Grouped Items might be wrongly exported/cropped to PDF 
child of 0003812 acknowledged Metabug: Grouped objects 

Activities

jhmtv

2015-07-09 07:19

reporter  

fail.sla (15,229 bytes)

Kunda

2015-07-09 12:31

manager   ~0035706

Thanks for the report.
jhmtv, can you write a step by step way to reproduce the bug ?

cbradney

2015-07-14 17:37

administrator   ~0035778

Also notice page size is 1800.7 x 630.7 vs 1800x630 in the doc.

jhmtv

2015-07-15 09:56

reporter   ~0035791

Right, there are different size in "Document setting", "Master page" and "Page" but fixing them to fit are not fixing the problem. The problem is related to the group. If I unwrap it, it looks okay, but if I wrap the rectangles inside a group the output is not using full page width.

Kunda

2015-07-20 18:03

manager   ~0035848

jhmtv, can you reproduce after the fix ?

Kunda

2015-09-14 18:20

manager   ~0036228

Fixed by jghali in r20261. Thanks!
Closing issue

Issue History

Date Modified Username Field Change
2015-07-09 07:19 jhmtv New Issue
2015-07-09 07:19 jhmtv File Added: fail.sla
2015-07-09 12:31 Kunda Note Added: 0035706
2015-07-14 15:34 jghali Target Version => 1.5.1
2015-07-14 17:37 cbradney Note Added: 0035778
2015-07-14 17:37 cbradney Assigned To => cbradney
2015-07-14 17:37 cbradney Status new => confirmed
2015-07-14 17:37 cbradney Assigned To cbradney =>
2015-07-15 09:56 jhmtv Note Added: 0035791
2015-07-18 15:09 jghali Summary Rectangle width not correctly exported to PDF => large group incorrectly clipped on PDF output
2015-07-18 15:10 jghali Status confirmed => resolved
2015-07-18 15:10 jghali Fixed in Version => 1.5.1svn
2015-07-18 15:10 jghali Resolution open => fixed
2015-07-18 15:10 jghali Assigned To => jghali
2015-07-18 22:28 FirasH Relationship added related to 0012508
2015-07-20 18:03 Kunda Note Added: 0035848
2015-07-22 15:25 Kunda Relationship added child of 0003812
2015-09-14 18:20 Kunda Note Added: 0036228
2015-09-14 18:20 Kunda Status resolved => closed