View Issue Details

IDProjectCategoryView StatusLast Update
0001328ScribusImport / Exportpublic2004-12-15 00:21
Reporterph0101 Assigned Tofschmid  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformGnu/Linux i686OSFedora Core RawhideOS Version3+
Product Version1.2CVS 
Target VersionFixed in Version1.2.1cvs 
Summary0001328: SVG Import: incorrect units
DescriptionSVG import results in my rectangle being the wrong size.
The SVG spec says numbers without units are measured in
"User Units" = 1 px.

1 pt = 1.25 px

Scribus loads the rectangle with width and height in
pt as default unit. Everything is the wrong size,
and my document is cut off at the end of the page.
Steps To Reproduce1. Create a rectangle in inkscape
2. Import the document in scribus
Additional InformationImageMagick's convert utility behaves the same way - it
cuts off the document at the end of the page, because
it's the wrong size.
TagsNo tags attached.
Patch

Relationships

child of 0002931 acknowledged Metabug: SVG 

Activities

cbradney

2004-11-19 23:09

administrator   ~0002910

As far as we know, Inkscape actually implements this incorrectly.

ph0101

2004-11-20 00:53

reporter   ~0002912

How so. The SVG spec over here:
http://www.w3.org/TR/2001/REC-SVG-20010904/coords.html#Units

says things without explicit units are measured in "user units" = 1 px = 1.25 pt.

A rectangle of width 195 with no unit marked in the xml file
appears to be of width 195pt in scribus, when it seems like
it should be 195/1.25 to display properly.

Please explain, or if I'm wrong advise what the problem is
with inkscape so I can file a bug over there.

ph0101

2004-11-20 00:55

reporter   ~0002913

I'm sorry that should have been 1pt = 1.25 px,
not 1px = 1.25 pt. It still looks wrong.

cbradney

2004-11-20 00:55

administrator   ~0002914

Didnt disagree with the issue.. but yes, they know theres an issue in Inkscape.

ph0101

2004-11-20 06:37

reporter   ~0002915

I don't understand. Scribus fails to interpret the SVG file generated with inkscape, because it doesn't follow SVG specs that say measurements
without units should be interpreted in px, not in pt. You don't disagree with the issue yet you're telling me the bug is in inkscape...doesn't make any sense to me.

Issue History

Date Modified Username Field Change
2004-11-18 22:04 ph0101 New Issue
2004-11-19 23:09 cbradney Note Added: 0002910
2004-11-20 00:53 ph0101 Note Added: 0002912
2004-11-20 00:55 ph0101 Note Added: 0002913
2004-11-20 00:55 cbradney Note Added: 0002914
2004-11-20 06:37 ph0101 Note Added: 0002915
2004-12-08 18:44 cbradney Status new => assigned
2004-12-08 18:44 cbradney Assigned To => fschmid
2004-12-10 21:53 fschmid Status assigned => resolved
2004-12-10 21:53 fschmid Fixed in Version => 1.2.1cvs
2004-12-10 21:53 fschmid Resolution open => fixed
2004-12-15 00:21 cbradney Status resolved => closed
2006-05-17 19:29 christoph_s Relationship added child of 0002931