View Issue Details

IDProjectCategoryView StatusLast Update
0013339ScribusUsabilitypublic2015-09-09 21:36
ReporterJLuc Assigned Tocbradney  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionwon't fix 
PlatformLinuxOSUbuntuOS Version14.04
Product Version1.5.0 
Target VersionFixed in Version 
Summary0013339: Confusing wordings for application settings and document settings
DescriptionApplication settings and document settings are same except the first are for the application and the 2nd are for a specific document. Some of the applications settings also exist for the document settings : the application settings are the default value of the document setting when it is created. THIS SHOULD APPEAR CLEARLY IN THE UI, SO THE USER UNDERSTANDS IT.

Alas, this is not clear : there is no explanation, no hint in these dialogs and instead of wording expressing this likeness, like for example "application settings" and "document settings", the wordings are totaly different and dont connect the 2 options together. In french, for example, the wordings are "Réglage du document" and "Preferences".

As a consequence many users dont understand and loose time trying to change application settings when they should change document settings. See for example a typical misunderstanding testimony in 0013336 : << It took me a very long amount of time (months!) to realize that ... the scratch space setting is not only present as a global preference, but also as a "per-document" preference (I was wondering why changing the scratch space dimensions in the preferences did not have any effect on the document I was working on),>>

How could that be made better ?

1) Add somewhere in the application's settings dialog a short explanation as "These settings are the default values when using scribus or when creating a new document. Some of these settings can be changed for a specific document in the 'document settings' "

2) Add somewhere in the document's settings dialog a short explanation as <<For a new document, these settings default to the value specified in the 'application's settings'>>

3) Use more obvious wordings for the labels of the menu entries, with both including a common word, so its obvious these 2 menu entries are connected together and so the user is invited to discover and understand the semantic of that connection.

For example in english : "Document's settings" and "Scribus settings" or even better "Default settings".

"Default settings" seems a good wording because scribus-settings relate both to the application use and to the all newly created documents settings, that can be changed later.

In french it could be : "Réglages du document" et "Réglages par défaut". (Instead of "Réglage" it could also be the more common "Options".)
TagsNo tags attached.
PatchNo

Activities

ale

2015-09-07 13:53

manager   ~0036160

what about putting the document settings under format as format > document?

iirc, in 1.5 there are already a few extra buttons in the preferences (apply to the current document) that make it at bit more clear that you're not seeing the current document's values (and the changes do not apply to it).

as so often, i agree that there is a real (and somehow urgent) problem... but i have the feeling that throwing textual warnings and descriptions at it is probably mostly not the best solution...

JLuc

2015-09-07 15:05

developer   ~0036162

also : It would make sense to have the document settings under the _Edit menu.

cbradney

2015-09-07 19:42

administrator   ~0036164

Edit is for Editing... File is related to the File. While I could accept that Edit might make sense, it also doesn't change the fact that the EN menu says Document Setup, which is pretty obvious.
The document requires almost all of the settings as are in Preferences.
You also need to take the translation side out of this - translators should not just be translating word for word, they need to add meaning for the language they translate to. So, consider the GUI in US English only, please.

JLuc

2015-09-07 20:40

developer   ~0036166

AFAIK and from what i can check reading your comment, english labels are "Document settings" and "Preferences". Isnt ? In such a case, my report applies : <<instead of wording expressing this likeness, like for example "application settings" and "document settings", the wordings are totaly different and dont connect the 2 options together.>> This is one reason why its difficult to understand what matters.

These 2 menu entries's wordings should be "connected together so the user is invited to discover and understand the semantic of that connection."
Examples :
- "Default settings" and "Document settings"
- "Scribus settings" and "Document settings"

Or it could be a single "Settings" entry, with 2 sub-menu entries :
- "Settings" > "Default behaviour"
- "Settings" > "Current document" (or it could be the name of the file here)
That would obviously connect the 2 together and shed light on their relationship.

As for the language, i dont mean that translation should be word for word !(?) It seems my (bad) english misled you. All the same, i have translated several books (from english to french) and know well what is a translation. Dont underestimate the power of words : when wordings in a menu are well choosen, user's understanding is much easier.

ale

2015-09-08 08:35

manager   ~0036167

jluc's latest propositions (a sub menu) makes sense, but has a bigger drawback: on os x the settings are in the "scribus" menu... which is the standard for os x but cannot apply on all other WMs

personally, i still like the way staroffice did (iirc) and, sadly, libreoffice does not anymore: file/Scribus > settings && format > document.
i just rediscovered that scribus does not have a "format" menu... and i wonder if there shouldn't be one.
as usual, i have the feeling that there should not be a "table" menu and split its entries between "insert > table" and "format > table".

the "format" menu could contain commands that make the properties palette visible and selects the matching tab; and the styles editor. (and probably some other entries that are currently placed in a very "technical" (and not semantic) way under "edit", "extras" and "windows".

ok, i stop here... i will continue my thoughts in a different place and then -- maybe -- make a proposal for changes.

cbradney

2015-09-09 21:36

administrator   ~0036182

I'm closing this. It doesn't add value to keep this around.

English has:
Preferences and Document Setup. Both are perfectly clear what they do.

Issue History

Date Modified Username Field Change
2015-09-06 19:22 JLuc New Issue
2015-09-06 19:24 JLuc Description Updated View Revisions
2015-09-06 19:25 JLuc Description Updated View Revisions
2015-09-06 19:28 JLuc Description Updated View Revisions
2015-09-06 19:28 JLuc Description Updated View Revisions
2015-09-07 13:53 ale Note Added: 0036160
2015-09-07 15:05 JLuc Note Added: 0036162
2015-09-07 18:35 JLuc Description Updated View Revisions
2015-09-07 19:42 cbradney Note Added: 0036164
2015-09-07 20:40 JLuc Note Added: 0036166
2015-09-08 08:35 ale Note Added: 0036167
2015-09-09 21:36 cbradney Note Added: 0036182
2015-09-09 21:36 cbradney Status new => closed
2015-09-09 21:36 cbradney Assigned To => cbradney
2015-09-09 21:36 cbradney Resolution open => won't fix