View Issue Details

IDProjectCategoryView StatusLast Update
0013505ScribusGraphics / Image Framespublic2015-11-08 17:51
Reporterjlpoole Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionduplicate 
Product Version1.5.1svn 
Target VersionFixed in Version 
Summary0013505: Enhancement: PFILE Attribute for PAGEOBJECT be Configurable to Relative or Abosolute Path
DescriptionCurrently, when an image file is imported, the file's location is saved in the PAGEOBJECT element's PFILE attribute. The value is a relative path, e.g. in Windows "../../../Temp/EVE0001.TIF".

It would be desirable to have the PFILE value be an absolute path, e.g. in Windows "D:/Temp/EVE0001.TIF", instead of a relative path, configurable by an option. Having absolute paths allows the Scribus file to be copied and moved about within the file system, e.g. having copies for testing, without breaking links.

The default setting for the option could be relative to preserve current functionality, but switchable to absolute paths.
Additional InformationI suppose the result could be achieved using a Plugin that visits each object and changes relative to absolute paths.
TagsNo tags attached.
PatchNo

Relationships

duplicate of 0006518 acknowledged [patch] Better control for your paths 

Activities

Kunda

2015-11-06 16:35

manager   ~0037283

Wouldn't this be an issue if you wanted to share your SLA via 'collect for output' ?

jlpoole

2015-11-06 16:38

reporter   ~0037284

I do not know what you mean by "share your SLA via "collect for output"'?

jlpoole

2015-11-06 16:39

reporter   ~0037285

Also, I was thinking Python Script, not Plugin when I used the words Plugin in the initial comment.

Kunda

2015-11-07 00:13

manager   ~0037290

OP, when you want to open this SLA on another machine with a different directory tree ? How will an absolute path help in any way ?

jlpoole

2015-11-07 00:24

reporter   ~0037291

Last edited: 2015-11-07 00:25

View 2 revisions

Here's my strategy:

All images are stored on a Linux server ("image server"), they are exposed on the Windows machine through a mount to P:

So I have my Scribus file ("sla") import the images using absolute paths,
e.g. P:\music\brahms\sym1\2P4H\P1\EVE001.TIF. The sla file can be anywhere on my Windows system, e.g. D:\projects\brahms88.sla, or D:\Temp\brahms88.sla, and the images will always appear (provided Scribus does not convert absolute paths to relative paths).

Then I can have the same file, brahms88.sla, on a Linux box, say in /home/jlpoole/work/music/brahms/sym1/2P4H/brahms88.sla and I have in that same directory a soft link named "P:" which points to a mounted share /P which, in turn mounts to the image server. I can move my brahms88.sla around anywhere on the Linux tree, I just have to have in the directory where it exists a soft link "P:".

Under this scenario, my brahms88.sla file can be free to be placed anywhere on either operating system tree and my images will always resolve.

Kunda

2015-11-07 00:29

manager   ~0037293

Duplicate of 0006518
Closing in favor of duplicate issue

jlpoole

2015-11-08 16:31

reporter   ~0037322

Last edited: 2015-11-08 16:31

View 2 revisions

I fixed this and uploaded a diff file in related bug 0006518. This is the first time I have contributed to the project and do not know the procedure to having the fix evaluated and considered. Is there anything else I should do?

jghali

2015-11-08 17:51

administrator   ~0037323

Please post all your remarks to 0006518. This issue is a duplicate of 0006518 and must not be reopened.

Issue History

Date Modified Username Field Change
2015-11-06 14:47 jlpoole New Issue
2015-11-06 16:35 Kunda Note Added: 0037283
2015-11-06 16:38 jlpoole Note Added: 0037284
2015-11-06 16:39 jlpoole Note Added: 0037285
2015-11-07 00:13 Kunda Note Added: 0037290
2015-11-07 00:17 Kunda Relationship added duplicate of 0006518
2015-11-07 00:24 jlpoole Note Added: 0037291
2015-11-07 00:25 jlpoole Note Edited: 0037291 View Revisions
2015-11-07 00:29 Kunda Note Added: 0037293
2015-11-07 00:29 Kunda Status new => closed
2015-11-07 00:29 Kunda Resolution open => duplicate
2015-11-08 16:31 jlpoole Note Added: 0037322
2015-11-08 16:31 jlpoole Status closed => feedback
2015-11-08 16:31 jlpoole Resolution duplicate => reopened
2015-11-08 16:31 jlpoole Note Edited: 0037322 View Revisions
2015-11-08 17:51 jghali Note Added: 0037323
2015-11-08 17:51 jghali Status feedback => resolved
2015-11-08 17:51 jghali Resolution reopened => duplicate
2015-11-08 17:51 jghali Assigned To => jghali
2015-11-08 17:51 jghali Status resolved => closed