View Issue Details

IDProjectCategoryView StatusLast Update
0013529ScribusOS-MacOSXpublic2016-03-18 21:37
ReporterKunda Assigned To 
PrioritylowSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
PlatformMacOSXOSYosemiteOS Version10.10.5
Product Version1.5.1 
Target Version1.5.2Fixed in Version1.5.2.svn 
Summary0013529: Feature Request: Ability to drop dirs/files in to Qt File dialog result: auto-find and highlight file
DescriptionThe outcome of a drag/drop from finder ideally would be that the specific directory/file would be found immediately in the Qt dialog box and highlighted to differentiate from other dir/files. Currently only the directory is found and the mouse shows the top of that directory each time. One must scroll to find the file they are looking for.

Steps To Reproduce1) Drag drop a file in to Qt File Dialog
Result top of directory is shown and the file is not highlighted
Additional InformationAs Craig mentions in 0012310:0031979
...I can't get it to scroll to the file though.
TagsQt5.6, upstream
PatchNo

Relationships

related to 0012310 closedcbradney Feature Request: Ability for OSX Finder to interact with Qt 'Open File' Dialog 
related to 0012068 confirmed [Qt5 BUG] Open file dialog doesnt remember bookmarked folders 
related to 0013748 confirmed Ability to move dirs/files in to Qt File dialog to other folders 

Activities

Kunda

2016-02-16 13:04

manager  

auto-scroll-to-file.gif (277,026 bytes)
auto-scroll-to-file.gif (277,026 bytes)

Kunda

2016-02-16 13:06

manager   ~0038785

So this bug is odd... for the longest time I could reproduce it all the time and now when I finally get around to update this ticket I can't always reproduce. For example, just uploaded a gif of the bug occurring. Initially the bug isn't reproduced but when I change directories then it shows up. It might be because the file I chose to use at first is an .sla file ?

Kunda

2016-03-18 21:37

manager   ~0039243

Finally fixed upstream in Qt5.6 !
Closing

Issue History

Date Modified Username Field Change
2015-11-13 17:04 Kunda New Issue
2015-11-13 17:04 Kunda Status new => assigned
2015-11-13 17:04 Kunda Assigned To => Kunda
2015-11-13 17:04 Kunda Issue generated from: 0012310
2015-11-13 17:04 Kunda Relationship added related to 0012310
2015-11-13 17:06 Kunda Assigned To Kunda =>
2015-11-13 17:06 Kunda Status assigned => confirmed
2015-11-13 17:07 Kunda Target Version => 1.6 milestone
2016-02-16 12:43 Kunda Additional Information Updated View Revisions
2016-02-16 13:04 Kunda File Added: auto-scroll-to-file.gif
2016-02-16 13:06 Kunda Note Added: 0038785
2016-02-16 13:07 Kunda Relationship added related to 0012068
2016-02-16 13:12 Kunda Issue cloned: 0013748
2016-02-16 13:12 Kunda Relationship added related to 0013748
2016-02-16 18:22 Kunda Tag Attached: upstream
2016-02-16 18:24 Kunda Tag Attached: Qt5.6
2016-03-18 21:37 Kunda Note Added: 0039243
2016-03-18 21:37 Kunda Status confirmed => closed
2016-03-18 21:37 Kunda Resolution open => fixed
2016-03-18 21:37 Kunda Fixed in Version => 1.5.2.svn
2016-03-18 21:37 Kunda Target Version 1.6 milestone => 1.5.2