View Issue Details

IDProjectCategoryView StatusLast Update
0013549ScribusUser Interfacepublic2017-04-13 16:25
ReporterFirasH Assigned ToFirasH  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.5.1svn 
Target VersionFixed in Version1.5.3.svn 
Summary0013549: Show correct icon for Spiral/Arc items in Outline Palette
DescriptionShow correct icon for Spiral/Arc items in Outline Palette.
Additional Information1.5.1.svn (20564)
Tagsdezso
PatchYes

Relationships

related to 0013700 closedPeterBenedek New icon set doesn't have some icons for the Character Palette dialog 
child of 0013906 acknowledged Metabug: UI enhancement proposals (1.5.x.svn) 

Activities

FirasH

2015-11-21 20:33

developer  

13549-Screen.png (18,019 bytes)
13549-Screen.png (18,019 bytes)

FirasH

2015-11-21 20:34

developer  

13549-Patch.diff (1,756 bytes)

diff --git a/scribus/ui/outlinepalette.cpp b/scribus/ui/outlinepalette.cpp
--- a/scribus/ui/outlinepalette.cpp
+++ b/scribus/ui/outlinepalette.cpp
@@ -457,6 +457,8 @@
 	textIcon = im->loadPixmap("22/insert-text-frame.png");
 	polylineIcon = im->loadPixmap("22/draw-path.png");
 	polygonIcon = im->loadPixmap("22/draw-polygon.png");
+	arcIcon = im->loadPixmap("22/draw-arc.png");
+	spiralIcon = im->loadPixmap("22/draw-spiral.png");
 	tableIcon = im->loadPixmap("22/insert-table.png");
 	groupIcon = im->loadPixmap("u_group.png");
 	buttonIcon = im->loadPixmap("22/insert-button.png");
@@ -834,12 +836,16 @@
 		item->setIcon( 0, lineIcon );
 		break;
 	case PageItem::Arc:
+		item->setIcon( 0, arcIcon );
+		break;
+	case PageItem::Spiral:
+		item->setIcon( 0, spiralIcon );
+		break;
 	case PageItem::Polygon:
 	case PageItem::RegularPolygon:
 		item->setIcon( 0, polygonIcon );
 		break;
 	case PageItem::PolyLine:
-	case PageItem::Spiral:
 		item->setIcon( 0, polylineIcon );
 		break;
 	case PageItem::PathText:
diff --git a/scribus/ui/outlinepalette.h b/scribus/ui/outlinepalette.h
--- a/scribus/ui/outlinepalette.h
+++ b/scribus/ui/outlinepalette.h
@@ -109,14 +109,15 @@
 	QLabel* filterLabel;
 	QLineEdit* filterEdit;
 	ScribusMainWindow* m_MainWindow;
+	QPixmap textIcon;
 	QPixmap imageIcon;
 	QPixmap latexIcon;
-	QPixmap textIcon;
+	QPixmap tableIcon;
 	QPixmap lineIcon;
 	QPixmap polygonIcon;
+	QPixmap arcIcon;
+	QPixmap spiralIcon;
 	QPixmap polylineIcon;
-	QPixmap groupIcon;
-	QPixmap tableIcon;
 	QPixmap buttonIcon;
 	QPixmap radiobuttonIcon;
 	QPixmap textFieldIcon;
@@ -126,6 +127,7 @@
 	QPixmap annotTextIcon;
 	QPixmap annotLinkIcon;
 	QPixmap annot3DIcon;
+	QPixmap groupIcon;
 	bool selectionTriggered;
 	ScribusDoc *currDoc;
 };
13549-Patch.diff (1,756 bytes)

jghali

2015-11-22 00:05

administrator   ~0037581

At that point, the patch does not work so well, not because it is faulty, but because the 1.5.1 icon theme is incomplete : the 22/draw-arc.png and 22/draw-spiral.png files are available, but the images they contain are fully transparent.

FirasH

2015-11-25 12:16

developer   ~0037672

Ok, we will wait till 1.5.1 theme is mostly completed.

Kunda

2016-04-03 21:27

updater   ~0039733

we need to ping dezso

jghali

2017-04-13 11:53

administrator   ~0043753

The adequate icons being now available in 1.5.1 icon set, I committed the patch. Thanks!

FirasH

2017-04-13 16:25

developer   ~0043761

Thanks jghali!
Committed in 1.5.3.svn (21889).

Issue History

Date Modified Username Field Change
2015-11-21 20:33 FirasH New Issue
2015-11-21 20:33 FirasH File Added: 13549-Screen.png
2015-11-21 20:34 FirasH File Added: 13549-Patch.diff
2015-11-22 00:05 jghali Note Added: 0037581
2015-11-25 12:16 FirasH Note Added: 0037672
2016-01-31 22:41 FirasH Relationship added related to 0013700
2016-02-23 14:06 Kunda Tag Attached: dezso
2016-04-03 10:45 FirasH Relationship added child of 0013906
2016-04-03 21:27 Kunda Note Added: 0039733
2017-04-13 11:53 jghali Assigned To => FirasH
2017-04-13 11:53 jghali Status new => resolved
2017-04-13 11:53 jghali Resolution open => fixed
2017-04-13 11:53 jghali Fixed in Version => 1.5.3.svn
2017-04-13 11:53 jghali Note Added: 0043753
2017-04-13 16:25 FirasH Status resolved => closed
2017-04-13 16:25 FirasH Note Added: 0043761