View Issue Details

IDProjectCategoryView StatusLast Update
0013560ScribusStory Editor / Text Framespublic2016-06-23 15:08
ReporterFirasH Assigned Tojghali  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version1.5.1svn 
Target VersionFixed in Version1.5.3.svn 
Summary0013560: "Edit" in Marks Manager crashes Scribus with Variable Text marks
Description"Edit" in Marks Manager crashes Scribus with Variable Text marks.
Steps To Reproduce0) Create a new document
1) Insert a Text Frame
2) Double-click on the Text Frame to enable modeEdit
3) Go to: Insert > Marks > Variable Text > add any text > OK
4) Go to: Edit > Marks...
5) Select the Mark created in step 3
6) Click on "Edit"

Scribus crashes due to Signal 11
Additional Information1.5.1.svn (20577)
TagsNo tags attached.
PatchNo

Relationships

duplicate of 0014111 closedjghali Crash when trying to edit 'Variable Text' Mark 
child of 0012496 acknowledged Metabug: Marks & Footnotes & Weld (1.5.0.svn) 

Activities

Kunda

2015-12-05 01:11

manager  

bt.txt (4,164 bytes)
(lldb) bt
* thread #1: tid = 0xfd7c0, 0x00007fff7588ec80 libc++abi.dylib`vtable for __cxxabiv1::__si_class_type_info + 16, queue = 'com.apple.main-thread', stop reason = EXC_BAD_ACCESS (code=2, address=0x7fff7588ec80)
  * frame #0: 0x00007fff7588ec80 libc++abi.dylib`vtable for __cxxabiv1::__si_class_type_info + 16
    frame #1: 0x000000010243c7f0 QtWidgets`QComboBox::findData(QVariant const&, int, QFlags<Qt::MatchFlag>) const + 96
    frame #2: 0x00000001005b0f9f Scribus`QComboBox::findText(QString const&, QFlags<Qt::MatchFlag>) const + 47
    frame #3: 0x00000001005b4547 Scribus`MarkVariableText::setValues(QString, QString) + 145
    frame #4: 0x00000001003c8de3 Scribus`ScribusMainWindow::editMarkDlg(Mark*, PageItem_TextFrame*) + 633
    frame #5: 0x00000001005b30b8 Scribus`MarksManager::on_EditButton_clicked() + 58
    frame #6: 0x00000001000294f8 Scribus`MarksManager::qt_metacall(QMetaObject::Call, int, void**) + 80
    frame #7: 0x00000001037c86ef QtCore`QMetaObject::activate(QObject*, int, int, void**) + 2815
    frame #8: 0x00000001026cd5d0 QtWidgets`QAbstractButton::clicked(bool) + 64
    frame #9: 0x000000010242145a QtWidgets`QAbstractButtonPrivate::emitClicked() + 58
    frame #10: 0x00000001024212b8 QtWidgets`QAbstractButtonPrivate::click() + 264
    frame #11: 0x00000001024222ee QtWidgets`QAbstractButton::mouseReleaseEvent(QMouseEvent*) + 270
    frame #12: 0x0000000102379a5f QtWidgets`QWidget::event(QEvent*) + 1631
    frame #13: 0x000000010242203f QtWidgets`QAbstractButton::event(QEvent*) + 175
    frame #14: 0x000000010233b97b QtWidgets`QApplicationPrivate::notify_helper(QObject*, QEvent*) + 251
    frame #15: 0x000000010233f013 QtWidgets`QApplication::notify(QObject*, QEvent*) + 9011
    frame #16: 0x00000001037984f3 QtCore`QCoreApplication::notifyInternal(QObject*, QEvent*) + 115
    frame #17: 0x000000010233c30b QtWidgets`QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) + 971
    frame #18: 0x0000000102399ed9 QtWidgets`QWidgetWindow::handleMouseEvent(QMouseEvent*) + 1177
    frame #19: 0x00000001023990ef QtWidgets`QWidgetWindow::event(QEvent*) + 111
    frame #20: 0x000000010233b97b QtWidgets`QApplicationPrivate::notify_helper(QObject*, QEvent*) + 251
    frame #21: 0x000000010233e2de QtWidgets`QApplication::notify(QObject*, QEvent*) + 5630
    frame #22: 0x00000001037984f3 QtCore`QCoreApplication::notifyInternal(QObject*, QEvent*) + 115
    frame #23: 0x00000001029fc222 QtGui`QGuiApplicationPrivate::processMouseEvent(QWindowSystemInterfacePrivate::MouseEvent*) + 2434
    frame #24: 0x00000001029e8572 QtGui`QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) + 162
    frame #25: 0x0000000105ba5391 libqcocoa.dylib`QCocoaEventDispatcherPrivate::postedEventsSourceCallback(void*) + 33
    frame #26: 0x00007fff854f2a01 CoreFoundation`__CFRUNLOOP_IS_CALLING_OUT_TO_A_SOURCE0_PERFORM_FUNCTION__ + 17
    frame #27: 0x00007fff854e4b8d CoreFoundation`__CFRunLoopDoSources0 + 269
    frame #28: 0x00007fff854e41bf CoreFoundation`__CFRunLoopRun + 927
    frame #29: 0x00007fff854e3bd8 CoreFoundation`CFRunLoopRunSpecific + 296
    frame #30: 0x00007fff8fe2e56f HIToolbox`RunCurrentEventLoopInMode + 235
    frame #31: 0x00007fff8fe2e1ee HIToolbox`ReceiveNextEventCommon + 179
    frame #32: 0x00007fff8fe2e12b HIToolbox`_BlockUntilNextEventMatchingListInModeWithFilter + 71
    frame #33: 0x00007fff8970f8ab AppKit`_DPSNextEvent + 978
    frame #34: 0x00007fff8970ee58 AppKit`-[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 346
    frame #35: 0x00007fff89704af3 AppKit`-[NSApplication run] + 594
    frame #36: 0x0000000105ba42df libqcocoa.dylib`QCocoaEventDispatcher::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) + 2191
    frame #37: 0x0000000103795c1c QtCore`QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) + 412
    frame #38: 0x0000000103798a95 QtCore`QCoreApplication::exec() + 341
    frame #39: 0x00000001007dbfad Scribus`mainApp(int, char**) + 90
    frame #40: 0x00007fff8c7b05c9 libdyld.dylib`start + 1
    frame #41: 0x00007fff8c7b05c9 libdyld.dylib`start + 1
bt.txt (4,164 bytes)

Kunda

2015-12-05 01:12

manager   ~0037821

Confirmed on MacOS 10.10.5 1.5.1svn r20609
Added backtrace

Kunda

2016-05-25 04:07

manager  

mark-crash.gif (961,780 bytes)
mark-crash.gif (961,780 bytes)

Kunda

2016-05-25 04:07

manager   ~0041409

added gif

Kunda

2016-05-29 02:45

manager   ~0041506

Duplicate ticket 0014111 was fixed by jghali in r21359
For organization purposes, I'm closing this ticket as a dupe of 0014111

FirasH

2016-05-29 09:09

developer   ~0041527

Changing status to fixed as it has been reported before 0014111.

Issue History

Date Modified Username Field Change
2015-11-25 12:15 FirasH New Issue
2015-11-25 12:15 FirasH Relationship added child of 0012496
2015-12-05 01:11 Kunda File Added: bt.txt
2015-12-05 01:12 Kunda Note Added: 0037821
2015-12-05 01:12 Kunda Status new => confirmed
2015-12-24 12:57 Kunda Target Version => 1.5.1
2016-01-23 17:16 cbradney Target Version 1.5.1 => 1.5.3
2016-05-25 04:07 Kunda File Added: mark-crash.gif
2016-05-25 04:07 Kunda Note Added: 0041409
2016-05-29 01:13 Kunda Relationship added related to 0014111
2016-05-29 02:45 Kunda Note Added: 0041506
2016-05-29 02:45 Kunda Status confirmed => closed
2016-05-29 02:45 Kunda Resolution open => duplicate
2016-05-29 02:46 Kunda Target Version 1.5.3 =>
2016-05-29 02:46 Kunda Relationship replaced duplicate of 0014111
2016-05-29 09:08 FirasH Status closed => feedback
2016-05-29 09:08 FirasH Resolution duplicate => reopened
2016-05-29 09:09 FirasH Note Added: 0041527
2016-05-29 09:09 FirasH Status feedback => new
2016-05-29 09:09 FirasH Status new => closed
2016-05-29 09:09 FirasH Resolution reopened => fixed
2016-05-29 09:12 FirasH Assigned To => jghali
2016-05-29 09:12 FirasH Status closed => feedback
2016-05-29 09:12 FirasH Resolution fixed => reopened
2016-05-29 09:12 FirasH Status feedback => closed
2016-05-29 09:12 FirasH Resolution reopened => fixed
2016-05-29 09:12 FirasH Fixed in Version => 1.5.3.svn
2016-06-23 15:08 PeterBenedek Relationship added related to 0014176
2016-06-23 15:11 PeterBenedek Relationship deleted related to 0014176