View Issue Details

IDProjectCategoryView StatusLast Update
0013768ScribusUser Interfacepublic2016-04-26 22:34
ReporterLaser Assigned Toplinnell 
PrioritynormalSeveritytweakReproducibilityhave not tried
Status closedResolutionduplicate 
PlatformPCOSArchlinuxOS Versionuptodate
Product Version1.5.2.svn 
Target Version1.5.2 
Summary0013768: No icon in the menu for scribus (in Arch and xfce)
DescriptionThere is no Scribus-Icon beneath the Name in the menu anymore.
I don't know exactly when this happened, but it is in 1.4.6, 1.5.1 and 1.5.2 svn.
Additional InformationI have this issue with Archlinux and xfce.
A friend has it "for a longer time" also with Kubuntu (kde), also with 1.4.6 and 1.5.x.

If you set a link in the pkgbuild (Arch-typical) from /usr/share/scribus/1_5_0/icons/scribus.png to /usr/share/applications, you get the icon.
TagsNo tags attached.
PatchNo

Relationships

duplicate of 0012708 closedplinnell GNOME/KDE: Please install the supplied AppData file 
related to 0011696 closedplinnell Scribus does not show up when searched for in Gnome Shell 
related to 0013812 closedplinnell Scribus does not show up in any menus 

Activities

Laser

2016-02-24 10:47

reporter  

Menu.png (37,715 bytes)   
Menu.png (37,715 bytes)   

Kunda

2016-02-24 13:10

updater   ~0038874

is this a scribus issue or an arch linux issue ?

Laser

2016-02-24 13:13

reporter   ~0038876

Not Arch - a friend has the same issue with kubuntu as told (I researched a little^^).

Kunda

2016-03-09 15:54

updater   ~0039083

Is this deszo related?

Kunda

2016-03-09 18:42

updater   ~0039089

As stated by Laser the workaround is to:
set a link in the pkgbuild (Arch-typical) from /usr/share/scribus/1_5_0/icons/scribus.png to /usr/share/applications, you get the icon.

Kunda

2016-03-10 13:22

updater   ~0039098

Laser, please check r21076 without your workaround to confirm if fixed. Thanks!

Laser

2016-03-11 13:16

reporter   ~0039126

Fix confirmed!

Kunda

2016-03-11 13:54

updater   ~0039127

Thanks Laser :)
Does craig's fix apply to the 1.4.7svn ?

Laser

2016-03-11 14:10

reporter   ~0039130

Can't test.
I have 1.4.6 and 1.5.2 - installed revision r21076 and also 1.4.6 got the icon.
Also the icon is found in the application symbols when adding a new starter in the taskbar.
So it should work anywhere.

Laser

2016-03-11 14:55

reporter   ~0039131

My friend says, still no icon in Kubuntu 15.10 with r21076.
ppa from here: https://launchpad.net/~scribus/+archive/ubuntu/ppa

Kunda

2016-03-11 16:28

updater   ~0039132

changing status based on 0013768:0039131

Kunda

2016-03-24 14:30

updater   ~0039383

mapreri, anyone report something similar to 0013768:0039131 lately ?

Kunda

2016-03-24 15:39

updater   ~0039389

Laser, can you ask your buddy to retest with latest PPA and see if issue is still present?

Laser

2016-03-24 20:13

reporter   ~0039396

He updated today from the ppa - probably r21113, still no icon.

In Sabayon with kde 5.19.0 and Scribus 1.5.0-r1 there is an icon.

Kunda

2016-04-10 11:48

updater   ~0040005

devs, any idea?

plinnell

2016-04-25 01:08

viewer   ~0040454

It is related to 0011696 and 0012708

Kunda

2016-04-26 22:34

updater   ~0040523

Closing as a dupe of 0012708

Issue History

Date Modified Username Field Change
2016-02-24 10:47 Laser New Issue
2016-02-24 10:47 Laser File Added: Menu.png
2016-02-24 13:10 Kunda Note Added: 0038874
2016-02-24 13:13 Laser Note Added: 0038876
2016-03-09 15:54 Kunda Note Added: 0039083
2016-03-09 18:41 Kunda Target Version => 1.5.2
2016-03-09 18:41 Kunda Summary No icon in the menu => No icon in the menu for scribus (in Arch and xfce)
2016-03-09 18:42 Kunda Note Added: 0039089
2016-03-10 13:22 Kunda Note Added: 0039098
2016-03-11 13:16 Laser Note Added: 0039126
2016-03-11 13:54 Kunda Note Added: 0039127
2016-03-11 13:54 Kunda Status new => resolved
2016-03-11 13:54 Kunda Fixed in Version => 1.5.2
2016-03-11 13:54 Kunda Resolution open => fixed
2016-03-11 13:54 Kunda Assigned To => cbradney
2016-03-11 13:55 Kunda Fixed in Version 1.5.2 => 1.5.2.svn
2016-03-11 14:10 Laser Note Added: 0039130
2016-03-11 14:55 Laser Note Added: 0039131
2016-03-11 16:28 Kunda Note Added: 0039132
2016-03-11 16:28 Kunda Status resolved => feedback
2016-03-11 16:28 Kunda Resolution fixed => reopened
2016-03-15 03:01 Kunda Relationship added related to 0013812
2016-03-15 13:05 Kunda Relationship added related to 0011696
2016-03-24 14:30 Kunda Note Added: 0039383
2016-03-24 15:39 Kunda Note Added: 0039389
2016-03-24 20:13 Laser Note Added: 0039396
2016-03-24 20:13 Laser Status feedback => assigned
2016-04-10 11:48 Kunda Note Added: 0040005
2016-04-25 01:08 plinnell Note Added: 0040454
2016-04-25 01:08 plinnell Assigned To cbradney => plinnell
2016-04-25 01:12 Kunda Relationship added related to 0012708
2016-04-26 22:34 Kunda Note Added: 0040523
2016-04-26 22:34 Kunda Relationship replaced duplicate of 0012708
2016-04-26 22:34 Kunda Status assigned => closed
2016-04-26 22:34 Kunda Resolution reopened => duplicate
2016-04-26 22:34 Kunda Fixed in Version 1.5.2.svn =>