View Issue Details

IDProjectCategoryView StatusLast Update
0014189ScribusPDFpublic2017-12-20 20:58
Reportercis Assigned Tojghali  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
PlatformMicrosoftOSWindowsOS Version7
Product Version1.5.2 
Target VersionFixed in Version1.5.4.svn 
Summary0014189: Fonts can't be outlined when exporting PDF/X
DescriptionIf you want to export a file to PDF/X, you have no option for outlining the used fonts.
Steps To Reproduce1. Open any Scribus file
2. go to File -> Export
3. Choose "Save as pdf"
4. Choose PDF/X-3 on Tab General
5. Go to tab "Fonts"
TagsNo tags attached.
PatchNo

Activities

Laser

2016-06-27 22:57

reporter   ~0041736

Ehm, perhaps you should outline fonts before exporting?
Export only means to export the document as is.

ale

2016-06-28 08:54

manager   ~0041738

no laser, during export scribus can transform the documents font.

this is a common action.

since pdf/x-3 requires all fonts to be embedded, i fear that somebody wanted to disable the option not to embed the fonts and at the same time disable the legit wish to outline all fonts.

Laser

2016-06-28 10:48

reporter   ~0041739

My fault. I've been somewhere else :-(

cis

2016-06-28 13:18

reporter   ~0041740

That's ok, Laser.
@ ale, thanks for your comment.

This functionallity is not available since 1.5.1.. in 1.4.6 it worked perfectly

cis

2016-06-28 13:31

reporter   ~0041741

Is there a workaround?

jghali

2016-06-28 13:45

administrator   ~0041742

Last edited: 2016-06-28 13:47

View 2 revisions

>> in 1.4.6 it worked perfectly

In 1.4.6, fonts are usually converted to Type 3 fonts when "outline" is selected, so this is not real outlining. 1.5.1+ does real outlining so that exported PDF does not contain any fonts. Note: use of Type 3 fonts and outlining tend to make fonts bolder when printed.

cis

2016-06-29 15:15

reporter   ~0041744

@jghali, good to hear, but if it's not an available feature, it doesn't help.

dcpurton

2017-02-07 04:18

reporter   ~0043452

I'd also like to see this. It affects PDF/X1-a and PDF/X-4 as well.

mauder

2017-06-29 08:39

reporter   ~0044106

Because of issue 14290 (problems with some print providers when not outlining fonts) I'm interested too in combining PDF X-3 and outlining all fonts in PDF. I can't see any discrepance in allowing both an the same time. "pdf/x-3 requires all fonts to be embedded" only means that if there are fonts at all they have to be embedded. But when outlining, there are only graphic objects and no more fonts. So this should be working without problems with pdf x-3 (and actually does if I use older scribus versions from 1.5.3svn when this combination was still allowed)

So it is possible to reenable outlining in pdf x-3?

jghali

2017-06-29 09:09

administrator   ~0044107

>> older scribus versions from 1.5.3svn when this combination was still allowed

Older versions are performing outlining by generating Type 3 font subsets when possible. So this is not outlining as 1.5.3 does it where there won't be any font or text object in the output PDF at the end.

mauder

2017-06-29 09:47

reporter   ~0044108

>> 1.5.1+ does real outlining

I'm talking about 1.5.3svn from end of last year. So it should already do real outlining

PeterBenedek

2017-11-09 15:05

developer   ~0044630

Last edited: 2017-11-09 15:09

View 3 revisions

Tested r22218; Linux Mint 18

Great job. Works well (but I couldn't test the PDF file in printing house).

Issue History

Date Modified Username Field Change
2016-06-27 21:01 cis New Issue
2016-06-27 22:57 Laser Note Added: 0041736
2016-06-28 08:54 ale Note Added: 0041738
2016-06-28 10:48 Laser Note Added: 0041739
2016-06-28 13:18 cis Note Added: 0041740
2016-06-28 13:31 cis Note Added: 0041741
2016-06-28 13:45 jghali Note Added: 0041742
2016-06-28 13:47 jghali Note Edited: 0041742 View Revisions
2016-06-28 19:06 jghali Severity major => feature
2016-06-28 20:01 jghali Priority high => normal
2016-06-29 15:15 cis Note Added: 0041744
2017-02-07 04:18 dcpurton Note Added: 0043452
2017-06-29 08:39 mauder Note Added: 0044106
2017-06-29 09:09 jghali Note Added: 0044107
2017-06-29 09:47 mauder Note Added: 0044108
2017-11-09 11:42 jghali Steps to Reproduce Updated View Revisions
2017-11-09 11:42 jghali Summary Fonts can't be outlined when exporting PDF-X3 => Fonts can't be outlined when exporting PDF/X
2017-11-09 11:42 jghali Description Updated View Revisions
2017-11-09 11:42 jghali Steps to Reproduce Updated View Revisions
2017-11-09 11:51 jghali Assigned To => jghali
2017-11-09 11:51 jghali Status new => resolved
2017-11-09 11:51 jghali Resolution open => fixed
2017-11-09 11:51 jghali Fixed in Version => 1.5.4.svn
2017-11-09 15:05 PeterBenedek Note Added: 0044630
2017-11-09 15:06 PeterBenedek Note Edited: 0044630 View Revisions
2017-11-09 15:09 PeterBenedek Note Edited: 0044630 View Revisions
2017-12-20 20:58 cbradney Status resolved => closed