View Issue Details

IDProjectCategoryView StatusLast Update
0014666ScribusFontspublic2018-02-22 08:30
Reporterapastuszak Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
PlatformLinuxOSArch LinuxOS Versionn/a
Product Version1.5.2 
Target VersionFixed in Version 
Summary0014666: Using "Adjust Frame Height To Text" option causes contants of text frame to left justify
DescriptionIf a text box is created and then text is entered and either centered or right justified, the Adjust Frame Height To Text" option from the right click context menu will left justify the text in the box. Using the "resize-text.py" script from the wiki, which does the same function, causes the same issue. if you add 0.2 mm to the height of the text box, then the text will properly justify or center.
Steps To Reproduce1. Create text box
2. Type some text
3. Center it
4. Right click on text box and choose "Adjust Frame Height To Text"

Workaround is to go into properties and add 0.2mm to the Height of the text box and the contents will then center.
Tagstext frames
PatchNo

Relationships

related to 0015153 confirmed "Adjust Frame Height to Text" does not always work 

Activities

apastuszak

2017-03-10 04:07

reporter   ~0043551

Just did a little more testing. it seems this only affects the LAST line of a text box.

itchka

2017-03-10 10:51

reporter   ~0043552

Confirmed. Present in OpenMandriva Lx3 Scribus V1.5.2

jghali

2017-03-10 10:57

administrator   ~0043553

I cannot reproduce this in 1.5.3.svn. Could you provide a concrete example which triggers the issue in 1.5.2?

apastuszak

2017-03-10 12:57

reporter   ~0043557

The steps to reproduce will reproduce the issue every time. I can test 1.5.3svn and see if the issue is still there. Perhaps a commit has fixed it already.

jghali

2017-03-10 13:28

administrator   ~0043558

>> The steps to reproduce will reproduce the issue every time.

No, because I can't reproduce the issue either in 1.5.2 or in 1.5.3.svn. So a concrete example is needed.

apastuszak

2017-03-10 14:23

reporter   ~0043559

I can reproduce this issue on both Arch Linux x64 and Windows 10 64 bit using Scribus. All I need to do is:

1. Launch Scribus 1.5.2
2. Create a new document
3. Create a text box of any size
4. Type some text
5. Center the text
6. Right click on the text box and choose 'Adjust Frame Height To Text'
7. Text becomes left justified

For me, this is 100% reproducible on both Linux and Windows using just those steps above.

EDIT: I think I found the problem! You need to have a fixed line spacing instead of automatic line spacing.

jghali

2017-03-10 15:01

administrator   ~0043560

Well the fact is that 1.5.x is a development branch. As a consequence:
- we won't provide any fix specific to 1.5.2
- it is expected that bugs by checked with *latest* code before being submitted

With 1.5.3.svn, fixed lined spacing or not, I can't reproduce this issue. So as already requested several times, please provide sample which allows us to reproduce the issue. Or this issue gonna be closed as "unable to reproduce".

apastuszak

2017-03-10 15:36

reporter   ~0043561

Is there a 1.5.3svn installer for Windows? I'm more than willing to test with latest code if there is a way for me to install it.

Arch has an AUR package for svn, so I am covered there.

apastuszak

2017-03-10 15:37

reporter   ~0043562

Ignore me. I found it.

jghali

2017-03-11 14:16

administrator   ~0043567

So any result from tests with 1.5.3.svn? Any example to reproduce issue with 1.5.3.svn?

apastuszak

2017-03-11 15:24

reporter   ~0043568

Sorry for the delay. This specific issue is not reproducible on Linux. You can close this bug.

jghali

2017-03-11 16:48

administrator   ~0043569

Ok. Thanks for the information.

Issue History

Date Modified Username Field Change
2017-03-10 04:02 apastuszak New Issue
2017-03-10 04:02 apastuszak Tag Attached: text frames
2017-03-10 04:07 apastuszak Note Added: 0043551
2017-03-10 10:51 itchka Note Added: 0043552
2017-03-10 10:57 jghali Note Added: 0043553
2017-03-10 12:57 apastuszak Note Added: 0043557
2017-03-10 13:28 jghali Note Added: 0043558
2017-03-10 14:23 apastuszak Note Added: 0043559
2017-03-10 15:01 jghali Note Added: 0043560
2017-03-10 15:36 apastuszak Note Added: 0043561
2017-03-10 15:37 apastuszak Note Added: 0043562
2017-03-11 14:16 jghali Note Added: 0043567
2017-03-11 15:24 apastuszak Note Added: 0043568
2017-03-11 16:48 jghali Assigned To => jghali
2017-03-11 16:48 jghali Status new => resolved
2017-03-11 16:48 jghali Resolution open => unable to reproduce
2017-03-11 16:48 jghali Note Added: 0043569
2017-03-11 16:49 jghali Status resolved => closed
2018-02-22 08:30 PeterBenedek Relationship added related to 0015153