View Issue Details

IDProjectCategoryView StatusLast Update
0014832ScribusTypographypublic2017-05-29 20:07
Reportermiemismd Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
PlatformMacbook Pro (Retina)OSOS X El CapitanOS Version10.11.6
Product Version1.5.3 
Target VersionFixed in Version 
Summary0014832: Optical Margins (hanging punctuation) misses quotation marks on the left
DescriptionERROR:
Optical Margins (German: Optischer Randausgleich) also known as "hanging punctuation" does not work at all on leftside quotation marks.

FEATURE REQUEST:
Also, it would be nice, to have an option to choose, if a punctuation sign should be completely shifted to the side. So that the text is aligned, as if there was no quotation mark, and after the sign will just take place, next to the line (both, left and right – or again as chosen by the user).

RELATED ERRORS:
The following may be an error on his own, but it's somehow related, because I think the "Optical Margin" function should handle this, before the line breaks:
At some point the justified text breaks and creates huge holes instead of shrinking holes that have already been quite big (See the pictures).

Yet another error:
What is the purpose of the "reset button" in the Optical Margins menu? As it does not change the look or the selected option for me.

Steps To ReproduceJust select a text-frame, fill it with Sample Text and add some quotation marks at the sides.

In the Text Properties select "Optical Margin" and set it to "Both".
TagsNo tags attached.
PatchNo

Relationships

duplicate of 0010539 confirmed Optical margins, protrusion into the left margin doesn't work 

Activities

jghali

2017-05-29 18:16

administrator   ~0043962

Duplicate of issue 0010539

miemismd

2017-05-29 18:35

reporter   ~0043963

Hey,

thanks for linking my post to the duplicate – I was checking the "font"-category not knowing there is also a dedicated "typography" category - sorry for that.

But still (which is not mentioned in the title of my post) there ist the feature request for more control over the "optical margins"-function as well as the two other errors.

And I forgot to put the attachments there, which I would like to do now ;).

Thank you for the fast reaction.

miemismd

2017-05-29 18:36

reporter   ~0043964

Here are the two files – the only difference is that I added a quotation mark, hoping the optical margin will handle it.

screenshot.png (83,278 bytes)
screenshot.png (83,278 bytes)
screenshot-2.png (90,043 bytes)
screenshot-2.png (90,043 bytes)

jghali

2017-05-29 20:07

administrator   ~0043968

A few golden rules when using our bug tracker:
1) Before submitting any issue, search bug reports to know if the issue is not already known
2) Bugs and feature requests must be stored in different reports
3) Different bugs must be stored in different reports

"Reset button" in the Optical Margins menu does nothing currently as it's marked as TODO in the code.

Issue History

Date Modified Username Field Change
2017-05-29 17:59 miemismd New Issue
2017-05-29 18:14 jghali Priority high => normal
2017-05-29 18:14 jghali Category Fonts => Typography
2017-05-29 18:16 jghali Assigned To => jghali
2017-05-29 18:16 jghali Status new => resolved
2017-05-29 18:16 jghali Resolution open => duplicate
2017-05-29 18:16 jghali Note Added: 0043962
2017-05-29 18:16 jghali Relationship added duplicate of 0010539
2017-05-29 18:16 jghali Status resolved => closed
2017-05-29 18:35 miemismd Status closed => feedback
2017-05-29 18:35 miemismd Resolution duplicate => reopened
2017-05-29 18:35 miemismd Note Added: 0043963
2017-05-29 18:36 miemismd File Added: screenshot.png
2017-05-29 18:36 miemismd File Added: screenshot-2.png
2017-05-29 18:36 miemismd Note Added: 0043964
2017-05-29 18:36 miemismd Status feedback => assigned
2017-05-29 20:07 jghali Status assigned => resolved
2017-05-29 20:07 jghali Resolution reopened => duplicate
2017-05-29 20:07 jghali Note Added: 0043968
2017-05-29 20:07 jghali Status resolved => closed