View Issue Details

IDProjectCategoryView StatusLast Update
0014838ScribusBuild Systempublic2017-12-20 20:59
Reporterale Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version1.5.4.svn 
Summary0014838: explain why cmake requires openssl
Descriptionas noted in here

https://github.com/scribusproject/scribus/issues/89#issuecomment-305484509

there might issues with explicitly requiring openssl in

https://github.com/scribusproject/scribus/blob/master/cmake/modules/FindLIBPODOFO.cmake

is it really needed?
TagsNo tags attached.
PatchNo

Relationships

related to 0014850 closedcbradney wrong case for 'OpenSSL' causes libpodofo >= 0.9.5 to not be used 

Activities

cbradney

2017-06-05 08:49

administrator   ~0043997

Its really needed as podofo 0.9.5 doesn't successfully include all its indirectly required headers. Jean says they are working on a fix for 0.9.6.

ale

2017-06-05 09:21

manager   ~0043998

in such cases it would be really helpful if the "hack" would be commented with the reason for it...

ale

2017-06-05 09:45

manager   ~0044000

here a patch with the comment:

https://github.com/scribusproject/scribus/compare/master...aoloe:comment-libpodofo-opensslhack?expand=1#diff-2cce7c0d9b72ed613ab22f1248fae0a7

jghali

2017-06-05 12:43

administrator   ~0044002

>> Its really needed as podofo 0.9.5 doesn't successfully include all its indirectly required headers.

Not exactly. It is needed because 0.9.5 use openssl headers in its public headers. From that point on, we need to know openssl include dirs.

ale

2017-06-07 08:08

manager   ~0044006

i can only reiterate the need for a better documentation of things that are unusual...

concerning the specific issue, it has been solved by mattia's patch... (the ticket linked above)

Issue History

Date Modified Username Field Change
2017-06-01 13:48 ale New Issue
2017-06-04 22:29 jghali Category - => Build System
2017-06-04 22:39 jghali Summary cmake explicetly requires openssl => cmake explicitly requires openssl
2017-06-05 08:49 cbradney Note Added: 0043997
2017-06-05 09:21 ale Note Added: 0043998
2017-06-05 09:45 ale Note Added: 0044000
2017-06-05 12:43 jghali Note Added: 0044002
2017-06-06 09:51 ale Relationship added related to 0014850
2017-06-07 08:08 ale Note Added: 0044006
2017-06-10 13:18 jghali Summary cmake explicitly requires openssl => explain why cmake requires openssl
2017-06-10 13:19 jghali Assigned To => jghali
2017-06-10 13:19 jghali Status new => resolved
2017-06-10 13:19 jghali Resolution open => fixed
2017-06-10 13:19 jghali Fixed in Version => 1.5.4.svn
2017-12-20 20:59 cbradney Status resolved => closed