View Issue Details

IDProjectCategoryView StatusLast Update
0014902ScribusStory Editor / Text Framespublic2017-12-20 20:58
Reportereudoxos Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSUbuntuOS Version17.04
Product Version1.5.4.svn 
Target VersionFixed in Version1.5.4.svn 
Summary0014902: Unlink text frames cut texts incorrectly when more than 2 frames selected
DescriptionI created 3 basic frames with text and linked them, each of them containing text. When I select all of them and unlink, the last frame remains empty and the last-1 is overflown. When selecting frames inidivually from the end and unlinking, the result is correct. When selecting the middle one, I have to unlink it twice so that it gets unlinked completely (from the front and from the back??) but the result is again correct.

It seems that the loop in ScribusDoc::itemSelection_UnlinkTextFrameAndKeepText supposes the operation over selected items is order-independent, but somehow is not (did not look into details more).
Steps To Reproduce1. Create 3 text frames, link them
2. Fill them with random text so that all frames contain some text (see linked.sla, linked.png attached)
3. Select all frames at once and go Item > Text Frame Links > Unlink Text Frames and Cut Text. (see unlinked.sla, unlinked.png attached)
TagsNo tags attached.
PatchNo

Activities

eudoxos

2017-07-08 14:57

reporter  

linked.sla (16,009 bytes)
unlinked.sla (16,206 bytes)
linked.png (47,265 bytes)
linked.png (47,265 bytes)
unlinked.png (28,753 bytes)
unlinked.png (28,753 bytes)

PeterBenedek

2017-07-19 05:53

developer   ~0044185

Tested Linux Mint 18.2; r22115

I cannot reproduce animore. Works well.
Thank you.

Issue History

Date Modified Username Field Change
2017-07-08 14:57 eudoxos New Issue
2017-07-08 14:57 eudoxos File Added: linked.sla
2017-07-08 14:57 eudoxos File Added: unlinked.sla
2017-07-08 14:57 eudoxos File Added: linked.png
2017-07-08 14:57 eudoxos File Added: unlinked.png
2017-07-15 21:04 jghali Summary Unlink text frames cut texts incorrectly (last-1 overflow, last one empty) => Unlink text frames cut texts incorrectly when more than 2 frames selected
2017-07-15 21:05 jghali Assigned To => jghali
2017-07-15 21:05 jghali Status new => resolved
2017-07-15 21:05 jghali Resolution open => fixed
2017-07-15 21:05 jghali Fixed in Version => 1.5.4.svn
2017-07-19 05:53 PeterBenedek Note Added: 0044185
2017-12-20 20:58 cbradney Status resolved => closed