View Issue Details

IDProjectCategoryView StatusLast Update
0014908ScribusStylespublic2017-07-11 21:59
Reportertarren Assigned Tojghali  
Status closedResolutionduplicate 
OSwindows 7 
Product Version1.5.3 
Summary0014908: changing paragraph styles causes subscripts to be dropped to become normal text.
DescriptionI am testing Scribus for a journal and have set up paragraph styles for first and subsequent paragraphs. Only difference between styles is first line indent.
It was requested I change to first paragraph style throughout document and purely by chance noticed that CO2 was not subscripted.
Then checked the original file and 2 in CO2 was subscripted. I then changed styles while watching the text in question and noticed that the subscripted 2 changed to normal 2 in 1.5.2 and 1.5.3 whenever changing paragraph style.
This is very disconcerting as it is unexpected behaviour that can cause serious embarrassment if not spotted.
TagsNo tags attached.


duplicate of 0008772 new Applying style by Properties/Text/Styles clear text attributes 



2017-07-10 20:31

administrator   ~0044161

Please provide sample file.


2017-07-10 20:34

administrator   ~0044162

I did a simple test and i am unable to reproduce.


2017-07-11 19:26

reporter   ~0044164

Attached is the Scribus file which was recreated tonight to reproduce problem and it worked again.
Steps taken to reproduce:
1. source of text in Libreoffice with subscripts (snip1)
2. highlight, copy from Libreoffice and paste into Scribus. (snip 2). Note, scribus loses subscript whereas all other formatting seems to be retained.
3. CO2 resubscripted with subscript button in properties palette. (snip 3 and 4)
4. paragraph changed to second paragraph style (snip 5) and subscripts revert to non-subscripted.
Also tried saving file between step 3 and 4 but still lost subscript.
SubScriptExample.sla (24,373 bytes)
snip5.jpg (69,868 bytes)   
snip5.jpg (69,868 bytes)   
snip1.jpg (132,991 bytes)   
snip1.jpg (132,991 bytes)   
snip2.jpg (67,834 bytes)   
snip2.jpg (67,834 bytes)   
snip3.jpg (66,715 bytes)   
snip3.jpg (66,715 bytes)   
snip4.jpg (50,092 bytes)   
snip4.jpg (50,092 bytes)   


2017-07-11 21:58

administrator   ~0044166

Thanks. Now I see what you meant, I thought subscript was changing after changing style in style editor. Your issue is in fact a known issue already logged as 0008772.


2017-07-11 21:59

administrator   ~0044167

Closing as issue is a duplicate.

Issue History

Date Modified Username Field Change
2017-07-10 20:11 tarren New Issue
2017-07-10 20:31 jghali Note Added: 0044161
2017-07-10 20:34 jghali Note Added: 0044162
2017-07-11 19:26 tarren File Added: SubScriptExample.sla
2017-07-11 19:26 tarren File Added: snip5.jpg
2017-07-11 19:26 tarren File Added: snip1.jpg
2017-07-11 19:26 tarren File Added: snip2.jpg
2017-07-11 19:26 tarren File Added: snip3.jpg
2017-07-11 19:26 tarren File Added: snip4.jpg
2017-07-11 19:26 tarren Note Added: 0044164
2017-07-11 21:58 jghali Note Added: 0044166
2017-07-11 21:59 jghali Assigned To => jghali
2017-07-11 21:59 jghali Status new => resolved
2017-07-11 21:59 jghali Resolution open => duplicate
2017-07-11 21:59 jghali Note Added: 0044167
2017-07-11 21:59 jghali Relationship added duplicate of 0008772
2017-07-11 21:59 jghali Status resolved => closed