View Issue Details

IDProjectCategoryView StatusLast Update
0014926ScribusGeneralpublic2017-12-20 20:58
Reporterirene Assigned Tojghali  
PrioritynormalSeveritycrashReproducibilityhave not tried
Status closedResolutionfixed 
Product Version1.5.3 
Target Version1.5.4Fixed in Version1.5.4.svn 
Summary0014926: Invalid character in xml attribute
DescriptionProgramm ist abgestürzt, beim Öffnen der aktuellen Datei erscheint bei 55 % die Meldung
"Fehler beim Parsen der Datei....."
Steps To Reproduceautosave datei hat auch nicht funktioniert
TagsNo tags attached.
PatchNo

Activities

irene

2017-07-23 10:32

reporter  

Jahresbericht 2016_17_neu.sla (940,892 bytes)

irene

2017-07-23 11:56

reporter   ~0044199

the exact warning ist "unable to parse .. error in line 3075 column 99"

irene

2017-07-23 12:05

reporter   ~0044200

tried it with version 1.5.4. - stops at 55 % with the error report above.

irene

2017-07-23 12:07

reporter   ~0044201

autosave file did also not work

Jahresbericht 2016_17_neu_autosave_23_07_2017_09_47.sla (973,489 bytes)

ale

2017-07-24 08:32

manager   ~0044206

there is a "strange" char in a toc entry (probably a new line character).

removing it solves the parsing error.

but, then, scribus crashes at me.
i've tried to "manually" remove all references to the TOC, but scribus still crashes when loading the file.

jghali

2017-07-24 22:36

administrator   ~0044212

Here is a fixed version of the document. I can open it successfully with latest 1.5.4.svn build.

14926_error_on_open_fixed.zip (135,692 bytes)

ale

2017-07-26 07:10

manager   ~0044222

jean, you also have removed the "new line" sign.
is it the only change you have done?

your document has other multiple changes

- in the positions (very tiny...)
- in the toc (new target)
- you have removed a list that looks like the hyphenation ignore list

since i don't see any commit relating to this issue, i'd like to ask if new tickets are needed to avoid this issue in the future?

jghali

2017-07-26 07:19

administrator   ~0044223

Last edited: 2017-07-26 07:25

View 2 revisions

Yes, removing the "new line" is the only change i've done. I've started from the first uploaded document, not the autosave one.

irene

2017-07-26 07:22

reporter   ~0044225

Thank you, problem solved!

jghali

2017-07-27 18:33

administrator   ~0044234

I did a small commit to fix the xml error which was likely caused by a copy/paste of text from a frame to the item attribute dialog. The fix change our line break character: previously we were using the control character with code 0x1C, now Scribus use the Unicode line separator (0x2028). The Unicode line separator is a valid character which can be used in an XML attribute.

Issue History

Date Modified Username Field Change
2017-07-23 10:32 irene New Issue
2017-07-23 10:32 irene File Added: Jahresbericht 2016_17_neu.sla
2017-07-23 10:52 jghali Target Version => 1.5.4
2017-07-23 11:56 irene Note Added: 0044199
2017-07-23 12:05 irene Note Added: 0044200
2017-07-23 12:07 irene File Added: Jahresbericht 2016_17_neu_autosave_23_07_2017_09_47.sla
2017-07-23 12:07 irene Note Added: 0044201
2017-07-24 08:32 ale Note Added: 0044206
2017-07-24 09:29 jghali Category - => General
2017-07-24 22:36 jghali File Added: 14926_error_on_open_fixed.zip
2017-07-24 22:36 jghali Note Added: 0044212
2017-07-24 23:00 jghali Priority immediate => normal
2017-07-26 07:10 ale Note Added: 0044222
2017-07-26 07:19 jghali Note Added: 0044223
2017-07-26 07:22 irene Note Added: 0044225
2017-07-26 07:25 jghali Note Edited: 0044223 View Revisions
2017-07-27 18:24 jghali Summary Fehler beim parsen der Datei => Error when parsing file
2017-07-27 18:25 jghali Summary Error when parsing file => Invalid character in xml attribute
2017-07-27 18:33 jghali Assigned To => jghali
2017-07-27 18:33 jghali Status new => resolved
2017-07-27 18:33 jghali Resolution open => fixed
2017-07-27 18:33 jghali Fixed in Version => 1.5.4.svn
2017-07-27 18:33 jghali Note Added: 0044234
2017-12-20 20:58 cbradney Status resolved => closed