View Issue Details

IDProjectCategoryView StatusLast Update
0014939ScribusImport / Exportpublic2017-12-20 20:58
Reporterjon.grossart Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformWindowsOSWindowsOS Version10
Product Version1.5.3 
Target VersionFixed in Version1.5.4.svn 
Summary0014939: SVG with Groups on Master Page don't export to PDF when grouped via Scribus
DescriptionI've been running into a problem on Scribus 1.5.3 when exporting my documents where certain objects in my document "headers" aren't being exported to PDF. I eventually tracked it down to an issue with Master Pages

Setup:
1. edit a master page
2. import SVG objects from inkscape with groups in them
3. group the SVGs from within Scribus

If the objects are just on a page, they are exported correctly. However, if those same objects are moved to a master page and applied to the blank page, then some/all of the elements won't be exported to PDF correctly.
Steps To Reproduce1. load the attached file
2. export to PDF
3. view the PDF

Depending on when you export the PDF, there is non-deterministic results as to what parts of the master page are exported (I've exported it one where it just had one single red square which was different from the uploaded test document where more of the parts rendered).
TagsNo tags attached.
PatchNo

Activities

jon.grossart

2017-08-06 05:06

reporter  

Grouped.svg (2,927 bytes)
Grouping Export.2.pdf (27,896 bytes)
Grouping Export.2.sla (42,808 bytes)

jon.grossart

2017-08-06 05:32

reporter   ~0044265

I also recreated the same file in Scribus 1.4.6 in openSUSE Tumbleweed to check if it was a regression. It worked as expected, so it's a 1.5.x regression.

Grouping Export.146.pdf (30,547 bytes)
Grouping Export.146.sla (105,509 bytes)

PeterBenedek

2017-08-06 06:34

developer   ~0044266

I can reproduce in LinuxMint 18.2; r22127 too.

jghali

2017-08-06 14:02

administrator   ~0044267

Fixed! I'll upload new snapshots for Windows on sourceforge later tonight.

jon.grossart

2017-08-06 17:05

reporter   ~0044271

Well, that was extraordinarily fast. Thanks.

PeterBenedek

2017-08-06 18:39

developer   ~0044275

Tested r22129; LinuxMint 18.2

I can't reproduce. Works well.

Thanks.

jghali

2017-08-06 20:02

administrator   ~0044276

As promised, new snapshots for Windows are available here:
https://sourceforge.net/projects/scribus/files/scribus-svn/1.5.4.svn/

jon.grossart

2017-08-06 21:02

reporter   ~0044277

I verified the Windows snapshot (64-bit) against my uploaded files and against my actual files, and it worked correctly.

Since it's still so close to the 1.5.3 release, any reason not to use the SVN snapshot as a replacement for 1.5.3? It seems faster and smoother as well. And hopefully one of the crash fixes is the one I'm constantly running up on after closing files.

Issue History

Date Modified Username Field Change
2017-08-06 05:06 jon.grossart New Issue
2017-08-06 05:06 jon.grossart File Added: Grouped.svg
2017-08-06 05:06 jon.grossart File Added: Grouping Export.2.pdf
2017-08-06 05:06 jon.grossart File Added: Grouping Export.2.sla
2017-08-06 05:32 jon.grossart File Added: Grouping Export.146.pdf
2017-08-06 05:32 jon.grossart File Added: Grouping Export.146.sla
2017-08-06 05:32 jon.grossart Note Added: 0044265
2017-08-06 06:34 PeterBenedek Note Added: 0044266
2017-08-06 14:02 jghali Assigned To => jghali
2017-08-06 14:02 jghali Status new => resolved
2017-08-06 14:02 jghali Resolution open => fixed
2017-08-06 14:02 jghali Fixed in Version => 1.5.4.svn
2017-08-06 14:02 jghali Note Added: 0044267
2017-08-06 17:05 jon.grossart Note Added: 0044271
2017-08-06 18:39 PeterBenedek Note Added: 0044275
2017-08-06 20:02 jghali Note Added: 0044276
2017-08-06 21:02 jon.grossart Note Added: 0044277
2017-12-20 20:58 cbradney Status resolved => closed