View Issue Details

IDProjectCategoryView StatusLast Update
0015047ScribusGeneralpublic2017-12-20 20:58
ReporterLuna Nightshade Assigned Tojghali  
PrioritynoneSeveritycrashReproducibilityalways
Status closedResolutionfixed 
PlatformWindowsOSWindowsOS Version10
Product Version1.5.4.svn 
Target VersionFixed in Version1.5.4.svn 
Summary0015047: Scribus hangs after trying to save or export an old file containing complex group
DescriptionI know this will be a hard Problem to pin down, as I can't just give you the file (need to clear this with the publisher, or somehow scramble the text ... if you have any tips on how to do that, they'd be appreciated)
The .sla file is about 3,309 KB in file-size, and can be opened in the old version, as well as in the new one.
Scribus 1.5.3 or 1.5.4svn (171112) can open the file. It takes longer than the old version to render it, but there is no problem thus far. I can even make changes to the text.
But as soon as I try to save the changes, or want create an PDF (which usually triggers the dialog showing any possible errors, if present, or the pdf-creation dialog), Scribus seems to hang, hogging one core fully. It may be that I was not patient enough though (probably because opening and rendering takes less time - less than a minute, versus waiting for more than 5 minutes) ...

The interesting thing is: It hangs before even writing anything to the disc.
Additional InformationThe file has 59 pages with 59 linked text-frames.
Notepad++ counts more than 7,200 times the ITEXT-tag in the .sla file, 1,740 PARA-tags, 2,700 PAGEOBJECT-tags (2,100 unique PAGEOBJECT-Containers), and a bunch of paths from a few chemical formula.
TagsNo tags attached.
PatchNo

Relationships

related to 0014992 new link text frame is much slower than before since r21563 

Activities

jghali

2017-11-22 18:05

administrator   ~0044648

Only solution for us to solve this issue: having the file. If we can't reproduce the issue, we will have to close this bug.

Luna Nightshade

2017-11-22 19:27

reporter   ~0044650

I did some creative reg-exp replacing using notepad++ (every character in <ITEXT CH=""> replaced by a, every number by a 9, then restoring the special entities ...).
The file contents doesn't quite match up with how they are used to, as not every letter is as large as an "a". But, the important thing is: I could reproduce the error with that file. I'll just attach it here.

test3.sla (3,387,940 bytes)

utnik

2017-11-22 23:14

updater   ~0044651

i can confirm the problem with the testfile on macOS 10.11.6/scribus 1.5.3.
i just ran a .pdf export test. after clicking 'ignore errors' (all errors are about overflowing text) in the preflight veryfier i saw a spinning wheel, which i ended 3 hours later by force quitting scribus.

Luna Nightshade

2017-11-23 05:08

reporter   ~0044652

On windows I didn't even get to the "ignore errors" - part, or got Scribus to save the file.
Many of those text-boxes are a bit tight (they contain arrows, for example - which weren't replaced) - and in Scribus 1.5.0 I just had to visit every error (without making changes) to make the errors disappear.

PeterBenedek

2017-11-23 18:01

developer   ~0044653

I can confirm the problem with the testfile on Linux Mint 18.2

I opened file: this very long time. Document almost unusable.
Seems related: 0014992

jghali

2017-11-23 23:01

administrator   ~0044655

I posted new Windows snapshots with the fix for this issue to sourceforge:
https://sourceforge.net/projects/scribus/files/scribus-svn/1.5.4.svn/

The build numbered 171123 is the one to download.

Issue History

Date Modified Username Field Change
2017-11-22 17:57 Luna Nightshade New Issue
2017-11-22 18:05 jghali Note Added: 0044648
2017-11-22 19:27 Luna Nightshade File Added: test3.sla
2017-11-22 19:27 Luna Nightshade Note Added: 0044650
2017-11-22 23:14 utnik Note Added: 0044651
2017-11-23 05:08 Luna Nightshade Note Added: 0044652
2017-11-23 17:46 PeterBenedek Relationship added related to 0014992
2017-11-23 18:01 PeterBenedek Note Added: 0044653
2017-11-23 19:19 jghali Summary Scribus hangs after trying to save or export an old file made with Scribus 1.4.5 / 1.5.0svn => Scribus hangs after trying to save or export an old file containing complex group
2017-11-23 19:23 jghali Assigned To => jghali
2017-11-23 19:23 jghali Status new => resolved
2017-11-23 19:23 jghali Resolution open => fixed
2017-11-23 19:23 jghali Fixed in Version => 1.5.4.svn
2017-11-23 23:01 jghali Note Added: 0044655
2017-12-20 20:58 cbradney Status resolved => closed