View Issue Details

IDProjectCategoryView StatusLast Update
0015104ScribusGeneralpublic2019-06-04 20:56
Reporterfgfletcher Assigned Tojghali  
PrioritynormalSeverityminorReproducibilitysometimes
Status closedResolutionfixed 
PlatformMac mini (Mid 2011)OSMac OS XOS Version10.12.6
Product Version1.5.3 
Target VersionFixed in Version1.5.4.svn 
Summary0015104: Lines sometimes reported by Preflight Verifier as "not on page"
DescriptionPrevious issue reported in 0015100 has resurfaced.
Two lines which previously worked (one on Master page and one on Page 1) and which have neither been modified nor moved are now again being reported by Preflight Verifier as "not on page" and will not export in PDF.
Other lines drawn on other pages are still OK.
Steps To ReproduceSave as PDF
Additional InformationA small amount of text editing was done in other areas of the document, and now the lines which were previously OK and exported normally to PDF no longer do.
I am attaching a PDF which contains Page 1 of the earlier (good) PDF and Page 1 as it is now produced (the 7 page full document is too big).
I am also attaching the .sla file and a screenshot of the Preflight Verifier dialog.
The line on the Master Page is the line near the bottom of each page above the footer text (title + page #)
The line on Page 1 is the line between the text and the footnotes.
The 28 images in the document can't be uploaded as they would require almost 100 MB...
TagsNo tags attached.
PatchNo

Activities

fgfletcher

2018-01-17 04:53

reporter  

Mason_Borders_Review_both_pg_1.pdf (870,931 bytes)
Mason_Borders_Review_3.sla (78,900 bytes)
preflight.jpg (42,550 bytes)
preflight.jpg (42,550 bytes)

jghali

2018-01-17 10:07

administrator   ~0044843

Those lines have no stroke color, so they cannot be visible when exporting to PDF...

jghali

2018-01-17 11:02

administrator   ~0044844

Changing back severity to minor as those lines have been obviously modified.

fgfletcher

2018-01-17 14:44

reporter   ~0044847

But they did export visibly prior to some text editing.
Two sources of confusion (to me):
a) what would have changed stroke color without my having selected and modified the lines
b) why does Preflight Verifier report them as "not on page"
Thanks

fgfletcher

2018-01-17 15:01

reporter   ~0044848

I checked and both lines had neither stroke nor fill colors assigned (though they must have had stroke previously).
However, even though I changed that to assign Black for each line's stroke and fill, Preflight Verifier still reports that neither object (lines 2 and 66) are on their page.
Furthermore when I tell Verifier to ignore errors and output the PDF, Line66 does export but Line2 (on the Master page) still does not.
Perhaps both the loss of stroke color and the "not on page" issues are related?
I'm attaching the updated .sla
Thanks

Mason_Borders_Review_3-2.sla (79,113 bytes)

jghali

2018-01-17 22:09

administrator   ~0044851

Another thing I noticed: your two lines have their width set to "Hairline". Using hairlines is generally not advised as their behavior is totally peripheral dependent. When used in professional printing, they can potentially totally disappear from print, so this is an error which is commonly checked by PDF preflight softwares! So set width of these two lines to something above 0, save your document and reload it. Then you should be good to continue your work.

The "not on page" issue is caused by incorrect handling of that hairline case when computing bounding rect of layout objects.

jghali

2018-01-17 22:11

administrator   ~0044852

Issue fixed.

fgfletcher

2018-01-17 23:01

reporter   ~0044853

Issue is **not** fixed!

I changed both the lines from hairline to 0.0139" (1 pt) and this made no change. Line2 (on Master) is still reported as "not on page".

fgfletcher

2018-01-17 23:07

reporter   ~0044854

OOOPS - I had only Saved the file - which did not solve the issue.
However Saving then Quitting Scribus, then restarting it and opening the file does seem to solve the problem.
Apparently simply fixing the file leaves something corrupted outside of the file.
Thanks for the help.
Suggestion: perhaps "hairline" should be removed as an option and/or some minimum width enforced?

Fahad

2018-01-18 06:09

developer   ~0044855

@jghali

There is an error in your patch to fix this problem in linux:

/home/ita/dev/scribus15/trunk/Scribus/scribus/pageitem.cpp: In member function ‘void PageItem::createConicalMesh()’:
/home/ita/dev/scribus15/trunk/Scribus/scribus/pageitem.cpp:3438:24: warning: comparison between signed and unsigned integer expressions [-Wsign-compare]
  for (int rst = 2; rst < gradient.Stops(); ++rst)
                        ^
[ 9%] Building CXX object scribus/CMakeFiles/scribus.dir/pageitem_line.cpp.o
/home/ita/dev/scribus15/trunk/Scribus/scribus/pageitem_line.cpp: In member function ‘virtual void PageItem_Line::getVisualBoundingRect(double*, double*, double*, double*) const’:
/home/ita/dev/scribus15/trunk/Scribus/scribus/pageitem_line.cpp:276:37: error: invalid use of incomplete type ‘class ScribusView’
     extraSpace = 0.5 / m_Doc->view()->scale();
                                     ^
In file included from /home/ita/dev/scribus15/trunk/Scribus/scribus/pageitem_line.cpp:41:0:
/home/ita/dev/scribus15/trunk/Scribus/scribus/scribusdoc.h:75:7: note: forward declaration of ‘class ScribusView’
 class ScribusView;
       ^
/home/ita/dev/scribus15/trunk/Scribus/scribus/pageitem_line.cpp:297:37: error: invalid use of incomplete type ‘class ScribusView’
     extraSpace = 0.5 / m_Doc->view()->scale();
                                     ^
In file included from /home/ita/dev/scribus15/trunk/Scribus/scribus/pageitem_line.cpp:41:0:
/home/ita/dev/scribus15/trunk/Scribus/scribus/scribusdoc.h:75:7: note: forward declaration of ‘class ScribusView’
 class ScribusView;
       ^
scribus/CMakeFiles/scribus.dir/build.make:12233: recipe for target 'scribus/CMakeFiles/scribus.dir/pageitem_line.cpp.o' failed
make[2]: *** [scribus/CMakeFiles/scribus.dir/pageitem_line.cpp.o] Error 1
CMakeFiles/Makefile2:196: recipe for target 'scribus/CMakeFiles/scribus.dir/all' failed
Makefile:149: recipe for target 'all' failed
make[1]: *** [scribus/CMakeFiles/scribus.dir/all] Error 2
make: *** [all] Error 2
09:59:59: The process "/usr/bin/cmake" exited with code 2.
Error while building/deploying project scribus (kit: Imported Kit)
The kit Imported Kit has configuration issues which might be the root cause for this problem.
When executing step "CMake Build"

jghali

2018-01-18 07:44

administrator   ~0044856

@Fahad Ooops, this is now fixed. Got caught by my msvc precompiled header including scribusview.h automatically.

Issue History

Date Modified Username Field Change
2018-01-17 04:53 fgfletcher New Issue
2018-01-17 04:53 fgfletcher File Added: Mason_Borders_Review_both_pg_1.pdf
2018-01-17 04:53 fgfletcher File Added: Mason_Borders_Review_3.sla
2018-01-17 04:53 fgfletcher File Added: preflight.jpg
2018-01-17 10:07 jghali Note Added: 0044843
2018-01-17 11:02 jghali Severity major => minor
2018-01-17 11:02 jghali Note Added: 0044844
2018-01-17 14:44 fgfletcher Note Added: 0044847
2018-01-17 15:01 fgfletcher File Added: Mason_Borders_Review_3-2.sla
2018-01-17 15:01 fgfletcher Note Added: 0044848
2018-01-17 22:09 jghali Note Added: 0044851
2018-01-17 22:11 jghali Assigned To => jghali
2018-01-17 22:11 jghali Status new => resolved
2018-01-17 22:11 jghali Resolution open => fixed
2018-01-17 22:11 jghali Fixed in Version => 1.5.4.svn
2018-01-17 22:11 jghali Note Added: 0044852
2018-01-17 23:01 fgfletcher Note Added: 0044853
2018-01-17 23:07 fgfletcher Note Added: 0044854
2018-01-18 06:09 Fahad Note Added: 0044855
2018-01-18 07:44 jghali Note Added: 0044856
2019-06-04 20:56 cbradney Status resolved => closed