View Issue Details

IDProjectCategoryView StatusLast Update
0015115ScribusGeneralpublic2018-03-13 20:16
Reporterchristoph_s Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityalways
Status newResolutionreopened 
Platformx86 64OSLinuxOS VersionopenSUSE 42.1
Product Version1.5.4.svn 
Target VersionFixed in Version 
Summary0015115: Adding a new HLC colour to a document based on an H value is visually impossible
DescriptionIf one tries to add a new HLC colour in the "Colours & Fills" dialogue, one cannot choose an H value, because the H slider only displays white, which is different from all the other colour models.
Steps To Reproduce1) Create a new doc.


2) Open the "Colours & Fills" dialogue.


3) Select "Solid Colours" > "Add".


4) In the new colour dialogue, select "HLC" as the colour model.


--> the H slider doesn't show any hues and is completely white, no matter what colour values you enter. One needs to click on the "Colour Map" for a starting point.
Additional InformationSame on Windows 7/10.
TagsNo tags attached.
PatchNo

Activities

utnik

2018-01-28 15:09

updater   ~0044882

imho this is expected behavior as long as the 'c' slider is set to 0.
you don't need to start on the color map, but you need to set some saturation to see any color.

jghali

2018-01-28 23:30

administrator   ~0044886

Yes, this is expected behavior. In HLC model, if L = 100 or C = 0, H has no meaning. That's one reason color specialists usually call it LCh: you'd better specific L and C first before being able to do anything meaningful with h. In HLC model, color hue is also not perceptually constant for a given H value if C vary. So it's totally pointless to specific H first.

jghali

2018-01-30 16:46

administrator   ~0044893

So what do we do with this one? Do we replace HLC by LCh or do we close as "no change required"?

utnik

2018-01-30 16:57

updater   ~0044894

i would just close it as 'no change required'.

jghali

2018-01-30 17:01

administrator   ~0044895

My question was more specifically addressed at @christoph_s, so I'm going to wait his answer.

jghali

2018-02-05 17:46

administrator   ~0044918

Closing due to lack of response

christoph_s

2018-03-07 04:10

administrator   ~0045030

Sorry for the delay, but I was waiting for feedback from DTP and colour professionals, which took some time. The consensus seems to be that we need to do the following:


1) Add a tooltip for HLC and LAB.

2) Set the default values for HLC as follows: H=360, L=50, C=64.

3) Explain LAB and HLC in the docs.

0000003 would be a separate issue to be handled by Greg and/or myself. As for 0000002, the reasoning was that by setting the H value to the maximum and the other values as mentioned, it would be easier for users to see that moving the H slider means effectively moving around in a circle, which is also reflected in the HLC Colour Atlas's colour wheel. However, considering the current display quality it might make more sense to set the L value to 100, because then it would be more visually obvious that the "x" is moving within a well-defined circle.

jghali

2018-03-13 19:44

administrator   ~0045040

Last edited: 2018-03-13 19:45

View 2 revisions

2) Set the default values for HLC as follows: H=360, L=50, C=64.

There are no default values for HLC at any point:
- the initial HLC values come from colorimetric conversion from device values to Lab then to HLC if initial color is RGB or CMYK
- the initial HLC values come from the conversion of Lab values when initial color is Lab

jghali

2018-03-13 19:51

administrator   ~0045041

>> moving the H slider means effectively moving around in a circle

Perceptually, this is false, when moving H you are not moving along a circle. Given the defects of Lab model, you are moving at best along a potatoïd. That does not remove also the fact that H is totally meaningless for specific values of L and C.

jghali

2018-03-13 20:16

administrator   ~0045042

>> Perceptually, this is false, when moving H you are not moving along a circle. Given the defects of Lab model, you are moving at best along a potatoïd.

That was mentioned previously, but that facts alone means that user cannot make a proper effective choice for the initial hue value. In HLC model, you have to set L and C first so as to be able to make a proper choice for hue. The JCh model derived from CIECAM02 is much better if h has to be set first because that model has much better perceptual characteristics.

Issue History

Date Modified Username Field Change
2018-01-28 06:22 christoph_s New Issue
2018-01-28 15:09 utnik Note Added: 0044882
2018-01-28 23:30 jghali Note Added: 0044886
2018-01-30 16:46 jghali Note Added: 0044893
2018-01-30 16:57 utnik Note Added: 0044894
2018-01-30 17:01 jghali Note Added: 0044895
2018-02-05 17:46 jghali Assigned To => jghali
2018-02-05 17:46 jghali Status new => resolved
2018-02-05 17:46 jghali Resolution open => no change required
2018-02-05 17:46 jghali Note Added: 0044918
2018-02-05 17:46 jghali Status resolved => closed
2018-03-07 04:10 christoph_s Status closed => new
2018-03-07 04:10 christoph_s Resolution no change required => reopened
2018-03-07 04:10 christoph_s Note Added: 0045030
2018-03-13 19:44 jghali Note Added: 0045040
2018-03-13 19:45 jghali Note Edited: 0045040 View Revisions
2018-03-13 19:51 jghali Note Added: 0045041
2018-03-13 20:16 jghali Note Added: 0045042