View Issue Details

IDProjectCategoryView StatusLast Update
0015180Scribus-public2018-03-06 09:14
Reporterale Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product Version1.5.4.svn 
Target VersionFixed in Version 
Summary0015180: applying formatting to the cursor
Descriptionit's currently not possible to define the formatting for the next character to be typed.
Steps To Reproduce- place the cursor in a text frame
- pick a character style
- type the new text.

there are two (imo wrong) cases:

- if there is a next character, that character gets formatted
- if there is no next character (cursor at the end of the frame, the formatting is simply discarded
Additional Informationthe expected result when there is no selection:

- picking a new formatting should not modify the current text
- the next letter typed will get the new formatting
- if the cursor is moved before typing anything, the formatting is discarded.

it's probably easier to get to this behavior if we remove the text formatting for the frame and replace it with a cursor formatting (an empty frame would have a cursor at 0 with the formatting of the last deleted character)
TagsNo tags attached.
PatchNo

Relationships

duplicate of 0013501 confirmed impossible to set the character formatting at the end of the frame 
related to 0013135 confirmed At the end of paragraph the text property is reset 

Activities

jghali

2018-03-06 08:10

administrator   ~0045019

Duplicate of 0013501

ale

2018-03-06 08:28

manager   ~0045020

sorry, it's not the same.
now it does not work either in the middle of the frame.

jghali

2018-03-06 09:13

administrator   ~0045021

But the cause is identical

Issue History

Date Modified Username Field Change
2018-03-06 07:52 ale New Issue
2018-03-06 08:05 PeterBenedek Relationship added related to 0013135
2018-03-06 08:10 jghali Assigned To => jghali
2018-03-06 08:10 jghali Status new => resolved
2018-03-06 08:10 jghali Resolution open => duplicate
2018-03-06 08:10 jghali Note Added: 0045019
2018-03-06 08:10 jghali Relationship added duplicate of 0013501
2018-03-06 08:10 jghali Status resolved => closed
2018-03-06 08:28 ale Status closed => new
2018-03-06 08:28 ale Resolution duplicate => reopened
2018-03-06 08:28 ale Note Added: 0045020
2018-03-06 08:29 ale Relationship replaced related to 0013501
2018-03-06 09:13 jghali Status new => resolved
2018-03-06 09:13 jghali Resolution reopened => duplicate
2018-03-06 09:13 jghali Note Added: 0045021
2018-03-06 09:13 jghali Relationship replaced duplicate of 0013501
2018-03-06 09:14 jghali Status resolved => closed