View Issue Details

IDProjectCategoryView StatusLast Update
0015184ScribusStylespublic2019-06-04 20:56
Reporterdarinshepit Assigned Tojghali  
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
PlatformOSWindowsOS Version7 Home Premium
Product Version1.5.3 
Target VersionFixed in Version1.5.4.svn 
Summary0015184: Writing in unavailable Font Family then trying to change it silently crashes application
DescriptionWorking in the Style Manger, whether with a Paragraph (on the Character Style tab) or a Character style, you can start typing in the Family area (which is also a dropdown box) to select the font you want.

Normally, if you start typing a font name, it will auto-populate. From there, you can press ENTER and it selects the font it started to auto-populate.

However, if you mistype the font name (or type in gibberish) so there's no matching font, you can still press ENTER. This doesn't immediately do anything. But, if you then try to use the dropdown menu to change your Family selection, it silently crashes the application.

This doesn't happen in the Text Properties window as it doesn't allow you to mistype a font name in the first place.
Steps To Reproduce1. Open Style Manager
2. Open a Paragraph Style and select the Character Style tab OR open a Character Style
3. Start typing in the Family textarea/dropdown menu to choose a Font Family
4. Type a font name that you don't have installed (Arail instead of Arial, for example, or some gibberish), then press ENTER; it accepts the faulty font name
5. Try to change the font by using the dropdown menu; it silently crashes Scribus
Tagscrash, Crashes, fails silently, font selection, styles, windows7
PatchNo

Activities

PeterBenedek

2018-03-08 16:28

developer   ~0045031

" This doesn't happen in the Text Properties window as it doesn't allow you to mistype a font name in the first place."

Tested r22423

But unfortunately does happen in 1.5.4 version.

The patch improves this (r22424)?

0015184.gif (210,048 bytes)
0015184.gif (210,048 bytes)

jghali

2018-03-08 16:30

administrator   ~0045032

r22424 is required.

PeterBenedek

2018-03-09 04:23

developer   ~0045033

Tested r22425

I can't reproduce anymore. Works perfectly.

Thanks.

Issue History

Date Modified Username Field Change
2018-03-08 11:53 darinshepit New Issue
2018-03-08 11:53 darinshepit Tag Attached: crash
2018-03-08 11:53 darinshepit Tag Attached: Crashes
2018-03-08 11:53 darinshepit Tag Attached: fails silently
2018-03-08 11:53 darinshepit Tag Attached: font selection
2018-03-08 11:53 darinshepit Tag Attached: styles
2018-03-08 11:53 darinshepit Tag Attached: windows7
2018-03-08 15:21 jghali Assigned To => jghali
2018-03-08 15:21 jghali Status new => resolved
2018-03-08 15:21 jghali Resolution open => fixed
2018-03-08 15:21 jghali Fixed in Version => 1.5.4.svn
2018-03-08 16:28 PeterBenedek File Added: 0015184.gif
2018-03-08 16:28 PeterBenedek Note Added: 0045031
2018-03-08 16:28 PeterBenedek Status resolved => feedback
2018-03-08 16:28 PeterBenedek Resolution fixed => reopened
2018-03-08 16:30 jghali Status feedback => resolved
2018-03-08 16:30 jghali Note Added: 0045032
2018-03-08 16:30 jghali Resolution reopened => fixed
2018-03-09 04:23 PeterBenedek Note Added: 0045033
2019-06-04 20:56 cbradney Status resolved => closed