View Issue Details

IDProjectCategoryView StatusLast Update
0001522ScribusGeneralpublic2005-10-02 23:29
Reportertom_verbeure Assigned Tosubik  
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionfixed 
PlatformPCOSLinuxOS Version2.4.20 Suse 8.2
Product Version 
Target VersionFixed in Version1.3.1cvs 
Summary0001522: configure wrongly reports detected Python version
Description
When I override the standard search paths for Python by using:

./configure --with-pythonpath=/usr/local/python-2.3

./configure will correctly find all the necessary ./include and ./lib directories and compile correctly.

However, when ./configure finished, it reports that it will use a version of Python smaller than 2.3.

This is fairly annoying, because it made me believe that the specified python version somehow wasn't found. (And since python 2.2 aborts during the scribus compilation, it resulted in a long quest to find the problem! :-) )

The reason for the wrong report is that the following step fails:
"checking python2.3/Python.h usability"
This check fails because the test is compiled without include paths specified.

This results in ac_cv_header_python_2_3_Python_h being set to 'no' after which hapython is also set to 'no'.
Ultimately, this variable is used to report that a version smaller than 2.3 will be used.

That said, the compilation works fine afterwards...
TagsNo tags attached.
Patch

Activities

subik

2005-01-23 15:30

manager   ~0003525

can you check it with these files?

tom_verbeure

2005-01-23 17:19

reporter   ~0003526

I'll try, but it may take a while. My development computer is currently loaned out. :-)

subik

2005-07-15 18:22

manager   ~0005594

Python availability checking is now rewritten. It's working now for all pythons installed here (2.1 ... 2.4)

Issue History

Date Modified Username Field Change
2005-01-10 02:07 tom_verbeure New Issue
2005-01-16 19:56 subik Status new => assigned
2005-01-16 19:56 subik Assigned To => subik
2005-01-23 14:41 subik File Added: configure.in.bot
2005-01-23 14:42 subik File Added: acinclude.m4.in
2005-01-23 15:30 subik Note Added: 0003525
2005-01-23 17:19 tom_verbeure Note Added: 0003526
2005-07-15 18:20 subik File Deleted: configure.in.bot
2005-07-15 18:20 subik File Deleted: acinclude.m4.in
2005-07-15 18:22 subik Status assigned => resolved
2005-07-15 18:22 subik Fixed in Version => 1.3.1cvs
2005-07-15 18:22 subik Resolution open => fixed
2005-07-15 18:22 subik Note Added: 0005594
2005-10-02 23:29 cbradney Status resolved => closed