View Issue Details

IDProjectCategoryView StatusLast Update
0015277ScribusInternalpublic2019-06-04 20:56
Reporterdcb Assigned Tojghali  
PrioritylowSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.4.7 
Target VersionFixed in Version1.5.5.svn 
Summary0015277: Warning: same iterator is used with different containers
Descriptionscribus-1.4.7/scribus/plugins/tools/hunspellcheck/hunspelldialog.cpp:41]: (error) Same iterator is used with different containers 'm_dictionaryMap' and 'dictionaryMap'.

Source code is

        QMap<QString, QString>::iterator it = m_dictionaryMap->begin();
        while (it != dictionaryMap->end())

Maybe better code

        QMap<QString, QString>::iterator it = m_dictionaryMap->begin();
        while (it != m_dictionaryMap->end())

TagsNo tags attached.
PatchNo

Activities

jghali

2018-04-29 00:48

administrator   ~0045187

False positive because 'm_dictionaryMap' and 'dictionaryMap' point to same container. But better to fix that warning.

Issue History

Date Modified Username Field Change
2018-04-28 16:19 dcb New Issue
2018-04-29 00:45 jghali Summary scribus-1.4.7/scribus/plugins/tools/hunspellcheck/hunspelldialog.cpp:41: wrong iterator ? => Warning: same iterator is used with different containers
2018-04-29 00:48 jghali Assigned To => jghali
2018-04-29 00:48 jghali Status new => resolved
2018-04-29 00:48 jghali Resolution open => fixed
2018-04-29 00:48 jghali Fixed in Version => 1.5.5.svn
2018-04-29 00:48 jghali Note Added: 0045187
2018-04-29 02:40 jghali Category Plug-ins => Internal
2019-06-04 20:56 cbradney Status resolved => closed