View Issue Details

IDProjectCategoryView StatusLast Update
0015319ScribusImport / Exportpublic2018-05-14 13:12
Reporterenzogian Assigned Tojghali  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
Product Version 
Target VersionFixed in Version 
Summary0015319: Image frame does read the svg as vector files
DescriptionI have noticed when importing an image into an image frame, the vector files (svg) get converted into bitmap image. When I reported about the fact that changing external vector images was not refreshing in scribus, then I have been suggested to use sgv inside the image frame but image frames convert them into bitmap..
the overall problem related to vectorial images and its capabilities to get updated etc... is quite an urgent issue for designers looking for high resolution results.
Tagsbitmap, SVG, vector
PatchNo

Relationships

duplicate of 0000393 acknowledged SVG inside a picture frame 

Activities

enzogian

2018-05-14 07:55

reporter   ~0045237

forgot to mention this is happening in version 1.5.4

jghali

2018-05-14 10:02

administrator   ~0045239

Last edited: 2018-05-14 10:05

View 2 revisions

Duplicate of 0000393. The solution is already expressed in this issue. When importing as vector, the whole SVG is converted to scribus elements... which means there is no SVG anymore after import and no possibility to keep a link to the original SVG. 0000393 already propose to allow importing SVG into image frames, which would allow to keep the link, and export as vector.

ale

2018-05-14 13:12

manager   ~0045240

imo, scribus should not allow to load svg as bitmap in image frames.

if you leave the selector to "supported" file types it does not even show you the svg files.

but at sometime in the future, i'd like scribus to be able to load svgs as vectors inside of a scribus frame / group without making its element visible to the scribus document...

Issue History

Date Modified Username Field Change
2018-05-14 07:39 enzogian New Issue
2018-05-14 07:39 enzogian Tag Attached: SVG
2018-05-14 07:39 enzogian Tag Attached: bitmap
2018-05-14 07:39 enzogian Tag Attached: vector
2018-05-14 07:55 enzogian Note Added: 0045237
2018-05-14 10:02 jghali Assigned To => jghali
2018-05-14 10:02 jghali Status new => resolved
2018-05-14 10:02 jghali Resolution open => duplicate
2018-05-14 10:02 jghali Note Added: 0045239
2018-05-14 10:02 jghali Relationship added duplicate of 0000393
2018-05-14 10:02 jghali Status resolved => closed
2018-05-14 10:05 jghali Note Edited: 0045239 View Revisions
2018-05-14 10:09 jghali Priority high => normal
2018-05-14 13:12 ale Note Added: 0045240