View Issue Details

IDProjectCategoryView StatusLast Update
0015422ScribusInternalpublic2019-06-04 20:56
Reporterale Assigned Tojghali  
Status closedResolutionfixed 
Product Version1.5.5.svn 
Target VersionFixed in Version1.5.5.svn 
Summary0015422: Remove PageItem::hasLinks()
Descriptionthe correct function seems to be PageItem::isInChain()

... imo all "chain" function with link in the name should be renamed:

bool testLinkCandidate(PageItem* nextFrame);
  --> canBeChained()
void unlink(bool createUndo = true);
  --> unChain()
void link(PageItem* nextFrame, bool addPARSEP = true);
  -->setChain() (or chain())
void dropLinks();
  --> unChainAll()
void unlinkWithText(bool);
  --> unChainWithText();
  (the bool parameter should be removed since it has been removed from the GUI... or at least there should be a comment saying why it has been removed and when)
TagsNo tags attached.



2018-09-09 16:22

manager   ~0045451

i can do a patch for this, but:

- i have to know if the proposed names are ok / better
- the patch must them be applied in a timely manner, otherwise the work for applying it will be as big as doing the patch yourself...

Issue History

Date Modified Username Field Change
2018-09-09 16:06 ale New Issue
2018-09-09 16:22 ale Note Added: 0045451
2018-09-10 15:07 jghali Category - => Internal
2018-09-30 20:55 jghali Summary deprecate (or remove) PageItem::hasLinks() => Remove PageItem::hasLinks()
2018-09-30 21:38 jghali Assigned To => jghali
2018-09-30 21:38 jghali Status new => resolved
2018-09-30 21:38 jghali Resolution open => fixed
2018-09-30 21:38 jghali Fixed in Version => 1.5.5.svn
2019-06-04 20:56 cbradney Status resolved => closed