View Issue Details

IDProjectCategoryView StatusLast Update
0015495ScribusPrintingpublic2019-06-04 20:55
Reporterfenugrec Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.5.4 
Target VersionFixed in Version1.5.5.svn 
Summary0015495: Print Preview is blank
DescriptionIt seems no matter what is on the layout, File->Print Preview always shows a blank page.

Scribus Version 1.5.4
28 April 2018
Build ID: C--T-F-C1.16.0-64bit
Using Ghostscript version 9.26
on Arch/Artix x86_64.
Steps To Reproduce1- create new file
2- insert text zone, type in dummy text
3- File->Print Preview...
4- admire blank space
Additional InformationExporting to PDF works as expected. Did not try actually printing directly from Scribus.
TagsNo tags attached.
PatchNo

Activities

ale

2018-12-03 15:55

manager   ~0045675

"file > print preview" is not a print preview as you probably think it is.

what you are looking for is view > preview > preview mode.

the file > preview should probably not be blank, but it's very likely that you should not care about it.

fenugrec

2018-12-03 16:34

reporter   ~0045677

Hmm, if one is about to print something (File -> Print), then wants to see a preview, what else is "print preview" supposed to mean ? I'm not concerned with spot colors or CMYK (just monochrome documents), but I still want to see how the included .ps and .pdf elements are rendered. Isn't that what a print preview should do ?

Yes, "view->preview->preview mode" is something I hadn't noticed that will be useful. But I think there's still a problem - either "print preview" means something so radically different and beyond my comprehension that maybe it deserves a note or a different name, or maybe there is a bug with this combination of scribus and backends. In either case I'd like to hear more, maybe a test to make "print preview" show something ?

ale

2018-12-03 22:15

manager   ~0045678

"file > print preview" is for sure wrong for what mots people expect from it.

i've been asking for years to rename it, but all the proposals i've made were judged as not fitting to what the command does.

nowadays, my wish would be to remove it completely from scribus and convert it to a stand alone tool that works on the pdf or the ps created by scribus.
imo, there is no reason for keeping it inside of scribus... but proposals for removing things from scribus are normally not really welcome...

jghali

2018-12-11 15:20

administrator   ~0045715

Last edited: 2018-12-11 19:11

View 3 revisions

This issue is caused by a third-party library issue (libpng) in GhostScript. libpng does some broken checks on sRGB profiles which prevent in this case GhostScript to output png preview correctly. In 1.5.5.svn I have already put in place some workarounds, but you have at this point to uncheck the "Display Transparency" option.

Here is a possible workaround for 1.5.4:
- download the sRGB2014 ICC profile from www.color.org/srgbprofiles.xalter
- install it on your system
- close any document which may be open in Scribus
- enable color management in File > Preferences
- set all RGB profiles to sRGB2014 including the monitor profile if monitor profile has not been set to a custom profile
- do the same for existing docs using File > Document Setup

jghali

2019-02-23 16:17

administrator   ~0045915

I generated a new sRGB profile titled "sRGB display profile (ICC v2.2)". This new profile will now be used as the default RGB profile for non-color managed docs. It also pass broken checks from recent libpng versions and hence allows Ghostscript to generate the print preview as expected.

Some manual operations may still be required to avoid completely this issue tho:
- for existing Scribus installations: in File > Preferences > Color Management, switch RGB profiles including monitor profiles from "sRGB IEC61966-2.1" to "sRGB display profile (ICC v2.2)" if necessary
- for existing documents: in File > Document Setup > Color Management, switch RGB profiles from "sRGB IEC61966-2.1" to "sRGB display profile (ICC v2.2)" if necessary

Issue History

Date Modified Username Field Change
2018-11-30 23:08 fenugrec New Issue
2018-12-03 15:55 ale Note Added: 0045675
2018-12-03 16:34 fenugrec Note Added: 0045677
2018-12-03 22:15 ale Note Added: 0045678
2018-12-11 15:20 jghali Note Added: 0045715
2018-12-11 15:21 jghali Note Edited: 0045715 View Revisions
2018-12-11 19:11 jghali Note Edited: 0045715 View Revisions
2019-02-23 16:06 jghali Summary print preview is blank => Print Preview is blank
2019-02-23 16:17 jghali Assigned To => jghali
2019-02-23 16:17 jghali Status new => resolved
2019-02-23 16:17 jghali Resolution open => fixed
2019-02-23 16:17 jghali Fixed in Version => 1.5.5.svn
2019-02-23 16:17 jghali Note Added: 0045915
2019-06-04 20:55 cbradney Status resolved => closed