View Issue Details

IDProjectCategoryView StatusLast Update
0015505ScribusGeneralpublic2018-12-14 17:27
Reporterdeevide1 Assigned Tojghali  
PrioritynormalSeveritymajorReproducibilityunable to reproduce
Status closedResolutionduplicate 
PlatformUbuntuOSLinuxOS VersionBionic
Product Version1.5.4 
Target VersionFixed in Version 
Summary0015505: Invisible headings comes out from the toolbar
DescriptionI am an editorial designer who recently shifted to FOSS, and the bugged version of scribus is the ONLY one that writes Arabic, which I currently need urgently. However, when I open the programme it doesn't show any text from the drop down menu of the main bar (file, edit... etc.) menu, therefore it is practically useless for me. Can you please fix this problem ASAP, either by fixing this version for Scribus (1.5.4) or adding a plugin for Scribus (1.4.7) that helps with UTF-8 and RTL as well as Hindi Numbering formats?
TagsNo tags attached.
PatchNo

Relationships

duplicate of 0015433 new AppImage download breaks 

Activities

jghali

2018-12-11 14:38

administrator   ~0045714

This is a duplicate of issue 0015433.

On Ubuntu Bionic, the simplest solution for you is probably to use the PPA setup by Canonical:
https://code.launchpad.net/~scribus/+archive/ubuntu/ppa

deevide1

2018-12-14 16:24

reporter   ~0045717

I tried many ways to add the line in the source.list.d but it is not possible. Kindly note the following:
1- my Scribus 1.5.4 is an "appimage" file that I operate by using properties> >all executable files> run as a program.
2- I will need the step by step codes, or operations.
Is there a way to make the 1.4.7 work with writing Arabic properly? or will the solution be for the appimage of 1.5.4?

jghali

2018-12-14 17:24

administrator   ~0045718

>> Is there a way to make the 1.4.7 work with writing Arabic properly?

No. The first version which supports Arabic is 1.5.3.

>> I will need the step by step codes, or operations.

1) open terminal
2) enter command: sudo add-apt-repository ppa:scribus/ppa
3) enter command: sudo apt-get update
3) enter command: sudo apt-get install scribus-ng

jghali

2018-12-14 17:26

administrator   ~0045719

>> Is there a way to make the 1.4.7 work with writing Arabic properly? or will the solution be for the appimage of 1.5.4?

Neither, the PPA solution will install Scribus as a regular Linux application, not as an appimage

Issue History

Date Modified Username Field Change
2018-12-11 13:44 deevide1 New Issue
2018-12-11 14:38 jghali Assigned To => jghali
2018-12-11 14:38 jghali Status new => resolved
2018-12-11 14:38 jghali Resolution open => duplicate
2018-12-11 14:38 jghali Note Added: 0045714
2018-12-11 14:38 jghali Relationship added duplicate of 0015433
2018-12-11 14:44 jghali Priority urgent => normal
2018-12-11 22:19 jghali Status resolved => closed
2018-12-14 16:24 deevide1 Status closed => feedback
2018-12-14 16:24 deevide1 Resolution duplicate => reopened
2018-12-14 16:24 deevide1 Note Added: 0045717
2018-12-14 17:24 jghali Status feedback => resolved
2018-12-14 17:24 jghali Resolution reopened => duplicate
2018-12-14 17:24 jghali Note Added: 0045718
2018-12-14 17:26 jghali Note Added: 0045719
2018-12-14 17:27 jghali Status resolved => closed