View Issue Details

IDProjectCategoryView StatusLast Update
0015527ScribusUsabilitypublic2019-06-04 20:55
Reporteraiena Assigned Tojghali  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version1.5.5.svn 
Target VersionFixed in Version1.5.5.svn 
Summary0015527: Page jumps when trying to edit an object
DescriptionI am using the latest windows snapshot on sourceforge

"https://sourceforge.net/projects/scribus/files/scribus-svn/1.5.5.svn/scribus-1.5.5.svn-snapshot-181217-x64.exe/download"

So product version is 1.5.5svn (not in list)

Selecting objects and editing them can cause the page to jump around. In the past it happened even when typing a single letter in a text frame.
Here it is demonstrated while editing a vector circle in a master page.
Steps To Reproduce1) Clear the Scribus appdata/rename old folder (just as an added measure)
2) Open Scribus 1.5.5svn
3) Open the "Executive Summary English.sla" file downloadable here https://drive.google.com/file/d/1SSQP_3x0Zc3GvVKrqx6KcpdorWUf7kEF/view?usp=sharing
4) In Scribus got to "Edit->master pages" choose the "Reg L" master page.
5) Select the green colored vector circle slightly above the green raster circle of the underlying image. If you double click it and press "ok" in the Nodes windows pop up, the page is stable.
6) Use the "Ctrl + Middle mouse scroll wheel" to zoom into the page slightly so the circle appears larger.
7) Double click the circle to edit it. The page jumps.
8) Close Scribus and re-open it and try again (note: here appdata not cleared) it happens again.
Additional InformationThe video of me performing these steps can be seen here https://youtu.be/sRV7ikOR1NU . Somewhere towards the end the page seems to be stable on double clicking the object. I am not sure why it is so.
 https://drive.google.com/file/d/1_GQZHFQ4mW9scWtjXcLEQMBD0EYZOuD9/view?usp=sharing is a zip file with the state of my scribus appdata folder at the end.

I had experienced this bug before. The page kept jumping around.
I had discussed this with a-l-e on IRC.
 It was hard for a-l-e to reproduce at that time. It seemed to happen with new files too (not necessarily in master pages) but never the first time when the scribus appdata was cleaned.

The main difference here is I have an SLA file in which I can reproduce it consistently. The past behaviour makes me feel that something when written to the appdata may be causing this.

Here are the video URLs from that time:
https://youtu.be/ksJx2npczA8
https://youtu.be/Z5LBdK1vlec
TagsNo tags attached.
PatchNo

Activities

ale

2019-01-07 17:49

manager   ~0045753

on debian i could not reproduce the bug.

i can zoom in and out and double clicking on the circle works ok...

aiena

2019-01-08 06:48

reporter   ~0045754

Hmm hope someone with a Windows system can test. Do you know roughly what code corresponds to this bug. Maybe there is some Windows Qt bug or something.

Luna Nightshade

2019-01-08 14:10

reporter   ~0045757

I am on windows and can confirm that it happens with the first double click on the circle after zooming in. Consecutive double clicks seem to be fine though.

ale

2019-01-08 15:02

manager   ~0045759

i get crazy things when double clicking on the circle... but only on windows.

aiena

2019-01-08 15:19

reporter   ~0045760

I noticed on Linux the blank space available around the canvas is limited to the configured "Scratch Space" in the "Display" tab of "Document Setup". On my Windows PC panning etc. bypasses this limit and I can go beyond the scratch space. Maybe when a user has zoomed into this state then zooms back and double clicks on the object the page jump occurs.

jghali

2019-01-08 18:08

administrator   ~0045764

Some explanations: the snapshots I post on sourceforge are not always built from pure svn code. This is the case here as I have put in those snapshots since a few weeks experimental code to improve zooming. There is several modifications vs svn code:
- always center zoom on clicked point when user click on canvas (was not always the case previously)
- same when zooming out, previously canvas was often offset in the process
- resize scratch space more dynamically, previously item could be created outside scratch space, but they were invisible in this case, or creation could fail

I have already fixes for this issue. However due to a somewhat flacky connection in the place where I am now, I may be able to post new snapshots only Sunday or next week

aiena

2019-01-10 06:50

reporter   ~0045765

Hi jghali. Can you let me know when you have a good 1.5.5svn build. I need a windows compatible build of Scribus as using a VM is pretty tedious performance wise. I need 1.5.5 because of it's RTL support. I'll download that specific version.

ale

2019-01-10 08:03

manager   ~0045766

@aiena 1.5.4 does support RTL... and I really think that the 1.5.4 releases are "clean" builds...

@jghali would be possible to write somewhere what is in the snapshot .exe (when they are not the same as the trunk, of course)?

both aiena and me lost several hours tracking that bug... knowing that you were experimenting with that code would have been very helpful!

aiena

2019-01-13 03:11

reporter   ~0045772

Please close this issue as I cannot reproduce it in my built from source Scribus 1.5.5svn. I succeded in building from soruce for Windows as the linux VM installed Scribus performance was terrible.

jghali

2019-01-13 15:37

administrator   ~0045780

New Windows snapshots are now available:
https://sourceforge.net/projects/scribus/files/scribus-svn/1.5.5.svn/

Issue History

Date Modified Username Field Change
2019-01-07 14:16 aiena New Issue
2019-01-07 14:20 jghali Product Version 1.5.4 => 1.5.5.svn
2019-01-07 17:49 ale Note Added: 0045753
2019-01-08 06:48 aiena Note Added: 0045754
2019-01-08 14:10 Luna Nightshade Note Added: 0045757
2019-01-08 15:02 ale Note Added: 0045759
2019-01-08 15:19 aiena Note Added: 0045760
2019-01-08 18:08 jghali Note Added: 0045764
2019-01-10 06:50 aiena Note Added: 0045765
2019-01-10 08:03 ale Note Added: 0045766
2019-01-13 03:11 aiena Note Added: 0045772
2019-01-13 13:13 jghali Assigned To => jghali
2019-01-13 13:13 jghali Status new => resolved
2019-01-13 13:13 jghali Resolution open => fixed
2019-01-13 13:13 jghali Fixed in Version => 1.5.5.svn
2019-01-13 15:37 jghali Note Added: 0045780
2019-06-04 20:55 cbradney Status resolved => closed