View Issue Details

IDProjectCategoryView StatusLast Update
0015546ScribusPlug-inspublic2019-06-04 20:55
Reporterale Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.5.5.svn 
Target VersionFixed in Version1.5.5.svn 
Summary0015546: cannot add plugins to some of the menus
Descriptioni manage to add plugins to "insert" and "extras", but i cannot add them -- as an example -- to "help".

i've tried to track PluginManager::setupPluginActions and MenuManager::addMenuItemStringAfter but i could not figure out what could be wrong.

adding a pluing in help, after tooltips get's into addMenuItemStringAfter(), but the action does not how up in the menus.

this is my current setup for the menu:

    m_actionInfo.name = "ActionSearch";
    // Action text for menu, including accel
    m_actionInfo.text = tr("&Action Search");
    m_actionInfo.menu = "Help";
    m_actionInfo.menuAfterName = "Tooltips";
    m_actionInfo.enabledOnStartup = false;
    m_actionInfo.needsNumObjects = -1;
TagsNo tags attached.
PatchNo

Activities

jghali

2019-01-21 14:45

administrator   ~0045836

Try to add following lines at the end of PluginManager::setupPluginActions(ScribusMainWindow *mw):
mw->scrMenuMgr->clearMenu("Help");
mw->scrMenuMgr->addMenuItemStringstoMenuBar("Help", mw->scrActions);

jghali

2019-01-23 02:07

administrator   ~0045838

Fixed. One important information tho, the string to use for m_actionInfo.menuAfterName is not the English string, but the internal name of the menu. So in your case, the proper code should not be:
m_actionInfo.menuAfterName = "Tooltips";
but
m_actionInfo.menuAfterName = "helpTooltips";
See ActionManager::initHelpMenuActions()

ale

2019-01-23 08:01

manager   ~0045839

ok, thanks!

it was not practical yet for me to test the lines above, since i'm in the middle of code changes and i did not want to change branch (nor commit).
i will test it today or tomorrow!

Issue History

Date Modified Username Field Change
2019-01-21 13:27 ale New Issue
2019-01-21 14:45 jghali Note Added: 0045836
2019-01-23 02:07 jghali Assigned To => jghali
2019-01-23 02:07 jghali Status new => resolved
2019-01-23 02:07 jghali Resolution open => fixed
2019-01-23 02:07 jghali Fixed in Version => 1.5.5.svn
2019-01-23 02:07 jghali Note Added: 0045838
2019-01-23 08:01 ale Note Added: 0045839
2019-06-04 20:55 cbradney Status resolved => closed