View Issue Details

IDProjectCategoryView StatusLast Update
0015607ScribusGraphics / Image Framespublic2019-12-08 21:24
Reporterale Assigned Toale  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.5.5.svn 
Target VersionFixed in Version1.5.6.svn 
Summary0015607: Image quality preview settings in the context menu are not mutually exclusive
Description"normal resolution" is checked by default.

if i check "full resolution", both are checked.

only the latest that has been picked should be checked.
Tagspatch
PatchYes

Activities

ale

2019-08-28 12:51

manager   ~0046557

here it is

actionmanager.diff (1,351 bytes)
diff --git a/scribus/actionmanager.cpp b/scribus/actionmanager.cpp
index 45e21117c..69c86f39b 100644
--- a/scribus/actionmanager.cpp
+++ b/scribus/actionmanager.cpp
@@ -472,6 +472,12 @@ void ActionManager::initItemMenuActions()
 	name="itemPDFFieldProps";
 	scrActions->insert(name, new ScrAction("", defaultKey(name), mainWindow));
 
+	itemPreviewGroup =new QActionGroup(this);
+	itemPreviewGroup->setExclusive(true);
+	(*scrActions)["itemPreviewLow"]->setActionGroup(itemPreviewGroup);
+	(*scrActions)["itemPreviewNormal"]->setActionGroup(itemPreviewGroup);
+	(*scrActions)["itemPreviewFull"]->setActionGroup(itemPreviewGroup);
+
 	(*scrActions)["itemImageIsVisible"]->setToggleAction(true);
 	(*scrActions)["itemPreviewFull"]->setToggleAction(true);
 	(*scrActions)["itemPreviewNormal"]->setToggleAction(true);
diff --git a/scribus/actionmanager.h b/scribus/actionmanager.h
index f0b03f823..fff8ac3b6 100644
--- a/scribus/actionmanager.h
+++ b/scribus/actionmanager.h
@@ -117,6 +117,7 @@ class SCRIBUS_API ActionManager : public QObject
 		UndoManager *undoManager {nullptr};
 		IconManager& im;
 		QMap<QString, QPointer<ScrAction> > *scrActions {nullptr};
+		QActionGroup* itemPreviewGroup;
 		QMultiHash<QString, QActionGroup*> *scrActionGroups {nullptr};
 		QStringList *modeActionNames {nullptr};
 		QStringList *nonEditActionNames {nullptr};
actionmanager.diff (1,351 bytes)

PeterBenedek

2019-08-29 03:56

developer   ~0046565

Tested in r23167; Linux Mint 19; Qt 5.12.0

I can't reproduce anymore. Works well.
Thanks ale.

Issue History

Date Modified Username Field Change
2019-03-18 14:59 ale New Issue
2019-03-18 15:55 jghali Summary image qualite preview settings in the context menu are not mutually exclusive => image quality preview settings in the context menu are not mutually exclusive
2019-08-28 12:50 ale Summary image quality preview settings in the context menu are not mutually exclusive => [PATCH] image quality preview settings in the context menu are not mutually exclusive
2019-08-28 12:50 ale Patch No => Yes
2019-08-28 12:51 ale File Added: actionmanager.diff
2019-08-28 12:51 ale Note Added: 0046557
2019-08-28 12:51 ale Tag Attached: patch
2019-08-28 13:39 jghali Summary [PATCH] image quality preview settings in the context menu are not mutually exclusive => Image quality preview settings in the context menu are not mutually exclusive
2019-08-28 13:41 jghali Assigned To => ale
2019-08-28 13:41 jghali Status new => resolved
2019-08-28 13:41 jghali Resolution open => fixed
2019-08-28 13:41 jghali Fixed in Version => 1.5.6.svn
2019-08-29 03:56 PeterBenedek Note Added: 0046565
2019-12-08 21:24 cbradney Status resolved => closed