View Issue Details

IDProjectCategoryView StatusLast Update
0015616ScribusImport / Exportpublic2019-06-04 20:55
Reportersonejostudios Assigned Tojghali  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version1.5.4 
Target VersionFixed in Version1.5.5.svn 
Summary0015616: After importing PDF created by imagemagick, scribus saves corrupt .sla files
DescriptionLoading a PDF file into scribus works fine. Saving this opened project as .sla file works fine, but if one try to open this .sla file, the following error pops up:

An error occurred while parsing file at line 3, column 645 :
Unexpected ''.

and no file is loaded.

Interesting fact: this seems to happen only with pdf made by imagemagick (convert).
I tried to create a pdf file with libreoffice and img2pdf, everything is okay, the .sla file opens after saving.

This might be a bug in imagemagick, but, since scribus opens the file correctly, why is it not able to save it properly?
Steps To Reproduce1. create a pdf made of pictures using imagemagick: convert *.jpg output.pdf
2. open this pdf file with scribus
3. save it as .sla file
4. try to open this .sla file, the error message is poping up.
Tagsimport, open, PDF, save
PatchNo

Activities

sonejostudios

2019-03-26 19:53

reporter  

Scribus 1.5.4_031.png (67,331 bytes)
Scribus 1.5.4_031.png (67,331 bytes)

jghali

2019-03-26 20:21

administrator   ~0046044

You will need to provide us a sample PDF which triggers this issue. Without it, we won't be able to provide much help. Nowadays most of the development is done outside of Linux environment. So imagemagick is not something I have at hand or even want to install on my computer.

sonejostudios

2019-03-26 23:00

reporter   ~0046046

Here a .pdf file and the sla file, after opening the pdf in scribus and saving it.

outsize.pdf (173,307 bytes)
outsize.sla (1,461,001 bytes)

jghali

2019-03-26 23:22

administrator   ~0046047

The PDF produce by imagemagick is apparently broken. The document title is stored incorrectly in the PDF:
/Title (þÿ<NUL>o<NUL>u<NUL>t<NUL>s<NUL>i<NUL>z<NUL>e<NUL><NUL>)

This way of storing a unicode string is incorrect. The proper syntax in this case would be:
/Title <FEFF006F0075007400730069007A0065>

jghali

2019-03-26 23:51

administrator   ~0046048

I added a small workaround to fix this issue. On our side, the issue is fixed. It would be good to report the PDF syntax bug to imagemagick too.

sonejostudios

2019-03-27 18:58

reporter   ~0046049

thanks!

the bug is reported to imagemagick here: https://imagemagick.org/discourse-server/viewtopic.php?f=3&t=35741

Issue History

Date Modified Username Field Change
2019-03-26 19:53 sonejostudios New Issue
2019-03-26 19:53 sonejostudios File Added: Scribus 1.5.4_031.png
2019-03-26 19:53 sonejostudios Tag Attached: import
2019-03-26 19:53 sonejostudios Tag Attached: PDF
2019-03-26 19:53 sonejostudios Tag Attached: open
2019-03-26 19:53 sonejostudios Tag Attached: save
2019-03-26 20:21 jghali Note Added: 0046044
2019-03-26 23:00 sonejostudios File Added: outsize.pdf
2019-03-26 23:00 sonejostudios File Added: outsize.sla
2019-03-26 23:00 sonejostudios Note Added: 0046046
2019-03-26 23:22 jghali Note Added: 0046047
2019-03-26 23:48 jghali Summary After importing a pdf-file scribus saves corrupt .sla files => After importing PDF created by imagemagick, scribus saves corrupt .sla files
2019-03-26 23:51 jghali Assigned To => jghali
2019-03-26 23:51 jghali Status new => resolved
2019-03-26 23:51 jghali Resolution open => fixed
2019-03-26 23:51 jghali Fixed in Version => 1.5.5.svn
2019-03-26 23:51 jghali Note Added: 0046048
2019-03-27 18:58 sonejostudios Note Added: 0046049
2019-06-04 20:55 cbradney Status resolved => closed