View Issue Details

IDProjectCategoryView StatusLast Update
0015631ScribusInternalpublic2019-06-04 20:55
Reporterale Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Product Version1.5.5.svn 
Target VersionFixed in Version1.5.5.svn 
Summary0015631: make StyleSet::getDefault() const
Descriptionin scribus/styles/styleset.h it should be

STYLE* getDefault() const { return m_default; }

instead of

STYLE* getDefault() const { return m_default; }

currently, getDefault() is not in use, but StyleSet is often const and and if one tries to use getDefault on one of them, the compilers complaines about the loss of constness.
TagsNo tags attached.
PatchNo

Relationships

related to 0015629 closedjghali Calling createCharStyle() with no arguments creates a style with a font size of 200 pt 

Activities

jghali

2019-04-04 19:03

administrator   ~0046069

I did it in a slightly different way so as to be consistent with StyleSet::operator[]

ale

2019-04-05 08:12

manager   ~0046072

@jghali, i'm checking if that works better.

but since getDefault() is const, is there any reason why you don't want to make it const?

Issue History

Date Modified Username Field Change
2019-04-04 13:18 ale New Issue
2019-04-04 13:46 jghali Category - => Internal
2019-04-04 14:12 ale Relationship added related to 0015629
2019-04-04 19:02 jghali Summary make StyleSet::getDefault const => make StyleSet::getDefault() const
2019-04-04 19:03 jghali Note Added: 0046069
2019-04-04 19:03 jghali Assigned To => jghali
2019-04-04 19:03 jghali Status new => resolved
2019-04-04 19:03 jghali Resolution open => fixed
2019-04-04 19:03 jghali Fixed in Version => 1.5.5.svn
2019-04-05 08:12 ale Note Added: 0046072
2019-06-04 20:55 cbradney Status resolved => closed