View Issue Details

IDProjectCategoryView StatusLast Update
0015633ScribusTranslationpublic2019-04-13 19:08
Reportermilo Assigned Tocbradney  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version1.5.4.svn 
Summary0015633: Help needed for croatian qm file
DescriptionLately I've been translating Scribus into croatian on Transifex.
Now, that most is finished, I'd like to test it on my local MacOS X 10.11.6 computer with Scribus 1.4.8.

I need somebody to generate the qm file for me – I'm not a programmer :(
Either attach it to this issue, or let it be generate on github – I can fetch it from there.
When I have the file, I would place it in the following folder:
/Applications/Scribus.app/Contents/share/scribus/translations/..
Is this the right place for the file?

Thank you.
TagsNo tags attached.
PatchNo

Activities

jghali

2019-04-06 20:08

administrator   ~0046079

I cannot provide much help myself as I do not use Transifex at all. The first thing we would need is a translation file in Qt .ts format.

milo

2019-04-06 23:30

reporter   ~0046080

This is the .ts-file I could download from Transifex.
Doesn't the Scribus project "import" translations from Transifex? Sorry, I don't know how the process is defined for Scribus.

for_use_scribus_scribus_hr_HR.ts (1,863,365 bytes)

jghali

2019-04-07 13:25

administrator   ~0046081

Last edited: 2019-04-07 13:27

View 2 revisions

Looking at the content of your ts file, the strings correspond to strings used by the 1.5.x development tree, ie trunk, not to 1.4.x strings. So they won't work well with 1.4.8, especially in preferences and properties palette.

Scribus imports translation strings from Transifex but that's only true for 1.5.x. The strings for 1.4.x should be retrieved directly from svn:
https://www.scribus.net/websvn/listing.php?repname=Scribus&path=%2Fbranches%2FVersion14x%2FScribus%2Fresources%2Ftranslations%2Fpo%2F&

Note that 1.4.8 has currently no translation for Croatian.So you would probably need to start from an already existing ts file, for example scribus.en_US.ts, copy and rename it to scribus.hr.ts, and from there do your translation work in Qt Linguist.

Anyway, here is a qm file converted from the ts file you uploaded (I did that with Qt Linguist too).



scribus.hr_HR.qm (858,727 bytes)

milo

2019-04-07 16:38

reporter   ~0046085

Thank you for the file! I understand that I'm working with a 1.5 translation in an 1.4.8 Scribus environment, so not everything will work properly.

Now, there is another issues:
- the file "sribus.hr_HR.qm" doesn't work, when placed in the application's folder (I'm on a MacOSX) - the croatian language does not appear in the pull-down menu in Scribus settings
- I removed the "_HR" coutry code from the filename ("sribus.hr.qm"), restarted Scribus, and croatian is there and works
- this "Error" could be because, in the original translateable strings there is only a string called "Croatian" - there is no string called "Croatian (Croatia)". For other languages there are such strings with country codes (i.e. "English (Canadian)", "English (UK)", "English (USA)", ...)

milo

2019-04-07 16:39

reporter   ~0046086

I could do the following:

1. Request a „Croatian” language for Scribus 1.4 at Transifex. Hopefully someone can copy all of my translated text from 1.5 into the file for 1.4. Obviously, 1.5-strings which do not exist in 1.4 wouldn’t be taken.

2. Request a separate „Croatian” language for Scribus (1.5) at Transifex - or even better, request to RENAME the existing „Croatian (Croatia)” to simple „Croatian”. IMO, the „Croatian (Croatia)” is actually not needed anyway.

Is this something you can do, or can you inform others? I’m no programmer, btw. So i can’t realy help out.

milo

2019-04-07 16:51

reporter   ~0046087

I forgott to mention, I do not translate with "Qt Linguist".
Before I do the above mentioned, I will try "Qt Linguist" and see how far I get.

milo

2019-04-10 19:01

reporter   ~0046108

I have now 2 croatian versions translated with "Qt Linguist".

=> 1) Scribus (1.5) with language "hr_HR"
The translation is on "Transifex". The translation is as complete as complete as it gets – all source strings are translated, except for 451 diverse languages (most of them I've never heard of, and don't know how to translate them).

As mentioned in one of my former messages :
I'd like to request a NEW „Croatian” (hr) language for Scribus (1.5) at Transifex – and at the same time to REMOVE the existing „Croatian (Croatia)”. The „Croatian (Croatia)” is actually not needed at all.

=> 2) Scribus 1.4 with language "hr"
The translation is 100 % complete and set with language "hr". (please do not change the language to "hr_HR", Scribus doesn't handle it – see my previous message from 2019-04-07 16:38)


If it's true, that the version 1.4 isn't retrieved from "Transifex", can someone place the attached file to the appropriate translation/po folder within the "websvn" (as jghali commented in an above message). I usually operate through GitHub, but in the case of Scribus, there isn't much recent action over there, and I do not know how to operate through www.scribus.net/websvn.

scribus.hr.ts (1,254,241 bytes)

jghali

2019-04-10 20:55

administrator   ~0046110

Thanks, I've committed your 1.4.x translation to 1.4.x branch. Unfortunately I cannot help with Transifex as I do not have any real contact with the Transifex guys.

milo

2019-04-10 22:02

reporter   ~0046112

Thank you Jean,
how soon is the croatian version going to be incorporated into the Scribus package – 1.5.x or 1.6?

Two more questions:
- can you tell me who I should contact about transifex – especially about the "hr_HR" issue. The only person I can contact is the croatian coordinator, who isn't really quick in responding – or maybe I'm just to impatient :-)

- I'd like to update the current "template" xml files and add the croatian one. Do I have to report a buck for each of them through Mantis? Or is there a system like GitHub where I could add my changes? I don't understand how WebSVN works.

cbradney

2019-04-10 22:08

administrator   ~0046113

Transifex has been updated for 1.5.x and TS files recommitted

milo

2019-04-10 22:25

reporter   ~0046114

OK, so just some additional strings.
Who can help me out with the "hr_HR" => "hr" problem, mentioned in the above messages??

milo

2019-04-13 00:27

reporter   ~0046122

MY ISSUE CAN BE CLOSED! Thank you.
I have installed Scribus 1.5.4 and the "hr_HR" works fine.

I've also downloaded the updated 1.5.x TS file from Transifex. Now that I do use "Qt Linguist", I'm finishing the "hr_HR" translation locally, including simentaniously testing it with Scribus 1.5.4. When done, I'll upload it back to Transifex.

Issue History

Date Modified Username Field Change
2019-04-05 00:28 milo New Issue
2019-04-06 20:08 jghali Note Added: 0046079
2019-04-06 23:30 milo File Added: for_use_scribus_scribus_hr_HR.ts
2019-04-06 23:30 milo Note Added: 0046080
2019-04-07 13:25 jghali File Added: scribus.hr_HR.qm
2019-04-07 13:25 jghali Note Added: 0046081
2019-04-07 13:27 jghali Note Edited: 0046081 View Revisions
2019-04-07 16:38 milo Note Added: 0046085
2019-04-07 16:39 milo Note Added: 0046086
2019-04-07 16:51 milo Note Added: 0046087
2019-04-10 19:01 milo File Added: scribus.hr.ts
2019-04-10 19:01 milo Note Added: 0046108
2019-04-10 20:55 jghali Note Added: 0046110
2019-04-10 22:02 milo Note Added: 0046112
2019-04-10 22:08 cbradney Note Added: 0046113
2019-04-10 22:25 milo Note Added: 0046114
2019-04-13 00:27 milo Note Added: 0046122
2019-04-13 19:08 cbradney Assigned To => cbradney
2019-04-13 19:08 cbradney Status new => closed
2019-04-13 19:08 cbradney Resolution open => fixed
2019-04-13 19:08 cbradney Fixed in Version => 1.5.4.svn