View Issue Details

IDProjectCategoryView StatusLast Update
0015640ScribusStory Editor / Text Framespublic2019-04-09 08:57
Reporterizaius Assigned Tojghali  
PriorityhighSeverityfeatureReproducibilityalways
Status closedResolutionduplicate 
PlatformAMD64OSLinuxOS VersionOpenSuSE 10.2
Product Version1.5.4 
Target VersionFixed in Version 
Summary0015640: Wish: generate TOC from paragraph styles
DescriptionThe current TOC editor unfortunately isn't very useful for me. I want to use Scribus to create book layouts, where text may flow between frames as adjustments are made. Thus, text headings (which appear in the TOC) can also flow from one frame to another, and marking a frame as a TOC item is not sufficient, because I do not know which frame a heading will end up in.

Therefore, I'd like to see the TOC generator functionality extended to be able to extract TOC information from paragraph styles - in particular, to be able to mark a particular paragraph style as "include in TOC", and then all paragraphs that get assigned this particular style (a Heading one) would get added to the TOC, with their page number included.

To my understanding, the current TOC generator is not able to do this.

/ Tomas
TagsNo tags attached.
PatchNo

Relationships

duplicate of 0005975 new Wish: generate TOC from paragraph styles 

Activities

ale

2019-04-09 07:58

manager   ~0046094

i'm slowly working on this:

https://github.com/aoloe/scribus-plugin-tableofcontents

collaboration is welcome...

jghali

2019-04-09 08:57

administrator   ~0046096

No need to clone an issue. That just make it a duplicate.

Issue History

Date Modified Username Field Change
2019-04-09 02:47 izaius New Issue
2019-04-09 02:47 izaius Issue generated from: 0005975
2019-04-09 02:47 izaius Relationship added child of 0005975
2019-04-09 07:58 ale Note Added: 0046094
2019-04-09 08:57 jghali Assigned To => jghali
2019-04-09 08:57 jghali Status new => resolved
2019-04-09 08:57 jghali Resolution open => duplicate
2019-04-09 08:57 jghali Note Added: 0046096
2019-04-09 08:57 jghali Relationship replaced duplicate of 0005975
2019-04-09 08:57 jghali Status resolved => closed