View Issue Details

IDProjectCategoryView StatusLast Update
0015713ScribusGraphics / Image Framespublic2019-06-17 10:10
ReporterJLuc Assigned ToJLuc  
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
PlatformLinuxOSUbuntu OS Version18.04
Product Version1.5.5 
Target VersionFixed in Version 
Summary0015713: Provide new "fixed viewport" image resize mode
DescriptionWhen the interesting part of an image is a small part of the image, we resize it and the image frame so as to display the interesting part of the image in the requested size and shape frame. Once this is done, it's frequent to have to adjust the size of the frame so as to fit layout, but without changing what is seen in the frame :
keep displayed content but different size = resize the frame but still have it display the same part of the image.
Doing this requires to
1) change frame size. But doing so there is no way to get a measure of know how much we changed. Or take tiedous notes of sizes before and after and compute the size ratio.
2) to achieve desired goal (same view, different size) we have to apply computed ratio to contained image
3) apply some translation to the image inside its frame so as to restore initial viewport to new scale

Request is : Provide a new "fixed viewport" mode.
With "fixed viewport", when resizing frame, the contained image is also automaticaly resized and translated when required.
In this mode, when frame is resized from 100% to x%, Xpos and Ypos and scaleX and scaleY of image within frame should also be altered with this x% ratio

TagsNo tags attached.
PatchNo

Relationships

related to 0015560 assignedale [PATCH (needs review)] fill a frame with the image 
related to 0015448 assignedale [PATCH] when an image is set to fit the frame, it should just fit it 
related to 0010992 newcbradney display possible keyboard modifiers for current action 

Activities

ale

2019-06-17 07:58

manager   ~0046308

that seems to be already working: just press ctrl and alt when resizing the image to keep the proportion and get scribus to also scale the content.

JLuc

2019-06-17 10:08

developer   ~0046313

Yes indeed.

JLuc

2019-06-17 10:09

developer   ~0046314

Keyboard modifier to achieve this exists.
0010992 requests to have a hint about it displayed.

Issue History

Date Modified Username Field Change
2019-06-14 17:55 JLuc New Issue
2019-06-14 17:56 JLuc Description Updated View Revisions
2019-06-14 17:56 JLuc Relationship added related to 0015560
2019-06-14 17:56 JLuc Relationship added related to 0015448
2019-06-14 17:58 JLuc Description Updated View Revisions
2019-06-17 07:58 ale Note Added: 0046308
2019-06-17 10:08 JLuc Note Added: 0046313
2019-06-17 10:09 JLuc Assigned To => JLuc
2019-06-17 10:09 JLuc Status new => closed
2019-06-17 10:09 JLuc Resolution open => fixed
2019-06-17 10:09 JLuc Note Added: 0046314
2019-06-17 10:10 JLuc Relationship added related to 0010992