View Issue Details

IDProjectCategoryView StatusLast Update
0015764ScribusInternalpublic2019-08-10 02:25
Reporterale Assigned Tojghali  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version1.5.6.svn 
Summary0015764: Warning in fparser.cc
Description../scribus/third_party/fparser/fparser.cc: In member function ‘const char* FunctionParser::CompileAddition(const char*)’:
../scribus/third_party/fparser/fparser.cc:1628:21: warning: this ‘if’ clause does not guard... [-Wmisleading-indentation]
                     if(!is_unary) data->ByteCode.push_back(cAdd); break;

should probably be fixed other fparser updated to a version that fixes this...
TagsNo tags attached.
PatchNo

Activities

jghali

2019-08-10 02:25

administrator   ~0046451

No bug, just a warning. Unfortunately we cannot upgrade fparser due to a license change in version 4.x (move to LGPL v3).

Issue History

Date Modified Username Field Change
2019-08-09 10:04 ale New Issue
2019-08-10 02:20 jghali Summary maybe bug in frparser... => Warning in fparser.cc
2019-08-10 02:25 jghali Assigned To => jghali
2019-08-10 02:25 jghali Status new => resolved
2019-08-10 02:25 jghali Resolution open => fixed
2019-08-10 02:25 jghali Fixed in Version => 1.5.6.svn
2019-08-10 02:25 jghali Note Added: 0046451
2019-08-10 02:25 jghali Category General => Internal