View Issue Details

IDProjectCategoryView StatusLast Update
0015824ScribusTypographypublic2019-09-23 09:07
Reporterranjithsiji Assigned Tojghali  
PrioritynormalSeveritytextReproducibilityalways
Status closedResolutionfixed 
PlatformGNU/LinuxOSFedora 30 / Kubuntu 19.04OS Version30
Product Version1.5.6.svn 
Target VersionFixed in Version1.5.6.svn 
Summary0015824: Removing hyphenation character in paragraph style is not working
DescriptionWhen creating a style We can remove the hyphenation chacter (We don't want a chacter to indicate the end of the hypenated line) and save the syle. But when the style is applied to a text box the default hyphenation character (-) is appearing when we hyphenate text.
Steps To Reproduce1. Create New Paragraph style
2. Remove the hypenation character (-) in Paragraph style > Character style
3. Save the Paragraph style
4. Create a text with Default style. it must be multi coloumn text
5. Apply newly created style.
6. Hyphenate text using Extras > Hyphenate
7. The removed Hypenation character (-) will appear on the right side of the hyphenated lines.

the hyphenation setting in the style is not applied to the styled text
Additional InformationWe tested this for Malayalam and English and the problem exists on 1.5.6 svn.
Tagshyphenation, typography
PatchNo

Activities

ranjithsiji

2019-09-19 21:16

reporter  

bug1.png (186,890 bytes)
bug1.png (186,890 bytes)
bug-hyphenation.gif (967,017 bytes)
bug-hyphenation.gif (967,017 bytes)

jghali

2019-09-19 23:09

administrator   ~0046678

Well in fact removing hyphenation char work for character style but does not work for paragraph style. If you remove hyphenation char in paragraph style and click "Apply", you will in fact see that the removed char comes back.

PeterBenedek

2019-09-20 19:45

developer   ~0046680

Last edited: 2019-09-20 19:46

View 2 revisions

Tested in r23203; Linux Mint 19

There is a small problem. If I delete hyphenation character in Paragraph Style, the Scribus insert a space character in the text field, but not use it.
This inserted space character not appear in the PP -- hyphenation field.

if I want to change hyphenation character in the style and I click the Apply button, this character is disappear, because of the space character.

jghali

2019-09-20 21:53

administrator   ~0046682

Well you just have to remove that "space" character and type another character.

PeterBenedek

2019-09-21 04:28

developer   ~0046683

Last edited: 2019-09-21 04:44

View 3 revisions

Ok, I understand, but space character is very thin in textfield and it is difficult to detect.I didn't think he was there, after I erased everything, It took me a while to figure out why I can't enter a new character... ...solve it the new user?

Proposal: if you click on hyphenation text field, the content of field let it be selected by default.

ale

2019-09-21 07:52

manager   ~0046685

euh, i don't know about the details, but if a field should be empty, it should not contain a space...

... a space as a hyphenation sign sounds so wrong, even if it is then ignored...

PeterBenedek

2019-09-21 08:01

developer   ~0046686

This is the problem...

PeterBenedek

2019-09-21 08:11

developer   ~0046687

during operation...
Star character will then appear, if before I deleted the unexpected space character (If I notice he's there).

disturbing_behavior.gif (952,937 bytes)
disturbing_behavior.gif (952,937 bytes)

jghali

2019-09-22 14:41

administrator   ~0046690

I did the necessary thing so that this space (which is in fact a null character) does not get displayed in the hyphenation character field. I've also took the opportunity to limit the number of character user can enter in that field to 1 as only a single char is taken into account.

PeterBenedek

2019-09-22 15:12

developer   ~0046691

Last edited: 2019-09-22 15:16

View 2 revisions

Excellent. Thanks Jean and ale.

PeterBenedek

2019-09-22 15:16

developer   ~0046692

Tested in Linux Mint 19; r23205

Works well.

ranjithsiji

2019-09-22 18:38

reporter   ~0046693

Thank you Jean, ale and PeterBenedek for finding some extra problems in that and solving them. The solution worked well for me.

Issue History

Date Modified Username Field Change
2019-09-19 21:16 ranjithsiji New Issue
2019-09-19 21:16 ranjithsiji File Added: bug1.png
2019-09-19 21:16 ranjithsiji File Added: bug-hyphenation.gif
2019-09-19 21:16 ranjithsiji Tag Attached: hyphenation
2019-09-19 21:16 ranjithsiji Tag Attached: typography
2019-09-19 23:09 jghali Note Added: 0046678
2019-09-19 23:15 jghali Summary Removing Hyphenation character in style is not working when the style is applied => Removing hyphenation character in paragraph style is not working
2019-09-19 23:27 jghali Assigned To => jghali
2019-09-19 23:27 jghali Status new => resolved
2019-09-19 23:27 jghali Resolution open => fixed
2019-09-19 23:27 jghali Fixed in Version => 1.5.6.svn
2019-09-20 19:45 PeterBenedek Note Added: 0046680
2019-09-20 19:45 PeterBenedek Status resolved => feedback
2019-09-20 19:45 PeterBenedek Resolution fixed => reopened
2019-09-20 19:46 PeterBenedek Note Edited: 0046680 View Revisions
2019-09-20 21:53 jghali Status feedback => resolved
2019-09-20 21:53 jghali Resolution reopened => fixed
2019-09-20 21:53 jghali Note Added: 0046682
2019-09-21 04:28 PeterBenedek Note Added: 0046683
2019-09-21 04:31 PeterBenedek Note Edited: 0046683 View Revisions
2019-09-21 04:44 PeterBenedek Note Edited: 0046683 View Revisions
2019-09-21 07:52 ale Note Added: 0046685
2019-09-21 08:01 PeterBenedek File Added: unexpected_space_character.gif
2019-09-21 08:01 PeterBenedek Note Added: 0046686
2019-09-21 08:11 PeterBenedek File Added: disturbing_behavior.gif
2019-09-21 08:11 PeterBenedek Note Added: 0046687
2019-09-22 14:41 jghali Note Added: 0046690
2019-09-22 15:12 PeterBenedek Note Added: 0046691
2019-09-22 15:16 PeterBenedek Note Added: 0046692
2019-09-22 15:16 PeterBenedek Note Edited: 0046691 View Revisions
2019-09-22 18:38 ranjithsiji Note Added: 0046693
2019-09-23 09:07 PeterBenedek Status resolved => closed