View Issue Details

IDProjectCategoryView StatusLast Update
0015837ScribusImport / Exportpublic2019-10-05 17:47
Reporterdavidrevoy Assigned Tojghali  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformDistro packages & Appimage-SVNOSGNU/Linux KubuntuOS Version18.04.2 LTS
Product Version1.5.6.svn 
Target VersionFixed in Version1.5.6.svn 
Summary0015837: Import of Tiff files: the default resolution unit should be "per inch"
DescriptionHi,
When importing a new tiff image on the canvas, this one appears with a resolution of 72ppi. Even if the file has Resolution.
Steps To Reproduce1. Save the test.tif file in attachement. You can test the file with Imagemagick in a terminal "$ identify -verbose test.tif | grep Resolution" → (output Resolution: 508x508)
3. Open Scribus , a A4 , drag and drop the tif on canvas.
4. The tif will appear bigger than a 2cm x 2cm box.
Additional InformationTested and reproduced in latest 15.5 appimage, 1.4.8 from Ppa package.
Tested and reproduced with other regular ppi: 300, 96, 600...
Tagsdpi, image, ppi, TIFF
PatchNo

Activities

davidrevoy

2019-10-04 13:44

reporter  

test.tif (1,602,288 bytes)

jghali

2019-10-04 23:33

administrator   ~0046734

Last edited: 2019-10-04 23:39

View 2 revisions

In fact your file does not specify if the resolution is expressed in dot per inch or dot per centimeter because the resolution unit tag is missing.

davidrevoy

2019-10-04 23:39

reporter   ~0046735

Hi @jghali. Thank you for the quick answer!
So do you think I should bug report that to Krita team?
Or is it a unit (per inch) that Scribus could assume in case missing instead of falling back to 72ppi?

jghali

2019-10-04 23:46

administrator   ~0046736

I have to check what TIFF specs says about resolution unit tag. I'll have to do that later tho as I have to quit my hotel room in a moment. I tend to think that we should probably use "per inch" unit as default. However it would be good if Krita would set the TIFF resolution unit tag properly.

davidrevoy

2019-10-04 23:52

reporter   ~0046737

Nice. No hurry, I'm not in a workflow breaker situation: I'm even using other file format as TIFF in my project right now and I'm using Scribus 1.4.8.
So, +1 for the "per inch" by default. I'll report this one to Krita.
Thanks!

jghali

2019-10-05 14:06

administrator   ~0046738

Ok, so the old TIFF specs says that the default resolution unit is indeed "per inch". So I will modify 1.5.x code to define this default value properly. I won't modify our stable 1.4.x branch however, as I fear that change may cause some document breakages.

davidrevoy

2019-10-05 17:47

reporter   ~0046739

Thank you again for having a look and fixing it in 1.5.x !
True, I totally understand for 1.4.x documents, that's wise.

Issue History

Date Modified Username Field Change
2019-10-04 13:44 davidrevoy New Issue
2019-10-04 13:44 davidrevoy File Added: test.tif
2019-10-04 13:44 davidrevoy Tag Attached: image
2019-10-04 13:44 davidrevoy Tag Attached: TIFF
2019-10-04 13:44 davidrevoy Tag Attached: dpi
2019-10-04 13:44 davidrevoy Tag Attached: ppi
2019-10-04 23:33 jghali Note Added: 0046734
2019-10-04 23:39 davidrevoy Note Added: 0046735
2019-10-04 23:39 jghali Note Edited: 0046734 View Revisions
2019-10-04 23:46 jghali Note Added: 0046736
2019-10-04 23:52 davidrevoy Note Added: 0046737
2019-10-05 14:06 jghali Note Added: 0046738
2019-10-05 14:06 jghali Summary Import of Tiff files: missing resolution/dpi/ppi => Import of Tiff files: the default resolution unit should be "per inch"
2019-10-05 14:06 jghali Steps to Reproduce Updated View Revisions
2019-10-05 14:07 jghali Assigned To => jghali
2019-10-05 14:07 jghali Status new => resolved
2019-10-05 14:07 jghali Resolution open => fixed
2019-10-05 14:07 jghali Fixed in Version => 1.5.6.svn
2019-10-05 17:47 davidrevoy Note Added: 0046739