View Issue Details

IDProjectCategoryView StatusLast Update
0015871ScribusGraphics / Image Framespublic2019-11-24 10:30
ReporterViviane Assigned Toale  
PriorityurgentSeverityfeatureReproducibilityhave not tried
Status closedResolutionfixed 
Product Version1.4.8 
Target VersionFixed in Version1.5.6.svn 
Summary0015871: pictures - path
DescriptionHi! Moving a folder with the .sla-document and all the pictures in it is impossilbe, because the document looses all the links to the pictures. So working - exchanging projects with other people is completly impossible, even cleaning up the own projects on my computer does not work. I have done a job with about 150 flyers for an non profit organisation and now I do not know, how to transfer the files to them without loosing all the picture-links. I can't even copy them to a backup-system without loosing all links.

So my urgent question: is there a possibility to define the path for all the picture of a document, to re-link all pictures in a doc at once? or to open a document and say: relink all the pictures within this folder (like in indesign).
Even if I would re-link the pictures one by one, I have to click dozens of times for each, as there is no memory for the place, where the last picture has been. I have to click from computer to user to project to subprocect to folder-for-this and folder-for-that and then I get to the right folder. This procedure has to be done for EACH picture...

Please find solutions for this. If Scribus should be an alternativ - open source- software for those who dont want to pay monthly abonnements to Adobe, it should be able to do this. Beeing a good alternative software even NGOs would like to spend some money for your developement.

Thanks and hopefully you understood my bad English.
TagsNo tags attached.
PatchNo

Relationships

related to 0009154 closedale [PATCH] Recursive search in Manage images 

Activities

Viviane

2019-10-23 18:36

reporter  

photo-links.jpeg (311,852 bytes)
photo-links.jpeg (311,852 bytes)

cbradney

2019-10-24 05:13

administrator   ~0046847

Hi

The File->Collect for Output function was built for collecting files for sharing. Have you tried this?

Also, if you need to do this in bulk, and have some scripting skills, the files can be edited programmatically to edit all paths if required.

Separately, we've considered options for localised paths (to the document) for a future version.

Craig

Viviane

2019-10-24 06:53

reporter   ~0046849

Thanks Craig!
I use the "collect for output" function, this is the only way to do it. But 150times? For each file? And what about sending documents to my partners and let them work on it and then getting it back to finish the project per mails or transferprogramm? No way... nowbody can sit hours (and several times for each document) to reconnect the links... however...
No, I have no scripting skills, sorry.
Please have a look how other programs allow you to transfere files from one place to the other and find an easy solution. Like "link again within this file" or so.... this would be great!
Thanks and best regards!
Vivi (who urgently would like to transfer her work to the NGO... )

ale

2019-10-24 07:20

manager   ~0046850

hi viviane,

for support, please come to http://forums.scribus.net (or if you speak french as your name could suggest, to https://linuxgraphic.org/forums/viewforum.php?f=20).

i can help you finding a solution to relink all the images at once (i think i have a script somewhere...)

ale

2019-10-24 16:28

manager   ~0046857

... i try to work on that...

ale

2019-10-25 17:19

manager   ~0046860

Last edited: 2019-10-26 07:06

View 3 revisions

here is a first patch:

https://gitlab.com/a.l.e/scribus/compare/master...manage-images

you can see it in action here:

https://peertube.social/videos/watch/5d853734-bc08-4ff7-a7df-8b60f1e2feba

for the next week there is an appimage:
https://gitlab.com/a.l.e/scribus/-/jobs/333413447/artifacts/file/Scribus-nightly-x86_64.AppImage

here some more details:

When changing the path of an image, it should be possible to optionally change the path in all matching images.

If the selected image has an invalid reference, only images with an invalid reference will match.

- [x] Add an "Apply to all Matching images" checkbox in `scribus/ui/picsearch.ui`
- [x] Set the image file name in the "Search" dialog (currently it says "... for search").
- [x] select the first item in the list (if any)
- [x] replace all matching
- [x] Add a warning if the "Matching" only replaces broken links.
- [ ] Add a button to the manager in the "Image" palette
- [ ] Add a tooltip for the matching checkbox
- [ ] Find out if other patter matching are useful / should be implemented

Implementation notes:

- The select button is now always enabled, since the list of matches is never empty.
- There is not a _global_ current item anymore: each function gets the item it works on.

My full notes can be found here:

https://gitlab.com/a.l.e/scribus/issues/5

ale

2019-10-25 17:21

manager   ~0046861

p.s. i will probably post the final patch in pygmee's tickets:

https://bugs.scribus.net/view.php?id=9154

Viviane

2019-11-21 17:22

reporter   ~0047110

Thanks Ale!

It took me a time to continue my tentatives, sorry for the long time passed.
I apreciate your efforts, but I confess, I am completly overchallenged.

I have no idea how to implement your script https://gitlab.com/a.l.e/scribus/compare/master...manage-images
And I do not know, how to change path like you described in this link: https://gitlab.com/a.l.e/scribus/issues/5

Is it something I should be able to or is this for future versions of scribus? Or is it to ask a person who can write software programs?

The link scribus/ui/picsearch.ui leads to the page http://www.scribus.com/ui/picsearch.ui, which can be bought...

What I would need, as a normal user ist a new version or a plugin or extention or anything, I can install without HTML codes...
Any ideas?

thanks and best regards

Viviane (not french, sorry :-)

ale

2019-11-22 08:27

manager   ~0047113

Last edited: 2019-11-22 08:35

View 2 revisions

hi @viviane ,

all the information above was not for you but for the other developers.

and i sadly forgot to upload the patch linked above... it's now done in 0009154 .

if you need further help until you can use the new feature in scribus (well, first we will need to wait for jean or craig to accept the patch...), please come to the scribus and ask there for help...

ciao
a.l.e

p.s.: no, i did not forget... but pygmee did fill two times the same issue... the patch was in 0011776 ...

ale

2019-11-24 10:30

manager   ~0047125

the patch is now in.

@viviane but if you want to use the feature you (and your clients) will need to go for the development version 1.5.6svn .

there are many people using the development version in production, but before you go for it, you should test it "thoroughly" and make sure it's good enough for you and your clients!

feel free to ask questions about it in the scribus forums (https://forums.scribus.net).

Issue History

Date Modified Username Field Change
2019-10-23 18:36 Viviane New Issue
2019-10-23 18:36 Viviane File Added: photo-links.jpeg
2019-10-24 05:13 cbradney Note Added: 0046847
2019-10-24 06:53 Viviane Note Added: 0046849
2019-10-24 07:20 ale Note Added: 0046850
2019-10-24 16:28 ale Note Added: 0046857
2019-10-25 17:19 ale Note Added: 0046860
2019-10-25 17:21 ale Note Added: 0046861
2019-10-26 07:06 ale Note Edited: 0046860 View Revisions
2019-10-26 07:06 ale Note Edited: 0046860 View Revisions
2019-11-21 17:22 Viviane Note Added: 0047110
2019-11-22 08:09 ale Relationship added related to 0009154
2019-11-22 08:27 ale Note Added: 0047113
2019-11-22 08:35 ale Note Edited: 0047113 View Revisions
2019-11-24 10:30 ale Assigned To => ale
2019-11-24 10:30 ale Status new => closed
2019-11-24 10:30 ale Resolution open => fixed
2019-11-24 10:30 ale Fixed in Version => 1.5.6.svn
2019-11-24 10:30 ale Note Added: 0047125