View Issue Details

IDProjectCategoryView StatusLast Update
0015900ScribusStory Editor / Text Framespublic2019-12-08 21:24
ReporterC.Rogers Assigned Tojghali  
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSUbuntuOS Version19.04
Product Version1.5.6.svn 
Target VersionFixed in Version1.5.6.svn 
Summary0015900: Story Editor jumps to top every time a style is changed
DescriptionIf you are scrolled down any amount from the top of the story editor, and you change a style, the editor jump all the way back up to the top, requiring the user to scroll down and try to find what last they were editing. This is a very costly bug time-wise, and severely cripples workflow. This is why I've marked the bug as major, and assigned it a high priority.
Steps To Reproduce1. make a text box with enough text to make the story editor scrollbars appear.
2. scroll down to a block of text, and change the style.

The editor jumps back up to the top once the style is changed. Working with anything more than a few paragraphs is an absolute nightmare.
Additional InformationPlease halp! :)
Thanks for your time, and dedication to making Scribus an industry grade page layout powertool.
Tagsscroll, story editor, styles, UI
PatchNo

Relationships

related to 0013525 closedjghali Content in SE jumps upward when switching between windows 

Activities

C.Rogers

2019-11-02 13:18

reporter   ~0046921

I've discovered this is actually a duplicate of this bug: https://bugs.scribus.net/view.php?id=13525
Situation is made worse by focus-follows-mouse, because you essentially have to keep the mouse over the story editor to keep it from jumping back to the top.
Also happens any time you move the window.

jghali

2019-11-03 00:21

administrator   ~0046935

0013525 is in fact related but not a duplicate.

C.Rogers

2019-11-03 00:40

reporter   ~0046936

Cool. If you can fix it, it will help me out a bunch. Thanks for your work!

Issue History

Date Modified Username Field Change
2019-11-02 13:08 C.Rogers New Issue
2019-11-02 13:08 C.Rogers Tag Attached: scroll
2019-11-02 13:08 C.Rogers Tag Attached: story editor
2019-11-02 13:08 C.Rogers Tag Attached: styles
2019-11-02 13:08 C.Rogers Tag Attached: UI
2019-11-02 13:18 C.Rogers Note Added: 0046921
2019-11-02 14:43 PeterBenedek Relationship added duplicate of 0013525
2019-11-03 00:18 jghali Relationship deleted 0013525
2019-11-03 00:18 jghali Relationship added related to 0013525
2019-11-03 00:21 jghali Assigned To => jghali
2019-11-03 00:21 jghali Status new => resolved
2019-11-03 00:21 jghali Resolution open => fixed
2019-11-03 00:21 jghali Fixed in Version => 1.5.6.svn
2019-11-03 00:21 jghali Note Added: 0046935
2019-11-03 00:40 C.Rogers Note Added: 0046936
2019-12-08 21:24 cbradney Status resolved => closed