View Issue Details

IDProjectCategoryView StatusLast Update
0015905ScribusGeneralpublic2019-11-04 08:29
Reporterale Assigned Toale  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionno change required 
Product Version1.5.6.svn 
Target VersionFixed in Version 
Summary0015905: cannot flip rotated items
Descriptionfor rotated items, the flip tools are enabled but don't act.

we should let them flip rotated items or disable them.
TagsNo tags attached.
PatchNo

Activities

jghali

2019-11-03 23:33

administrator   ~0046947

I just did a test and flipping rotated items definitely works.

utnik

2019-11-04 03:27

updater   ~0046950

yes, rotated objects can be flipped – but is it really sane behaviour that they flip around a rotated axes?
i would expect the axes to stay horizontally/vertically.

jghali

2019-11-04 08:00

administrator   ~0046951

Last edited: 2019-11-04 08:01

View 2 revisions

This is how flipping items has always worked. The way of flipping items you propose is slightly different : if using this way, the horizontal/vertical flipping state would have to stop being an item property. That would also requires some changes in the UI : the flip buttons would have to be switched to push buttons. Another drawback : changing this behavior would break existing documents.

ale

2019-11-04 08:28

manager   ~0046952

ok, thanks utnik for catching the detail!

personally, i tend to think that flipping around the rotated axes is not what the user wants.

and i also think that the rotation should not be a property, but an action...

since the feature works as designed i'll close this ticket... and open a new asking for a "real" flipping

Issue History

Date Modified Username Field Change
2019-11-03 14:37 ale New Issue
2019-11-03 23:33 jghali Note Added: 0046947
2019-11-04 00:43 jghali Category - => General
2019-11-04 03:27 utnik Note Added: 0046950
2019-11-04 08:00 jghali Note Added: 0046951
2019-11-04 08:01 jghali Note Edited: 0046951 View Revisions
2019-11-04 08:28 ale Note Added: 0046952
2019-11-04 08:29 ale Assigned To => ale
2019-11-04 08:29 ale Status new => closed
2019-11-04 08:29 ale Resolution open => no change required