View Issue Details

IDProjectCategoryView StatusLast Update
0015913ScribusFontspublic2019-11-19 09:10
ReporterNoeppes Assigned Tojghali  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
PlatformXeon 4Core 8GB RAMOSWindows 7 OS Version64bit prof.
Product Version1.5.5 
Target VersionFixed in Version 
Summary0015913: new installed or changed Font ist not useable
Description
If a font is deleted, or a new one is installed or an existing one is changed, then it can not be used in Scribus.
It is not displayed under Settings-> Fonts or in the selection window for the currently used font or can be selected there.
After installing Scribus, no changes to the usable fonts are possible. Even a new installation does not change that.
It does not matter which font I install (PS/OT/TTF)
Steps To Reproduce- Install Scribus
- Create a document
- close Scribus
- Install a new font (PS/OT/TTF)
- open Scribus and open a new document
- Try using this font in a text box
Additional InformationTestet on 3 different Workstations with Win7 64bit prof. and one VM
Tagsfont install, font selection, fonts
PatchNo

Relationships

duplicate of 0013630 resolvedjghali Add Registry support for fonts in Windows 

Activities

jghali

2019-11-04 23:27

administrator   ~0046961

Unable to reproduce, works here.

ale

2019-11-05 06:54

manager   ~0046963

that's probably a windows issue.

there are a few ways to install fonts in windows and not not all of them work for every program. it depends on how each program detects the fonts.

as far as i know, this is even worse in windows 10, where only one way of adding fonts will work for most multiplatform programs.

Noeppes

2019-11-05 12:29

reporter   ~0046971

Here we use typeface Typograf without (in the last 5 years) problems. Typographer uses the Windows Install Font feature and inserts the font into the Windows font database and copies it to the Windows Font folder.
There is also the possibility to temporarily install fonts by telling Windows that the font file can be found in a directory other than the default one. I have not tested the latter yet.

ale

2019-11-05 12:55

manager   ~0046972

on linux and macos scribus is able to use fonts that are not installed in the system.
this should also be possible for windows.

just put he fonts in a directory and and that directory to the scribus fonts preferences.

if i understood it correctly, jghali is looking into the font registry. it might be, that in the near future, scribus will play nicely with typograf... who knows?

jghali

2019-11-17 04:44

administrator   ~0047092

Closing as it is most likely a duplicate of issue 0013630

ale

2019-11-17 11:50

manager   ~0047097

i would be interested to know if @Noeppes can now use Typograf with Scribus...

@jghali , as soon as you have a "normal" internet connection, can you please upload a windows snapshot and notify this ticket so that he / she can test it?

Noeppes

2019-11-19 07:52

reporter   ~0047103

Closed? - Really?
After this age-old bug, the Windows font system is not fully supported. So Scribus is NOT fully usable on Windows - and you know it and still advertise it. So such a behavior I know so far only from QuarkXPress. We are looking for a working alternative but Scribus is, just like years ago. still not. If basic features are not supported ...
And if you get into Scribus, test a lot of things, report these mistakes, and then handle them with a reference to a 3-year-old bug (really, 3 years old, what the ...). Since one understands the help seemingly not wanted - where I am not wanted I go.

@ale
No, Typograf is not working correctly.

ale

2019-11-19 08:10

manager   ~0047104

@noeppes , i think that you missed something.

jean has fixed 0013630 and with it, he has probably fixed your issue too.

you say that typograf still does not work correctly, but there is little chance that you have compiled yourself the newest scribus code on your machine and jean is still locked in a (almost) dead spot and can't upload a new exe snapshot.

would you mind waiting for a new exe to show up in https://sourceforge.net/projects/scribus/files/scribus-svn/1.5.6.svn/ and then test if scribus now works correctly with typograph?

ale

2019-11-19 09:00

manager   ~0047105

p.s.: @noeppes despite the sometimes triumphal tone of at least one scribus person, scribus is imo still not the "comfortable" choice for page layout.
there are very good reasons for using it, but if you want to go the easy way, there are other tools that will be more pleasant for you.

personally, i'm working hard to improve some "important" roughness, but there is a long way to go, before i can suggest scribus to somebody who just wants things done.

Issue History

Date Modified Username Field Change
2019-11-04 21:38 Noeppes New Issue
2019-11-04 21:38 Noeppes Tag Attached: font install
2019-11-04 21:38 Noeppes Tag Attached: font selection
2019-11-04 21:38 Noeppes Tag Attached: fonts
2019-11-04 23:27 jghali Note Added: 0046961
2019-11-05 00:28 jghali Priority high => normal
2019-11-05 06:54 ale Note Added: 0046963
2019-11-05 12:29 Noeppes Note Added: 0046971
2019-11-05 12:55 ale Note Added: 0046972
2019-11-17 04:44 jghali Assigned To => jghali
2019-11-17 04:44 jghali Status new => resolved
2019-11-17 04:44 jghali Resolution open => duplicate
2019-11-17 04:44 jghali Note Added: 0047092
2019-11-17 04:44 jghali Relationship added duplicate of 0013630
2019-11-17 04:45 jghali Status resolved => closed
2019-11-17 11:50 ale Note Added: 0047097
2019-11-19 07:52 Noeppes Status closed => feedback
2019-11-19 07:52 Noeppes Resolution duplicate => reopened
2019-11-19 07:52 Noeppes Note Added: 0047103
2019-11-19 08:10 ale Note Added: 0047104
2019-11-19 09:00 ale Note Added: 0047105
2019-11-19 09:10 jghali Status feedback => resolved
2019-11-19 09:10 jghali Resolution reopened => duplicate
2019-11-19 09:10 jghali Status resolved => closed