View Issue Details

IDProjectCategoryView StatusLast Update
0015946ScribusGeneralpublic2019-12-08 21:24
Reporterarko Assigned Tojghali  
PrioritynormalSeveritymajorReproducibilityhave not tried
Status closedResolutionfixed 
PlatformAMDOSLinuxOS Versionarch
Product Version1.5.5 
Target VersionFixed in Version1.5.6.svn 
Summary0015946: File size increase
Descriptionthe file size of my document did increase every time - now a document with some 120 pages has a size of the sla of 9.3MB which results in loading time of about 15 minutes and a memory load once done of 3.2GB
the size increased first slowly, with the latest savings in larger steps (I'm kind of sure not to bind pictures to the document, thus e.g. the latest changes mainly doing hyphenation and few pictures should come with this change in size):
27.10.2019 20:22 683.260 chronik-v10e.sla
29.10.2019 20:27 694.485 chronik-v10f.sla
29.10.2019 21:15 720.003 chronik-v10g.sla
29.10.2019 22:08 785.058 chronik-v10h.sla
30.10.2019 19:30 792.571 chronik-v10i.sla
30.10.2019 20:52 1.049.818 chronik-v10j.sla
02.11.2019 20:40 1.146.292 chronik-v10n.sla
03.11.2019 20:26 1.235.473 chronik-v10o.sla
03.11.2019 21:13 1.235.492 chronik-v10p.sla
08.11.2019 22:17 1.396.899 chronik-v10q.sla
09.11.2019 20:31 1.672.171 chronik-v10r.sla
09.11.2019 21:55 2.228.425 chronik-v10s.sla
10.11.2019 21:20 3.324.420 chronik-v10t.sla
11.11.2019 20:07 5.488.688 chronik-v10u.sla
11.11.2019 20:58 5.486.438 chronik-v10v.sla
12.11.2019 20:29 9.817.031 chronik-v10w.sla

Thus I had done a 3-way comparison of the sla version q/r/s - and to me it looks like a large block is being added again and again (recursion?)
Steps To Reproducehmm - I guess when saving the next version it will increase again, but then it will become difficult to continue working on that project
TagsNo tags attached.
PatchNo

Activities

arko

2019-11-14 08:48

reporter  

scrib-3way.jpg (720,174 bytes)
scrib-3way.jpg (720,174 bytes)

ale

2019-11-14 09:46

manager   ~0047074

generally speaking, it's better not to embed the images in the .sla.

can you please provide the .sla file so that somebody can look at the diffs?

you can mark this ticket as private, if you don't want the files to be world readable.

arko

2019-11-14 09:55

reporter   ~0047075

sorry that I might have written badly - I think I have no embedded images

arko

2019-11-14 10:11

reporter  

ticket-0015946.zip (1,007,451 bytes)

jghali

2019-11-14 21:20

administrator   ~0047080

Last edited: 2019-11-14 21:21

View 2 revisions

Ooops, for some reason there is a link between a textframe from masterpage chronik-abt-l and a frame from a normal page. This is what triggers this issue.

To workaround the issue:
- open your document
- edit masterpage chronij-abt-l
- select text frame whose text begins by "Offen für alle Bevölkerungskreise"
- Item -> Text Frame Links -> Unlink Text Frames (or Unlink Text Frames and Cut Text)
- save your document

arko

2019-11-15 07:47

reporter   ~0047083

wanted to report today that it was reproducable by saving the latest version (9MB) under new name so the file size did increase to 17MB. But to see now you analyzed already, provided fix and workaround - GREAT!

Issue History

Date Modified Username Field Change
2019-11-14 08:48 arko New Issue
2019-11-14 08:48 arko File Added: scrib-3way.jpg
2019-11-14 09:46 ale Note Added: 0047074
2019-11-14 09:55 arko Note Added: 0047075
2019-11-14 10:10 arko File Added: scribus-0015946.zip
2019-11-14 10:11 arko File Deleted: scribus-0015946.zip
2019-11-14 10:11 arko File Added: ticket-0015946.zip
2019-11-14 21:20 jghali Note Added: 0047080
2019-11-14 21:21 jghali Note Edited: 0047080 View Revisions
2019-11-14 21:27 jghali Summary file size increase => File size increase
2019-11-14 21:29 jghali Assigned To => jghali
2019-11-14 21:29 jghali Status new => resolved
2019-11-14 21:29 jghali Resolution open => fixed
2019-11-14 21:29 jghali Fixed in Version => 1.5.6.svn
2019-11-15 07:47 arko Note Added: 0047083
2019-12-08 21:24 cbradney Status resolved => closed